Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: After suspend/sleep can't login

  1. #1

    Default After suspend/sleep can't login

    Hey anyone.

    I have problem, when my opensuse desktop 13.1 suspend > sleep or lockscreen I can't to login, the form of login is lose.

    How to fix it? I was try upgrade my kernel-desktop to 3.13 version but same

  2. #2
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: After suspend/sleep can't login

    I use 13.1 with KDE, 4.12.2 in my case but same for 4.11 I believe.
    Can not comment on Gnome or others DEs

    I believe what you are saying is that your user password does not unlock the screen locker.

    I normally shut of screenlocker password - but that may not be good for your situation.

    To turn off screen locker password
    1. Kill KDM with Alt-Ctl-Backspace, this should get you back to the loging greeter screen.
    2. Login
    3. Open System Settings-Display and Monitor- Screen Locker
    4. Deselect the Require password after Radio button, then Apply


    Also, open System Settings-Power Management-Advanced Settings
    Deselect Lock Screen on Resume checkbox
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  3. #3

    Default Re: After suspend/sleep can't login

    maybe it's problem in kernel-desktop 3.11

  4. #4
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: After suspend/sleep can't login

    Quote Originally Posted by alakulihal View Post
    maybe it's problem in kernel-desktop 3.11
    I don't think so; I am running 3.11.10-9 (due to issues with Bluetooth and Sleep)

    What DE are your running?

    Are you sure you know what your user passwd is?
    If you use auto-login, it can be easy to forget.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  5. #5

    Default Re: After suspend/sleep can't login

    I use KDE 4.11.5, my problem not about password. But can't login because no login session after suspend.

  6. #6

    Default Re: After suspend/sleep can't login

    Quote Originally Posted by cmcgrath5035 View Post
    I don't think so; I am running 3.11.10-9 (due to issues with Bluetooth and Sleep)
    JFYI, kernel 3.11.10 has been released as official online update today, so you might want to switch back to the one from the update repo.

    @alakulihal:
    Could you try to explain the problem more clearly please?
    Is your password not accepted?
    Is it not possible to type it in?
    Do you maybe only get a black screen after resume?

    If it's the latter, there might be some BIOS settings that could help. Or kernel options like acpi_osi, see here: http://askubuntu.com/questions/28848...i-osi-linux-do

  7. #7

    Default Re: After suspend/sleep can't login

    After get up from suspend. my desktop only wallpaper and cursor, look no login display.

  8. #8

    Default Re: After suspend/sleep can't login

    Quote Originally Posted by alakulihal View Post
    After get up from suspend. my desktop only wallpaper and cursor, look no login display.
    Ok, so apparently the screen is locked, but there's no password dialog?

    Did you try already what cmcgrath5035 suggested in his first post? (the reply to your initial post)

    Sounds like this:
    https://bugs.kde.org/show_bug.cgi?id=327947#c3

    But I can't reproduce this here.
    Does it work when you create a new user?

    Maybe try to change the "Ask password after" setting in "Configure Desktop"->"Display and Monitor"->Screenlocker (i.e. enable/disable it, and change the time out value)

  9. #9
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: After suspend/sleep can't login

    Quote Originally Posted by wolfi323 View Post
    Ok, so apparently the screen is locked, but there's no password dialog?
    I will use slightly different terminology here, because it sounds to me like you are not actually returning from suspend fully, and that your screen is "frozen" (my terminology), not "locked" which to me implies that the screen locker has been activated.

    To be specific, When your system correctly returns from suspend, you get a Screen Locker or not, depending on your settings.
    If you get a screen locker, your password will unlock it. You do not get a "login" screen or dialog.
    However, what you are experiencing sounds to me like a failure to fully return from resume, after suspend.

    I realize we my be operating in 2 or three languages here (with translation), the details here can be difficult to identify.

    You might benefit from reviewing THIS THREAD
    My problem was different than yours, but the forum discussion revealed that pm-utilities is on the way out and the kernel and Upower will take over suspend/resume management in the future.
    In post 13 of the thread I summarize how I removed pm-utilities and verified that they were no longer needed.

    To help you with a failure to resume after suspend, we will probably need at least the following info from you:
    1. What DE (KDE, GNOME, etc)?
    2. What hardware (CPU, chipset, etc)?
    3. Are pm-utilities installed? If so, have to reviewed /var/log/pm-suspend.log for suspend/resume errors messages?
    4. You can also execute "dmesg" in a console window, look for suspend/resume diagnostic messages
    5. Are you sleeping (STR) or hibernating (STD) your system? If STD, is your swap partition at least as large as your installed RAM?
    6. Any past history with your hardware - sleep OK with other Linux or Windows?
    7. Sometimes proprietary video drivers are a problem - what video device and driver are you running?


    As a general statement, I have found that STR works well on several different hardware platforms running 13.1, but that is no guarantee it does without help(tweaks) on yours.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  10. #10

    Default Re: After suspend/sleep can't login

    Quote Originally Posted by cmcgrath5035 View Post
    I will use slightly different terminology here, because it sounds to me like you are not actually returning from suspend fully, and that your screen is "frozen" (my terminology), not "locked" which to me implies that the screen locker has been activated.
    Yes, and that's exactly what I mean.
    It seems to me that the screen locker has been activated (i.e. the screen is locked), but it doesn't show any password dialog.
    And that's exactly what that bug report is about.

    He says he sees the "desktop wallpaper" and the mouse cursor. The screen locker uses the default desktop wallpaper as background image.
    Oh, and he already wrote that he uses KDE 4.11.5.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •