Results 1 to 3 of 3

Thread: libquvi: Could not find any subtitle scripts

  1. #1
    Join Date
    Aug 2011
    Location
    usa
    Posts
    232

    Default libquvi: Could not find any subtitle scripts

    Hi again, I'm having trouble using quvi, clive, and cclive

    Code:
    % quvi info
    
    ** (scan:27174): CRITICAL **: [_chk_script_ident] /usr/share/libquvi-scripts/0.9/common/quvi/youtube.lua:69: module 'socket.url' not found:
            no field package.preload['socket.url']
            no file '/usr/share/lua/5.2/socket/url.lua'
            no file '/usr/share/lua/5.2/socket/url/init.lua'
            no file '/usr/lib64/lua/5.2/socket/url.lua'
            no file '/usr/lib64/lua/5.2/socket/url/init.lua'
            no file './socket/url.lua'
            no file '/usr/share/libquvi-scripts/0.9/common/socket/url.lua'
            no file '/usr/lib64/lua/5.2/socket/url.so'
            no file '/usr/lib64/lua/5.2/loadall.so'
            no file './socket/url.so'
            no file '/usr/lib64/lua/5.2/socket.so'
            no file '/usr/lib64/lua/5.2/loadall.so'
            no file './socket.so'
    error: while initializing libquvi: Could not find any subtitle scripts in the path
    
    % clive --no-download 'http://short-url-to-save-space.com/'
    Detect quvi from $PATH
      Check for quvi ...0.9.3
    Copyright (C) 2012,2013  Toni Gundogdu <legatvs@gmail.com>
    quvi comes with ABSOLUTELY NO WARRANTY.  You may redistribute copies of
    quvi under the terms of the GNU Affero General Public License version 3
    or later. For more information, see <http://www.gnu.org/licenses/agpl.html>.
    
    To contact the developers, please mail to <quvi-devel@lists.sourceforge.net>
    Detect a download command from $PATH
        Check for curl ...7.32.0
    Checking ...error: `http://short-url-to-save-space.com/'  is not a quvi command. See 'quvi help'.
    
    % cclive --support
    libquvi: error: lua util scripts not found
    I checked and found that quvi and all it's packages are installed and the dependencies are ok.

    Code:
    % rpm -q quvi
    quvi-0.9.3-2.1.4.x86_64
    % rpm -q libquvi
    libquvi-0.9.2-2.1.3.x86_64
    % rpm -q libquvi-scripts
    libquvi-scripts-0.9.20130805-2.1.2.x86_64
    What's up?

  2. #2

    Default Re: libquvi: Could not find any subtitle scripts

    Thanks,

    This has been identifed and reported as https://bugzilla.novell.com/show_bug.cgi?id=863126
    Fixed packages are available in the repository mentioned in the bug for testing.

    Please let us know if those packages fix you issue as well.

  3. #3
    Join Date
    Aug 2011
    Location
    usa
    Posts
    232

    Default Re: libquvi: Could not find any subtitle scripts

    Yes and no,
    Yes, quvi now works.
    No, clive and cclive do not

    Code:
    % clive -F "http://www.youtube.com/watch?v=example"
    Detect quvi from $PATH
      Check for quvi ...0.9.3
    Copyright (C) 2012,2013  Toni Gundogdu <legatvs@gmail.com>
    quvi comes with ABSOLUTELY NO WARRANTY.  You may redistribute copies of
    quvi under the terms of the GNU Affero General Public License version 3
    or later. For more information, see <http://www.gnu.org/licenses/agpl.html>.
    
    To contact the developers, please mail to <quvi-devel@lists.sourceforge.net>
    Detect a download command from $PATH
      Check for curl ...7.32.0
    Checking ...error: `http://www.youtube.com/watch?v=D6ZqaGTvP8w' is not a quvi command. See 'quvi help'.
    
    % 
    cclive --query-formats 'http://www.youtube.com/watch?v=example'
    libquvi: error: lua util scripts not found

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •