Page 1 of 8 123 ... LastLast
Results 1 to 10 of 76

Thread: No sound :(

  1. #1

    Default No sound :(

    Hi, I'm using openSUSE 13.1, I have onboard sound but I also have a Soundbalster Z (I don't use the onboard sound).

    Anyway there's no sound in Suse, maybe it's set to use my onboard sound? Possibly but I'm such a linux noob I have no idea how to check and change it

  2. #2

    Default Re: No sound :(

    Quote Originally Posted by Astralogic View Post
    Hi, I'm using openSUSE 13.1, I have onboard sound but I also have a Soundbalster Z (I don't use the onboard sound).

    Anyway there's no sound in Suse, maybe it's set to use my onboard sound? Possibly but I'm such a linux noob I have no idea how to check and change it
    Type this in terminal and post the output in code.

    Code:
    aplay -l
    the 'l' is small letter L
    Code:
    aplay -L
    There might be someone who can help you.
    People who do not break things first will never learn to create anything

  3. #3

    Default Re: No sound :(

    Quote Originally Posted by conram View Post
    Type this in terminal and post the output in code.

    Code:
    aplay -l
    the 'l' is small letter L
    Code:
    aplay -L
    There might be someone who can help you.
    Here is the output:

    Code:
    calvin@linux-kmee:~> aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC1150 Analog [ALC1150 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC1150 Digital [ALC1150 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 2: Creative [HDA Creative], device 0: CA0132 Analog [CA0132 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 2: Creative [HDA Creative], device 1: CA0132 Digital [CA0132 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    calvin@linux-kmee:~>

  4. #4

    Default Re: No sound :(

    Post also the output of
    Code:
    aplay -L
    People who do not break things first will never learn to create anything

  5. #5

    Default Re: No sound :(

    Quote Originally Posted by conram View Post
    Post also the output of
    Code:
    aplay -L
    OK.

    Code:
    calvin@linux-kmee:~> aplay -L null     Discard all samples (playback) or generate zero samples (capture) default     Default ALSA Output (currently PulseAudio Sound Server) sysdefault:CARD=PCH     HDA Intel PCH, ALC1150 Analog     Default Audio Device front:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     Front speakers surround40:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     4.0 Surround output to Front and Rear speakers surround41:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     5.0 Surround output to Front, Center and Rear speakers surround51:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Digital     IEC958 (S/PDIF) Digital Audio Output hdmi:CARD=NVidia,DEV=0     HDA NVidia, HDMI 0     HDMI Audio Output hdmi:CARD=NVidia,DEV=1     HDA NVidia, HDMI 1     HDMI Audio Output hdmi:CARD=NVidia,DEV=2     HDA NVidia, HDMI 2     HDMI Audio Output hdmi:CARD=NVidia,DEV=3     HDA NVidia, HDMI 3     HDMI Audio Output sysdefault:CARD=Creative     HDA Creative, CA0132 Analog     Default Audio Device front:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     Front speakers surround40:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     4.0 Surround output to Front and Rear speakers surround41:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=Creative,DEV=0     HDA Creative, CA0132 Digital     IEC958 (S/PDIF) Digital Audio Output calvin@linux-kmee:~>
    I don't know why the formatting is messed up :/

  6. #6

    Default Re: No sound :(

    Quote Originally Posted by Astralogic View Post
    OK.

    Code:
    calvin@linux-kmee:~> aplay -L null     Discard all samples (playback) or generate zero samples (capture) default     Default ALSA Output (currently PulseAudio Sound Server) sysdefault:CARD=PCH     HDA Intel PCH, ALC1150 Analog     Default Audio Device front:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     Front speakers surround40:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     4.0 Surround output to Front and Rear speakers surround41:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     5.0 Surround output to Front, Center and Rear speakers surround51:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Analog     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=PCH,DEV=0     HDA Intel PCH, ALC1150 Digital     IEC958 (S/PDIF) Digital Audio Output hdmi:CARD=NVidia,DEV=0     HDA NVidia, HDMI 0     HDMI Audio Output hdmi:CARD=NVidia,DEV=1     HDA NVidia, HDMI 1     HDMI Audio Output hdmi:CARD=NVidia,DEV=2     HDA NVidia, HDMI 2     HDMI Audio Output hdmi:CARD=NVidia,DEV=3     HDA NVidia, HDMI 3     HDMI Audio Output sysdefault:CARD=Creative     HDA Creative, CA0132 Analog     Default Audio Device front:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     Front speakers surround40:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     4.0 Surround output to Front and Rear speakers surround41:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     4.1 Surround output to Front, Rear and Subwoofer speakers surround50:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     5.0 Surround output to Front, Center and Rear speakers surround51:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     5.1 Surround output to Front, Center, Rear and Subwoofer speakers surround71:CARD=Creative,DEV=0     HDA Creative, CA0132 Analog     7.1 Surround output to Front, Center, Side, Rear and Woofer speakers iec958:CARD=Creative,DEV=0     HDA Creative, CA0132 Digital     IEC958 (S/PDIF) Digital Audio Output calvin@linux-kmee:~>
    I don't know why the formatting is messed up :/
    Yes it is unreadable.

    Can you please post the output again of
    Code:
    aplay -L
    Be sure to make it good like when you post the output of aplay -l

    There might be a chance an expert in this area will be able to help you.
    People who do not break things first will never learn to create anything

  7. #7

    Default Re: No sound :(

    Quote Originally Posted by conram View Post
    Yes it is unreadable.

    Can you please post the output again of
    Code:
    aplay -L
    Be sure to make it good like when you post the output of aplay -l

    There might be a chance an expert in this area will be able to help you.
    I copied and pasted them both in exactly the same way, I understand why the formatting went bad. I'll try again in a minute.

  8. #8

    Default Re: No sound :(

    Quote Originally Posted by Astralogic View Post
    I copied and pasted them both in exactly the same way, I understand why the formatting went bad. I'll try again in a minute.
    The formatting won't display properly so I took a screenshot of the output instead.

  9. #9

    Default Re: No sound :(

    Quote Originally Posted by Astralogic View Post
    The formatting won't display properly so I took a screenshot of the output instead.
    Hi there,

    To set your default audio card to use do the following:

    1. Open YAST (need root password). Go to Hardware -> Sound.
    2. Select the card you want from the list to be primary, go to Other (on the lower right), select the Set as Primary card option.
    3. Select other card (onboard) click delete to disable it. Won't show in your audio devices anymore. A better option would be to go to your BIOS settings and disable the onboard soundcard from there.
    4. Install pavucontrol (search for it in Yast -> Software Management). This will allow you to better control your audio setup, changing default profiles, outputs and inputs of cards, volume levels etc. It's a must if using Pulseaudio (default on OpenSUSE).
    5. Optional: As per https://features.opensuse.org/310668 (please vote), changing the /etc/pulse/daemon.conf line ; flat-volumes = yes to flat-volumes = no (mind the ; missing from the begging of the line), will make you master audio level not get changed by changing another app's volume level. Makes for a better audio session than the current default.
    6. Reboot so the changes take effect.
    7. Enjoy.

  10. #10

    Default Re: No sound :(

    Quote Originally Posted by sirdeiu View Post
    Hi there,

    To set your default audio card to use do the following:

    1. Open YAST (need root password). Go to Hardware -> Sound.
    2. Select the card you want from the list to be primary, go to Other (on the lower right), select the Set as Primary card option.
    3. Select other card (onboard) click delete to disable it. Won't show in your audio devices anymore. A better option would be to go to your BIOS settings and disable the onboard soundcard from there.
    4. Install pavucontrol (search for it in Yast -> Software Management). This will allow you to better control your audio setup, changing default profiles, outputs and inputs of cards, volume levels etc. It's a must if using Pulseaudio (default on OpenSUSE).
    5. Optional: As per https://features.opensuse.org/310668 (please vote), changing the /etc/pulse/daemon.conf line ; flat-volumes = yes to flat-volumes = no (mind the ; missing from the begging of the line), will make you master audio level not get changed by changing another app's volume level. Makes for a better audio session than the current default.
    6. Reboot so the changes take effect.
    7. Enjoy.
    I've done that but, I still have no sound.

Page 1 of 8 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •