Page 1 of 7 123 ... LastLast
Results 1 to 10 of 68

Thread: problem of bumblebee in 13.1 x86_64

  1. #1

    Default problem of bumblebee in 13.1 x86_64

    According the page : http://smithfarm-thebrain.blogspot.c...bumblebee.html , I use Overman79's repository : http://download.opensuse.org/reposit...openSUSE_13.1/

    But I can not install dkms-nvidia and x11-video-nvidia from the repository .

    Code:
    $ sudo zypper in x11-video-nvidia
    root's password:
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      x11-video-nvidia 
    
    1 new package to install.
    Overall download size: 9.8 KiB. After the operation, additional 495.0 B will be 
    used.
    Continue? [y/n/? shows all options] (y): 
    (1/1) Installing: x11-video-nvidia-331.38-3.1 ...........................[error]
    Installation of x11-video-nvidia-331.38-3.1 failed:
    Error: Subprocess failed. Error: RPM failed: Error in checksums 142193369 564647467
    error: %pre(x11-video-nvidia-331.38-3.1.x86_64) scriptlet failed, exit status 254
    error: x11-video-nvidia-331.38-3.1.x86_64: install failed
    
    
    Abort, retry, ignore? [a/r/i] (a): 
    Problem occured during or after installation or removal of packages:
    Installation aborted by user
    
    Please see the above error message for a hint.
    
    $ sudo zypper in dkms-nvidia
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      dkms-nvidia 
    
    1 new package to install.
    Overall download size: 6.6 KiB. After the operation, additional 513.0 B will be 
    used.
    Continue? [y/n/? shows all options] (y): 
    (1/1) Installing: dkms-nvidia-331.38-2.1 ................................[error]
    Installation of dkms-nvidia-331.38-2.1 failed:
    Error: Subprocess failed. Error: RPM failed: Error in checksums 142193369 564647467
    error: %pre(dkms-nvidia-331.38-2.1.x86_64) scriptlet failed, exit status 254
    error: dkms-nvidia-331.38-2.1.x86_64: install failed
    
    
    Abort, retry, ignore? [a/r/i] (a): 
    Problem occured during or after installation or removal of packages:
    Installation aborted by user
    
    Please see the above error message for a hint.
    I use 13.1 x86_64 gnome 3.10 version.
    How to do with it ?

    Thanks

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: problem of bumblebee in 13.1 x86_64

    Are you sure you point to the correct repo?

  3. #3

    Default Re: problem of bumblebee in 13.1 x86_64

    Quote Originally Posted by gogalthorp View Post
    Are you sure you point to the correct repo?
    I am sure : I use http://download.opensuse.org/reposit...openSUSE_13.1/ according to http://smithfarm-thebrain.blogspot.c...bumblebee.html .

    Thanks

  4. #4
    Join Date
    Oct 2012
    Location
    Czech Republic
    Posts
    14

    Default Re: problem of bumblebee in 13.1 x86_64

    I installed the same versions of dkms-nvidia and x11-video-nvidia, from the same repository, a couple days ago and had no trouble. Please post the output of the following commands:
    Code:
    # zypper se -s dkms-nvidia
    # zypper se -s x11-video-nvidia
    # zypper lr Overman79

  5. #5
    Join Date
    Oct 2012
    Location
    Czech Republic
    Posts
    14

    Default Re: problem of bumblebee in 13.1 x86_64

    It is of interest to look at the NVIDIA installation script that is downloaded and is supposed to install the binary blob:
    * http://us.download.nvidia.com/XFree8..._64-331.38.run

    There you can see that the error occurs in the following line:
    Code:
    echo "Error in checksums $sum1 $CRCsum"
    One plausible scenario for this to occur is that the file was not completely downloaded, or was corrupted somehow in transit. Try reinstalling the package via
    Code:
    zypper in -f

  6. #6

    Default Re: problem of bumblebee in 13.1 x86_64

    Code:
    opensuse-tf:~ # zypper se -s dkms-nvidia
    Loading repository data...
    Reading installed packages...
    
    S | Name        | Type       | Version    | Arch   | Repository           
    --+-------------+------------+------------+--------+----------------------
      | dkms-nvidia | package    | 331.38-2.1 | x86_64 | home:Overman79:Laptop
      | dkms-nvidia | package    | 331.38-2.1 | i586   | home:Overman79:Laptop
      | dkms-nvidia | srcpackage | 331.38-2.1 | noarch | home:Overman79:Laptop
    opensuse-tf:~ # zypper se -s x11-video-nvidia
    Loading repository data...
    Reading installed packages...
    
    S | Name                   | Type       | Version    | Arch   | Repository           
    --+------------------------+------------+------------+--------+----------------------
      | x11-video-nvidia       | package    | 331.38-3.1 | x86_64 | home:Overman79:Laptop
      | x11-video-nvidia       | package    | 331.38-3.1 | i586   | home:Overman79:Laptop
      | x11-video-nvidia       | srcpackage | 331.38-3.1 | noarch | home:Overman79:Laptop
      | x11-video-nvidia-32bit | package    | 331.38-3.1 | x86_64 | home:Overman79:Laptop
    opensuse-tf:~ # zypper lr Overman79
    Repository 'Overman79' not found by its alias, number, or URI.
    Use 'zypper repos' to get the list of defined repositories.
    
    opensuse-tf:~ # zypper lr home:Overman79:Laptop
    Alias          : home:Overman79:Laptop                                                           
    Name           : home:Overman79:Laptop                                                           
    URI            : http://download.opensuse.org/repositories/home:/Overman79:/Laptop/openSUSE_13.1/
    Enabled        : Yes                                                                             
    Priority       : 99                                                                              
    Auto-refresh   : On                                                                              
    Keep Packages  : On                                                                              
    Type           : rpm-md                                                                          
    GPG Check      : On                                                                              
    GPG Key URI    :                                                                                 
    Path Prefix    :                                                                                 
    Parent Service :                                                                                 
    MD Cache Path  : /var/cache/zypp/raw/home:Overman79:Laptop
    Code:
    # zypper in -f dkms-nvidia
    Loading repository data...
    Reading installed packages...
    Forcing installation of 'dkms-nvidia-331.38-2.1.x86_64' from repository 'home:Overman79:Laptop'.
    Resolving package dependencies...
    
    The following NEW package is going to be installed:
      dkms-nvidia 
    
    1 new package to install.
    Overall download size: 6.6 KiB. After the operation, additional 513.0 B will be used.
    Continue? [y/n/? shows all options] (y): 
    (1/1) Installing: dkms-nvidia-331.38-2.1 ...............................................................................[error]
    Installation of dkms-nvidia-331.38-2.1 failed:
    Error: Subprocess failed. Error: RPM failed: Error in checksums 142193369 564647467
    error: %pre(dkms-nvidia-331.38-2.1.x86_64) scriptlet failed, exit status 254
    error: dkms-nvidia-331.38-2.1.x86_64: install failed
    
    
    Abort, retry, ignore? [a/r/i] (a): r            
    (1/1) Installing: dkms-nvidia-331.38-2.1 ...............................................................................[error]
    Installation of dkms-nvidia-331.38-2.1 failed:
    Error: Subprocess failed. Error: RPM failed: Error in checksums 142193369 564647467
    error: %pre(dkms-nvidia-331.38-2.1.x86_64) scriptlet failed, exit status 254
    error: dkms-nvidia-331.38-2.1.x86_64: install failed
    
    
    Abort, retry, ignore? [a/r/i] (a): a
    Problem occured during or after installation or removal of packages:
    Installation aborted by user
    
    Please see the above error message for a hint.
    Thanks

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: problem of bumblebee in 13.1 x86_64

    You do not want all packages you want only the packages for your architecture. It looks like you installed all packages.

  8. #8

    Default Re: problem of bumblebee in 13.1 x86_64

    I see. It is about the file NVIDIA-Linux-x86_64-331.38.run, I do not download it completely.
    This file is not in /var/cache, it is in /usr/src .
    You must delete the file manually and rerun those install commands.

    Now it is OK. Thanks

    PS: How to mark the post as SOLVED ?

  9. #9

    Default Re: problem of bumblebee in 13.1 x86_64

    I got the same error the exit code is different

    Code:
    2014-02-22 14:33:42 (379 KB/s) - 'NVIDIA-Linux-x86_64-331.38.run' saved [60164869/60164869]
    
    check sums and md5 sums are ok
    Creating directory NVIDIA-Linux-x86_64-331.38
    Verifying archive integrity... OK
    Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 331.38......................................................................................................................................................................................................................
    error: %pre(dkms-nvidia-331.38-2.1.x86_64) scriptlet failed, exit status 1
    error: dkms-nvidia-331.38-2.1.x86_64: install failed
    Any hint please?
    Saluti
    R

  10. #10

    Default Re: problem of bumblebee in 13.1 x86_64

    Unfortunately my GUI doesn't work. My Hardware is:
    Code:
    vaio-i5:~ # lspci|grep VGA
    00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M LE] (rev a1)
    I got some more output. Running the installation command

    Code:
    zypper in dkms dkms-nvidia dkms-bbswitch bumblebee primus x11-video-nvidia
    I got the following error message


    Code:
    2014-02-24 14:35:26 (385 KB/s) - 'NVIDIA-Linux-x86_64-331.38.run' saved [60164869/60164869]
    
    check sums and md5 sums are ok
    Creating directory NVIDIA-Linux-x86_64-331.38
    Verifying archive integrity... OK
    Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 331.38......................................................................................................................................................................................................................
    + '[' -x /usr/sbin/dkms ']'
    + /usr/sbin/dkms add -m nvidia -v 331.38-2.1 --rpm_safe_upgrade
    
    Creating symlink /var/lib/dkms/nvidia/331.38-2.1/source ->
                     /usr/src/nvidia-331.38-2.1
    
    DKMS: add completed.
    + /usr/sbin/dkms build -m nvidia -v 331.38-2.1
    
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area....(bad exit status: 2)
    make KERNELRELEASE=3.11.10-7-desktop -C /lib/modules/3.11.10-7-desktop/build SUBDIRS=/var/lib/dkms/nvidia/331.38-2.1/build modules....(bad exit status: 2)
    Error! Bad return status for module build on kernel: 3.11.10-7-desktop (x86_64)
    Consult /var/lib/dkms/nvidia/331.38-2.1/build/make.log for more information.
    + /usr/sbin/dkms install -m nvidia -v 331.38-2.1
    
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area....(bad exit status: 2)
    make KERNELRELEASE=3.11.10-7-desktop -C /lib/modules/3.11.10-7-desktop/build SUBDIRS=/var/lib/dkms/nvidia/331.38-2.1/build modules....(bad exit status: 2)
    Error! Bad return status for module build on kernel: 3.11.10-7-desktop (x86_64)
    Consult /var/lib/dkms/nvidia/331.38-2.1/build/make.log for more information.
    + popd
    The content of the make log file is

    Code:
    vaio-i5:~ # cat /var/lib/dkms/nvidia/331.38-2.1/build/make.log 
    DKMS make.log for nvidia-331.38-2.1 for kernel 3.11.10-7-desktop (x86_64)
    Mon Feb 24 14:35:42 CET 2014
    make: Entering directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop'
    make: Entering an unknown directory
    make: *** ../../../linux-3.11.10-7: No such file or directory.  Stop.
    make: Leaving an unknown directory
    make: *** [all] Error 2
    make: Leaving directory `/usr/src/linux-3.11.10-7-obj/x86_64/desktop'

    I have the obj directory installed it seems to looking for the ../../../linux-3.11.10-7: directory. How can I get it?

    I appreciate very much any help
    Saluti
    R

Page 1 of 7 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •