Page 1 of 7 123 ... LastLast
Results 1 to 10 of 62

Thread: Two monitor are not working correctly

  1. #1

    Default Two monitor are not working correctly

    I have an annoying problem. I have two monitors, well one's a TV, and I need to switch them, because on my TV it says "unsupported format" or something as though the resolution is wrong, but on my monitor I only see desktop 2. So I need to modify the display settings of the TV and switch them around to that I get desktop 1 onmy monitor . Any ideas how to do that without being able to see the main desktop?

    Quote Originally Posted by gogalthorp View Post
    Maybe boot to rescue mode? I don't think that mode supports dual monitors so you should only see the main one.
    That would probably only make my TV active which currently has an unsupported format so I wouldn't see anything on it.

  2. #2

    Default Re: Two monitor are not working correctly

    It will be hard for those who want to chime-in to this thread if you will not provide more information about your computer
    ie: is it a desktop or a laptop, or what is your video card or what DE are you using
    People who do not break things first will never learn to create anything

  3. #3

    Default Re: Two monitor are not working correctly

    Quote Originally Posted by conram View Post
    It will be hard for those who want to chime-in to this thread if you will not provide more information about your computer
    ie: is it a desktop or a laptop, or what is your video card or what DE are you using
    Yes it's a desktop computer, my video card is a nvidia gtx 770, and I'm using KDE.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,706
    Blog Entries
    1

    Default Re: Two monitor are not working correctly

    Quote Originally Posted by Astralogic View Post
    Yes it's a desktop computer, my video card is a nvidia gtx 770, and I'm using KDE.
    Still not enough info. Please tell us
    1. openSUSE version and desktop environment (eg KDE, Gnome,...)
    2. Are you using the open source driver or proprietary nvidia driver?
    Code:
    /usr/sbin/hwinfo --gfxcard

  5. #5

    Default Re: Two monitor are not working correctly

    Quote Originally Posted by Astralogic View Post
    Yes it's a desktop computer, my video card is a nvidia gtx 770, and I'm using KDE.
    Here's a link to my full specs if you need it.

  6. #6

    Default Re: Two monitor are not working correctly

    Quote Originally Posted by deano_ferrari View Post
    Still not enough info. Please tell us
    1. openSUSE version and desktop environment (eg KDE, Gnome,...)
    2. Are you using the open source driver or proprietary nvidia driver?
    Code:
    /usr/sbin/hwinfo --gfxcard
    It's openSUSE 13.1 with KDE.

    I'm using whatever driver openSUSE defaulted me to. I'm in Windows at the minute so I'll run that code and get back to you with the output soon. Can I access a terminal without access to the main dasektop?

  7. #7

    Default Re: Two monitor are not working correctly

    When I was installing from the disc it did setup up my displays the correct way round. But once installed and booting from the HD it swapped them around and gave my TV funky settings that it doesn't want to display.

    Edit: If necessary I could just unplug my TV from the computer, that should give me the main desktop on my monitor, but I don't know what to do after that to get them set up so they can both be left connected to the computer.

  8. #8

    Default Re: Two monitor are not working correctly

    Here's the output of the commands you gave me earlier:

    Code:
    linux-kmee:~ # /usr/sbin/hwinfo --gfxcard
    22: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.319]
      Unique ID: VCu0.+KN0roOebrF
      Parent ID: vSkL.QvIcRUNlaeA
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia VGA compatible controller"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x1184 
      SubVendor: pci 0x1458 "Giga-byte Technology"
      SubDevice: pci 0x361a 
      Revision: 0xa1
      Driver: "nouveau"
      Driver Modules: "drm"
      Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
      Memory Range: 0xe8000000-0xefffffff (ro,non-prefetchable)
      Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
      I/O Ports: 0xe000-0xefff (rw)
      Memory Range: 0xf7000000-0xf707ffff (ro,non-prefetchable,disabled)
      IRQ: 16 (6217 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v000010DEd00001184sv00001458sd0000361Abc03sc00i00"
      Driver Info #0:
        Driver Status: nvidiafb is not active
        Driver Activation Cmd: "modprobe nvidiafb"
      Driver Info #1:
        Driver Status: nouveau is active
        Driver Activation Cmd: "modprobe nouveau"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #9 (PCI bridge)
    
    Primary display adapter: #22
    Edit: I left my TV unplugged and got to my main desktop on my monitor but there was no "start menu" if you know what I mean, the KDE menu in the lower left was not there. Should I remove openSUSE and reinstall it?

  9. #9

    Default Re: Two monitor are not working correctly

    Quote Originally Posted by Astralogic View Post
    Edit: I left my TV unplugged and got to my main desktop on my monitor but there was no "start menu" if you know what I mean, the KDE menu in the lower left was not there. Should I remove openSUSE and reinstall it?

    Please disregard this question, I'll make a new thread for it.

  10. #10

    Default Re: Two monitor are not working correctly

    Quote Originally Posted by Astralogic View Post
    Here's the output of the commands you gave me earlier:
    I would advise you to install the proprietary nvidia driver, that should work better especially in a multi-monitor setup:
    https://en.opensuse.org/SDB:NVIDIA_drivers

    Or (that's how I would do it) just enable the NVidia repo in YaST->Software Repositories->Add->Community Repositories, then run YaST->Software Management and install the following packages (just type "nvidia" into the search field and you should see all of them):
    nvidia-gfxG03-kmp-desktop, x11-video-nvidiaG03, nvidia-glG03, nvidia-computeG03 (at least the latter two should be selected automatically anyway when you select the first one)

    This of course implies that you are using kernel-desktop, which should be the default.
    For kernel-default, you would need nvidia-gfxG03-kmp-default as first package.
    You can check the kernel with "uname -a", or just look in YaST which kernel package is installed.

    I can't really help you with the two monitors setup, but it should be possible to configure correctly in Configure Desktop->Display and Monitor.
    Or you could use "nvidia-settings" after you installed the nvidia driver.

Page 1 of 7 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •