Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Can not start fcitx in 13.1 using Ctrl + Space

  1. #1

    Default Can not start fcitx in 13.1 using Ctrl + Space

    I have installed fcitx in 13.1 amd64, and set /etc/sysconfig/language to fcitx.
    But I can not start it with Ctrl + Space.

    What is the matter?
    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    Quote Originally Posted by waterloo2005 View Post
    I have installed fcitx in 13.1 amd64, and set /etc/sysconfig/language to fcitx.
    ?
    This isn't necessary

    But I can not start it with Ctrl + Space.
    what DE?
    Is it even running? Do you have the fcitx systray icon showing?

    If using KDE, install fcitx-config-kde4 and configure the shortcut to change languages.
    if Gnome fcitx-config-gtk3

  3. #3

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    I install fcitx in gnome 3.10 and can not see systray icon.

    Do I need set 'region&language' in system config?

    fcitx
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-table.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-chttrans.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-googlepinyin.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-punc.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-unicode.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-autoeng.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-spell.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-x11.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-lua.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-sunpinyin.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-quickphrase.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-classic-ui.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-pinyin-enhance.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-ipc.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-libpinyin.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-kimpanel-ui.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-keyboard.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-clipboard.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-notificationitem.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-xkb.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-imselector.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-cloudpinyin.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-xim.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-freedesktop-notify.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-vk.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-dbus.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-remote-module.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-fullwidth-char.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-pinyin.conf
    (INFO-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-xkbdbus.conf
    (WARN-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/module/dbus/dbusstuff.c:246) DBus Service Already Exists
    (ERROR-2362 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/instance.c:427) Exiting.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    Quote Originally Posted by waterloo2005 View Post
    I install fcitx in gnome 3.10 and can not see systray icon.
    for first use of fcitx you must start it manually

    Code:
    fcitx
    I don't use gnome but I assume you would get a tray icon of some sort the same as in KDE.
    Once started open the configuration and set required language input and shortcut to start/switch from there. (you need to install the config module I mentioned in previous post)
    even if you can't see a tray icon you should be able to launch the config module as long as fcitx has been started.

    Code:
    fcitx-configtool
    Do I need set 'region&language' in system config?
    it shouldn't be necessary but maybe check in

    yast > language > details

    make sure "use utf8_encoding" is checked.

  5. #5

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    I install fcitx in 13.1 x86_64 gnome 3.10. I can not see language systray icon in panel of gnome 3.10.
    Code:
    xxxx$ fcitx
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-table.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-chttrans.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-light-ui.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-googlepinyin.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-punc.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-unicode.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-autoeng.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-spell.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-x11.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-lua.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-sunpinyin.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-quickphrase.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-classic-ui.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-pinyin-enhance.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-ipc.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-libpinyin.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-kimpanel-ui.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-keyboard.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-clipboard.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-notificationitem.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-xkb.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-imselector.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-cloudpinyin.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-xim.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-freedesktop-notify.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-vk.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-dbus.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-remote-module.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-fullwidth-char.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-pinyin.conf
    (INFO-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/addon.c:151) Load Addon Config File:fcitx-xkbdbus.conf
    xxxx$ (WARN-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/module/dbus/dbusstuff.c:246) DBus Service Already Exists
    (ERROR-2110 /home/abuild/rpmbuild/BUILD/fcitx-4.2.8.3/src/lib/fcitx/instance.c:427) Exiting.

  6. #6
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    I install fcitx in 13.1 x86_64 gnome 3.10. I can not see language systray icon in panel of gnome 3.10.
    you can turn the tray icon on with the configuration tool

    Code:
    fcitx-configtool

  7. #7

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    Quote Originally Posted by farcusnz View Post
    you can turn the tray icon on with the configuration tool

    Code:
    fcitx-configtool
    fcitx-configtool do not turn language icon in my machine.

    Do I need some setting in ~/.profile ?

    Thanks

  8. #8
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    Quote Originally Posted by waterloo2005 View Post
    fcitx-configtool do not turn language icon in my machine.

    Do I need some setting in ~/.profile ?

    Thanks
    No, you shouldn't need to. You should be able to manage all settings from within fcitx.

    As long as you have established fcitx is running launch the config tool.
    Then check to show in systray.



    Then you need to add the language you want to use in fcitx (and of course install the corresponding fcitx language files from yast)
    I use Japanese so installed fcitx-mozc and then set in the config tool



    then set the keyboard shortcut to switch the language input on and off (in my case - control-space)



    restart Gnome and it should work.

    (also make sure you have some fonts installed for the language that you want to use)

  9. #9

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    Quote Originally Posted by farcusnz View Post
    No, you shouldn't need to. You should be able to manage all settings from within fcitx.

    (also make sure you have some fonts installed for the language that you want to use)
    Thanks !

    I do like what you offer. Now I can use Ctrl + Space to activate fcitx and input , but I still can not see systray icon in gnome 3.10 panel.

    But now I can only using fcitx input method in firefox , gedit ,etc., still can not use fcitx in gnome-terminal.

  10. #10
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Can not start fcitx in 13.1 using Ctrl + Space

    Quote Originally Posted by waterloo2005 View Post
    Thanks !

    I do like what you offer. Now I can use Ctrl + Space to activate fcitx and input , but I still can not see systray icon in gnome 3.10 panel.

    But now I can only using fcitx input method in firefox , gedit ,etc., still can not use fcitx in gnome-terminal.
    did you reboot after setup? In KDE these types of issues occur without reboot.

    I don't know what the issue might be as things just work in KDE.
    Firefox and gnome terminal are both gtk programs so if one works so should the other.
    I can only guess that perhaps the issue is caused by terminal being a gtk3 app and firefox gtk2.
    Do you have fcitx-gtk3 installed?

    Perhaps a gnome user might be able to jump in and help out.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •