Hi,
openSUSE 11.3 mit kernel 2.6.39: (PS: DELL OPTIPLEX 745 32bit)
Wird da der LSI SAS Controller HBA 9207-8e default mäßig unterstützt?

Ich fand beim Neukompilieren und upgrade auf kernel 2.6.39 im driver verzeichnis Baum das Verzeichnis mpt2sas mit frisch
kompilierten *.o files.

Weiters fand ich auf der LSI.com site, die Driver als ZIP für sles 11, wobei ich versuchte das binery des rpm packages zu installieren. Da kam folgendes als Error.

PHP Code:
rpm -ivh lsi-mpt2sas-kmp-default-18.00.00.00_sles11-1.i586.rpm 

error
Failed dependencies:    
kernel(default:drivers_char) = 9eac313ab2bc8ba4 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:drivers_pci) = 5f289cc7237dbac8 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:kernel) = 3df41a687950fa3d is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:kernel) = 7f1373e539002cf0 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:kernel) = a71f20c04b8e8bc9 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:mm) = f3eb7c17cf1a1604 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:drivers_scsi) = d299ba7adf0f5a0d is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:drivers_scsi) = c7f76710839742bb is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:kernel_irq) = 40f41acbf82d5a9a is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:vmlinux) = de5c7ba437e2813b is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:arch_x86_kernel) = cd0f8682a926a58d is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:block) = 703091c9e6b0f2a5 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:drivers_base) = e2dcb95a5652034f is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:kernel_time) = 737dc055885b5e6f is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:fs) = ae1a6b2a7b8b3b88 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:fs) = bd37340224cf87a7 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:drivers_pci_pcie_aer) = 854ef760629d6c2e is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:lib) = 3ce5e8985356727f is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:arch_x86_mm) = 134ae7c026908908 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586    
kernel
(default:arch_x86_mm) = 322d28c96c238f14 is needed by lsi-mpt2sas-kmp-default-18.00.00.00_2.6.27.19_5-1.i586 
da ich den Controller noch nicht habe, meine Frage: Kommen diese nichtaufgelösten Abhängigkeiten daher, weil der Controller noch nicht eingebaut ist und daher im kernel beim Booten diese Module nicht geladen hat?

Danke für hilfreiche Tips.