Results 1 to 9 of 9

Thread: problem with cups

  1. #1

    Default problem with cups

    Recently I have encounter a problem with cups seems related to cups.socket
    journalctl report:
    Code:
    Jan 31 14:03:09 PC-17.WORKGROUP systemd[1]: cups.socket failed to listen on sockets: Cannot assign requested address
    Jan 31 14:03:09 PC-17.WORKGROUP systemd[1]: Unit cups.socket entered failed state
    a small extract of my cups/error_log
    Code:
    E [18/Jan/2014:15:00:09 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [22/Jan/2014:21:00:47 +0100] Browsing=1
    E [22/Jan/2014:21:00:47 +0100] BrowseLocalProtocols=0
    E [22/Jan/2014:21:00:47 +0100] BrowseRemoteProtocols=1
    E [22/Jan/2014:21:00:47 +0100] BROWSE_CUPS=1
    E [22/Jan/2014:21:00:47 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [23/Jan/2014:14:46:45 +0100] Browsing=1
    E [23/Jan/2014:14:46:45 +0100] BrowseLocalProtocols=0
    E [23/Jan/2014:14:46:45 +0100] BrowseRemoteProtocols=1
    E [23/Jan/2014:14:46:45 +0100] BROWSE_CUPS=1
    E [23/Jan/2014:14:46:45 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [30/Jan/2014:15:29:13 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [30/Jan/2014:15:44:02 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [30/Jan/2014:15:52:45 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [30/Jan/2014:16:07:05 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [30/Jan/2014:16:16:12 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    E [30/Jan/2014:16:22:08 +0100] Unable to bind socket for address [v1.::1]:631 - Cannot assign requested address.
    result of "systemctl status cups.service"
    Code:
    cups.service - CUPS Printing Service
              Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)
              Active: inactive (dead)
              CGroup: name=systemd:/system/cups.service
    and systemctl status cups.socket
    Code:
    cups.socket - CUPS Printing Service Sockets
              Loaded: loaded (/etc/systemd/system/cups.socket; enabled)
              Active: failed (Result: resources)
              CGroup: name=systemd:/system/cups.socket
    
    Jan 31 14:03:09 PC-17.WORKGROUP systemd[1]: Starting CUPS Printing Service Sockets.
    Jan 31 14:03:09 PC-17.WORKGROUP systemd[1]: Failed to listen on CUPS Printing Service Sockets.
    Jan 31 14:03:09 PC-17.WORKGROUP systemd[1]: Unit cups.socket entered failed state
    If I restart manually cups.service after the boot all works fine, but at the next reboot the problem come back.
    I have already tried to disable cups.service and enable it again after a reboot but nothing changes.
    I'm using opensuse 3.7.10-1.24-desktop

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: problem with cups

    On 2014-01-31 17:26, Laskan88 wrote:
    >
    > Recently I have encounter a problem with cups seems related to
    > cups.socket


    Code:
    View this thread: http://forums.opensuse.org/showthread.php?t=494878

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,847
    Blog Entries
    1

    Default Re: problem with cups

    You can either

    1. keep socket activation (with cups.socket enabled), as described in the thread linked to by Carlos

    or

    2. follow the bug report advice to update CUPS with the latest packages from the printing repo. Refer

    https://bugzilla.novell.com/show_bug.cgi?id=857372#c75

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,847
    Blog Entries
    1

    Default Re: problem with cups

    Quote Originally Posted by ScottMorton View Post
    The solution for me was to downgrade both the server and the client systems to cups 1.5.4.5.2.1
    Thanks for the update.

  5. #5

    Default Re: problem with cups

    I tried to add the Printing Repo and set the priority on it to 98 like other repos I have added (packman, etc). CUPS and HPLIP refuse to update to the version that is there. I even bumped it to 97, but still no luck. Any ideas?

    I need CUPS to work when the system boots without me having to manually restart CUPS so that my daughter can do her homework/print stuff without any manual intervention.

    I tried to read the bug report but the discussion was just too long to figure out what the right fix is.

    Thanks in advance.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,847
    Blog Entries
    1

    Default Re: problem with cups

    Quote Originally Posted by Gweeper64 View Post
    I tried to add the Printing Repo and set the priority on it to 98 like other repos I have added (packman, etc). CUPS and HPLIP refuse to update to the version that is there. I even bumped it to 97, but still no luck. Any ideas?
    There should be no need to change priorities. Just add/enable the repo, then
    Code:
    zypper in -f cups
    should have been sufficient to prompt an update from the printing repo.

  7. #7

    Default Re: problem with cups

    On 03/02/2014 07:56 PM, Gweeper64 pecked at the keyboard and wrote:
    > I tried to add the Printing Repo and set the priority on it to 98 like
    > other repos I have added (packman, etc). CUPS and HPLIP refuse to update
    > to the version that is there. I even bumped it to 97, but still no luck.
    > Any ideas?
    >
    > I need CUPS to work when the system boots without me having to manually
    > restart CUPS so that my daughter can do her homework/print stuff without
    > any manual intervention.
    >
    > I tried to read the bug report but the discussion was just too long to
    > figure out what the right fix is.
    >
    > Thanks in advance.
    >
    >


    I would recommend you start YaST Package Management, select the printing
    repo and click near the top to switch system packages to the repo. This
    should be the easiest way to get cups and hplip updated,

    Ken

  8. #8

    Default Re: problem with cups

    Both suggestions worked. Thanks guys. I had not noticed that "Switch system packages" toggle in Yast Package Manager before.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,847
    Blog Entries
    1

    Default Re: problem with cups

    Quote Originally Posted by Gweeper64 View Post
    Both suggestions worked. Thanks guys. I had not noticed that "Switch system packages" toggle in Yast Package Manager before.
    Glad to have been of help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •