Results 1 to 2 of 2

Thread: openSuSE 13.1: XDMCP doesn't autodetect remote hosts

  1. #1

    Default openSuSE 13.1: XDMCP doesn't autodetect remote hosts

    Greetings!

    Although I already got XDMCP up and running, there is still a little drop of bitterness in all this: For some reason my X terminal fails to autodetect my remote X server. I have to manually add the remote server to the XDMCP chooser, which in turn causes it to show up, but then the stats don't get auto-updated.

    What I have done so far is the following:
    * X terminal
    /etc/X11/xdm/Xaccess
    * CHOOSER BROADCAST #uncommented this line

    The line containing only the asterisk stays commented out (I don't want terminals to connect to this box)

    /etc/X11/xdm/xdm-config
    DisplayManager.requestPort: 177

    Just added the XDMCP port number here

    /usr/share/kde4/config/kdm/kdmrc
    [Xdmcp]
    Enable=true
    Port=177


    Is this necessary to be able to receive replies to XDMCP broadcast requests?

    The displaymanager sysconfig is set to not listen to remote queries and to open port 6000/tcp.

    * Remote X server
    /etc/X11/xdm/Xaccess
    * #uncommented this line

    The line dealing with the chooser stays commented out.

    /etc/X11/xdm/xdm-config
    DisplayManager.requestPort: 177

    Just added the XDMCP port number here

    /usr/share/kde4/config/kdm/kdmrc
    [Xdmcp]
    Enable=true
    Port=177


    I have also opened the necessary ports in the firewalls on both machines (i. e. 177/udp in both firewalls in the appropriate zones and 6000/tcp only on the X terminal). I have also allowed XDMCP broadcasts in both firewalls.

    Right now this enables me to
    - Get an X display manually (i. e. X -query <ipaddr>:0)
    - Detect the remote server by explicitly entering its IP address in the chooser
    - Connect to any servers that I have added manually via XDMCP

    However, I want the remote server to automatically show up in the chooser window so I can immediately select it without having to type anything.

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,828

    Default Re: openSuSE 13.1: XDMCP doesn't autodetect remote hosts

    Please, for your next posts, do not use italics, bolds, etc. for copied/pasted computer texts. Paste them between CODE tags. Use the # button in the toolbar of the post editor.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •