Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

  1. #1

    Default OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Hi there,

    I'm using the VirtualBox since a while and was quite happy with it. But I yesterday tried to somehow share my printer over Samba on the LAN. That's when the fun was over: Next time I tried to start VirtualBox the"jumping loading appplication" mouse pointer appeared and after some seconds ... the normal mouse pointer came back and ... nothing ... no error message ... simply nothing. As if I never have treid to start the virtual box. So I had the idea to look in the systgem log. Open Yast and System Log and ... had simply no idea which message was relevant in this context.

    So I decided to unstill the VirtualBox, reboot, install it again and reboot and ... still the same problem. Seems as if the uninstall does not really clean everything as it should do ...

    Started to find information on the internet and found the hint to use dmesg. Got lots of information and several ideas what might be important for me to solve this problem. But this puzzle also did not lead to a solution.

    After adding the repo http://download.opensuse.org/reposit...openSUSE_13.1/ (got the idea from another thread for OS 12.3) I tried the uninstall / Install procedure again and now even this does not work anymore.

    How can I clean old remains of the virtualbox and make a clean new installation ?
    And if virtualbox has a problem during the installation - how can I know what it is ?
    Or is it better/easier/faster to reinstall Opensuse 13.1 ?

  2. #2

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Quote Originally Posted by J0Eeoj View Post
    How can I clean old remains of the virtualbox and make a clean new installation ?
    And if virtualbox has a problem during the installation - how can I know what it is ?
    Or is it better/easier/faster to reinstall Opensuse 13.1 ?
    Which packages do you have installed now?
    Code:
    rpm -qa | grep -i virtualbox
    Try to run it in a terminal window. Do you get an error message?
    Code:
    VirtualBox
    PS: Uninstalling/reinstalling will only remove/readd the files contained in the packages. Other stuff like the configuration or the VMs itself will not be altered.
    Those are found by default in ~/.VirtualBox/ and "~/VirtualBox VMs/".
    You may want to try to rename the ~/.VirtualBox/ folder to do a fresh start. But I actually doubt that the configuration is at fault here.

  3. #3

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Hi Wolfi323,

    thanks a lot for your reply.

    VirtualBox in the konsole does not work, nor does vbox. And su does not help as well
    The systems answers:
    "If 'VirtualBox' is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf VirtualBox"

    Frankly said, I have no idea where Yast2 takes the packages from, what method/stratregy it uses is to handle the instll/uninstall of software.
    Currently it suggests to install virtualbox and virtualbox-host-kmp-desktop, which is less than It did 4 months ago. But at this time it was still OS 12.3, so I though, maybe things have changed slightly and 2 files are sufficient. May it makes sense to chosse alll files which contain a virtualbox string in their name ...

    I used Windows as from WfW 3.11 until now Win7 and my Linux knowledge/experience is now around 4 month old. I develope software with IBM lotus Notes and Eclipse. And made last year the big jump to Linux. And its a big jump indeed, but I'm still able to learn ;-)

    So how can I find out, what yast has done ?

    TIA, Joe

  4. #4

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Have overseen the rpm line. Here is the result:
    rpm -qa | grep -i virtualbox
    virtualbox-host-kmp-desktop-4.3.6_k3.11.6_4-108.7.x86_64
    virtualbox-4.3.6-108.7.x86_64

  5. #5

    Default AW: Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Quote Originally Posted by J0Eeoj View Post
    VirtualBox in the konsole does not work, nor does vbox. And su does not help as well
    The systems answers:
    "If 'VirtualBox' is not a typo you can use command-not-found to lookup the package that contains it, like this: cnf VirtualBox"
    Please uninstall "vboxgtk" and install "virtualbox-qt" instead, that's the official GUI. "vboxgtk" doesn't really work with recent VirtualBox versions (although it should at least start though)

    I guess this will fix all your problems.

    So how can I find out, what yast has done ?
    In YaST's menu, Extras->History.

  6. #6

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Hello Wolfi323,

    yes it did help ! The instalaltion takes place and I can start the VirtualBox again.

    But I get the following error:

    Failed to create the VirtualBox COM object.

    The application will now terminate.
    Details: Callee RC:

    NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)


    Cheers, Joe

  7. #7

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Quote Originally Posted by J0Eeoj View Post
    Failed to create the VirtualBox COM object.

    The application will now terminate.
    Details: Callee RC:

    NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)
    According to Google this could point to a permissions issue in the /tmp directory.
    And this most probably happened because you tried to run VirtualBox as root. (this is never a good idea)

    Try to remove all its temporary files:
    Code:
    sudo rm -r /tmp/.vbox*
    Hopefully it would work then again.

  8. #8

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Wolif323,

    can't find Yast2 -> Extras and no history.

    This is what I get in the Yast2->System Log whe nI try to start teh VirtualBox:

    kernel: [ 7988.964348] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)
    2014-01-31T13:30:01.258886+01:00 Hasty /usr/sbin/cron[5936]: pam_unix(crond:session): session opened for user root by (uid=0)
    2014-01-31T13:30:01.262953+01:00 Hasty systemd[1]: Starting Session 11 of user root.
    2014-01-31T13:30:01.263667+01:00 Hasty systemd[1]: Started Session 11 of user root.
    2014-01-31T13:30:01.293999+01:00 Hasty /USR/SBIN/CRON[5936]: pam_unix(crond:session): session closed for user root
    2014-01-31T13:39:49.160446+01:00 Hasty su: (to joe) joe on none

    2014-01-31T13:39:49.161245+01:00 Hasty su: pam_unix(su:session): session opened for user root by (uid=1000)
    2014-01-31T13:39:49.163215+01:00 Hasty su: pam_systemd(su:session): pam_putenv: delete non-existent entry; XDG_RUNTIME_DIR

  9. #9

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Wolfi323,


    BINGO ! You got 100 points ! It's running again ! Thanks a lot !


    Cheers , Joe

  10. #10

    Default Re: OS 13.1 : VirtualBox does not start any more, uninstall and new install does not help !

    Quote Originally Posted by J0Eeoj View Post
    can't find Yast2 -> Extras and no history.
    The software installation history is in YaST->Software Management:


Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •