Results 1 to 10 of 10

Thread: 13.1 KDE Session init Failed (after deactivating Wallet)

  1. #1

    Default 13.1 KDE Session init Failed (after deactivating Wallet)

    Hello: sorry for my bad english. I come from Spanish forum; without solutions! I was enjoying my Open Suse KDE many weeks, until I`ve maked some kind of mistake. I hated KWallet, cause each init of any session, asked me the Wallet key, to activate Internet connection. Then, when I tryed to initiate a new session, the Login screen (that never was there before!) appears and...the keys (root or user) are not recongnized! "Session Init Failed", again and again. I`ve tryed to change de root passwd ( with Wiki instructions), but nothing changes!

    Please Help!

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    On 2014-01-31 02:56, pandasuse wrote:
    >
    > Hello: sorry for my bad english. I come from Spanish forum; without
    > solutions! I was enjoying my Open Suse KDE many weeks, until I`ve maked
    > some kind of mistake. I hated KWallet, cause each init of any session,
    > asked me the Wallet key, to activate Internet connection. Then, when I
    > tryed to initiate a new session, the Login screen (that never was there
    > before!) appears and...the keys (root or user) are not recongnized!
    > "Session Init Failed", again and again. I`ve tryed to change de root
    > passwd ( with Wiki instructions), but nothing changes!


    Try to login in text mode. Type [Ctrl][Alt][F1], and try there your
    login and password.

    This is not to make you work in text mode, but to find out if it works.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    Thanks. I`ve tryed in text mode; but...the keys (both) are not recognized!

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    On 2014-01-31 04:16, pandasuse wrote:
    >
    > Thanks. I`ve tryed in text mode; but...the keys (both) are not
    > recognized!


    For keys you mean the "contraseñas"? That's "password" in English. Keys
    will be understood here as "las teclas del teclado".

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  5. #5

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    Yes, Carlos, Passwords (user and root keys) not recognized, when tryed session login...

  6. #6

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    Quote Originally Posted by pandasuse View Post
    Hello: sorry for my bad english. I come from Spanish forum; without solutions! I was enjoying my Open Suse KDE many weeks, until I`ve maked some kind of mistake. I hated KWallet, cause each init of any session, asked me the Wallet key, to activate Internet connection.
    Just set an empty password for your wallet and you won't be asked anymore.

    Then, when I tryed to initiate a new session, the Login screen (that never was there before!) appears and...the keys (root or user) are not recongnized! "Session Init Failed", again and again. I`ve tryed to change de root passwd ( with Wiki instructions), but nothing changes!
    How did you change the password?
    IIUYC you can't even log in as root, right?

    The login screen appears because the automatic login fails, so that's quite normal regarding the circumstances.

    Do the following:
    Press 'e' at the boot menu, search for the line starting with "linux", append "init=/bin/sh" to then end of that line, and press F10 to boot.
    You should get to a text mode prompt then, without having to login.

    Change the root password there, by running "passwd".

    OTOH your problem doesn't really sound like wrong passwords.
    Did you uninstall anything?
    Maybe your PAM configuration is screwed up?

    Have a look at ~/.xsession-errors-:0 and /var/log/kdm.log (provided you are using KDM), maybe there's some clue there.

  7. #7

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    Thanks a lot. Many items

    1) About your question ":How did you change the password?" The answer is in your indication "Press 'e' at the boot menu, search for the line starting with "linux", append "init=/bin/sh" to then end of that line, and press F10 to boot.
    You should get to a text mode prompt then, without having to login.
    Change the root password there, by running "passwd"."

    I changed the password (a tex says "succesfull", but I couldn`t restart the system (with startx, it runs a short time and ...frozen!)

    2) About ~/.xsession-errors-:0: in this link: http://tny.cz/650bf3fb


    3) I think, too, that is not about passwords, the central problem. I dont have uninstalled anything. I only maked a Grub2 update, via YaST, cause I liked the clean visual organization of boot screen. And, the mentioned "error" (I think); deselection of KWallet via YaST

    I`ll continue investigating (lucky to me, I have Korora, Manjaro and Debian, in multiboot Grub2)

  8. #8

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    And the last /Var/Log/Kdm.log: http://tny.cz/8f169287

  9. #9

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    Quote Originally Posted by pandasuse View Post
    2) About ~/.xsession-errors-:0: in this link: http://tny.cz/650bf3fb
    The most obvious in there are DBUS errors. And kdm.log says this:
    Code:
    klauncher(1051) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
    kdeinit4: Communication error with launcher. Exiting!
    So apparently DBUS is not running, or something is wrong with your DBUS installation.

    Please check that the packages "dbus-1" and "dbus-1-x11" are installed.

    3) I think, too, that is not about passwords, the central problem. I dont have uninstalled anything. I only maked a Grub2 update, via YaST, cause I liked the clean visual organization of boot screen. And, the mentioned "error" (I think); deselection of KWallet via YaST
    What does that mean? YaST has no option about KWallet anywhere AFAIK.
    So please, how exactly did you "deactivate" KWallet.
    Normally deactivating KWallet cannot cause something like this. It is a KDE thing, how should it prevent logging in in text mode anyway.

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 13.1 KDE Session init Failed (after deactivating Wallet)

    On 2014-02-01 01:36, pandasuse wrote:
    >
    > Thanks a lot. Many items
    >
    > 1) About your question ":How did you change the password?" The answer is
    > in your indication "Press 'e' at the boot menu, search for the line
    > starting with "linux", append "init=/bin/sh" to then end of that line,
    > and press F10 to boot.
    > You should get to a text mode prompt then, without having to login.
    > Change the root password there, by running "passwd"."


    That's what you did today, or did you do it before?

    > I changed the password (a tex says "succesfull", but I couldn`t restart
    > the system (with startx, it runs a short time and ...frozen!)


    After doing that emergency password change you have to reboot.


    > 3) I think, too, that is not about passwords, the central problem.


    Password is the first problem to handle. You can do nothing to your
    system till you can log in.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •