Results 1 to 6 of 6

Thread: Wired connection works on his own way

  1. #1
    Join Date
    Jul 2009
    Location
    Spain
    Posts
    52

    Question Wired connection works on his own way

    Hello

    I'm using OpenSUSE on my HTPC since 11.3 version. No hardware or LAN changes since then. However, from OpenSUSE 12.2, wired conecction is working his own way. Even now, when I installed from scratch OpenSUSE 13.1, the same problem. The problem is this: When I boot OpenSUSE, mostly Network Manager plasmoid says "No wired connection". But the wire is connected and the LAN it's working ok. However, if I enable/disable repeatedly "Enable networking" on the NetworkManager plasmoid (see images in https://spideroak.com/browse/share/C...iderOAK/Images , "Habilitar redes" in my Spanish KDE interface), finally, OpenSUSE detect my wire is connected and all works fine. If I reboot my machine or suspend it or even I disable and enable "Enable networking" option in network manager, it can or not appear wired connected, and must repeat the trick ... enablng and disabling repeatedly the network. I even tried to manage the network configuration with "ifup", but the result was the same, so finally I'm working with NetworkManager but I'm tired of do the trick.

    The screenshots show the different states and info in the two situations, but the cat5 cable is always connected despite OpenSUSE said it's not, and, yes, I tried with other computer on the same cable and worked fine.

    Please, any suggestion?

    Thank you

    Additonal info:
    02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 03)
    Subsystem: ASRock Incorporation Motherboard (one of many) [1849:8168]
    Kernel driver in use: r8169
    Kernel modules: r8169

    Settings for eth0:
    Supported ports: [ TP MII ]
    Supported link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Supported pause frame use: No
    Supports auto-negotiation: Yes
    Advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    1000baseT/Half 1000baseT/Full
    Advertised pause frame use: Symmetric Receive-only
    Advertised auto-negotiation: Yes
    Link partner advertised link modes: 10baseT/Half 10baseT/Full
    100baseT/Half 100baseT/Full
    Link partner advertised pause frame use: Symmetric
    Link partner advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 0
    Transceiver: internal
    Auto-negotiation: on
    Supports Wake-on: pumbg
    Wake-on: g
    Current message level: 0x00000033 (51)
    drv probe ifdown ifup
    Link detected: yes

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Wired connection works on his own way

    When I interprete this correctly, you talk about openSUSE13.1. But in 13.1 there is normaly no eth0. Thus I am interested on how you got the information you show.

    And please remember that we like computer text copied/pasted completely (prompt and command you used, output up to and including next prompt) between CODE tags in a post. You get the CODE tags by clicking on the # button in the toolbar of the posteditor.
    Henk van Velden

  3. #3
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: Wired connection works on his own way

    try to set up statci route thorugh yast->network devices. try to read this thread https://forums.opensuse.org/showthre...t-script/page2
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  4. #4
    Join Date
    Jul 2009
    Location
    Spain
    Posts
    52

    Default Re: Wired connection works on his own way

    Quote Originally Posted by hcvv View Post
    When I interprete this correctly, you talk about openSUSE13.1. But in 13.1 there is normaly no eth0. Thus I am interested on how you got the information you show.

    And please remember that we like computer text copied/pasted completely (prompt and command you used, output up to and including next prompt) between CODE tags in a post. You get the CODE tags by clicking on the # button in the toolbar of the posteditor.
    First, thank you. I didn't take into account the QUOTE tags and the command given to obtain the data I pasted. And you are not wrong: Is OpenSUSE 13.1. Even this computer where I am writing is OpenSUSE 13.1 and have eth0 and eth1. Anyway, this is the info I think could be interesting:

    Code:
    # ip link
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
        link/ether 00:25:22:34:ae:71 brd ff:ff:ff:ff:ff:ff
    Code:
    # ethtool -i eth0
    driver: r8169
    version: 2.3LK-NAPI
    firmware-version: rtl_nic/rtl8168d-1.fw
    bus-info: 0000:02:00.0
    supports-statistics: yes
    supports-test: no
    supports-eeprom-access: no
    supports-register-dump: yes
    supports-priv-flags: no
    Code:
    # ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:25:22:34:AE:71  
              inet addr:10.0.0.11  Bcast:10.0.0.255  Mask:255.255.255.0
              inet6 addr: fe80::225:22ff:fe34:ae71/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:9825 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6446 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:9284897 (8.8 Mb)  TX bytes:1135093 (1.0 Mb)
    
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:578 errors:0 dropped:0 overruns:0 frame:0
              TX packets:578 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:235807 (230.2 Kb)  TX bytes:235807 (230.2 Kb)
    Code:
     # /usr/sbin/ethtool eth0
    Settings for eth0:
            Supported ports: [ TP MII ]
            Supported link modes:   10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
                                    1000baseT/Half 1000baseT/Full 
            Supported pause frame use: No
            Supports auto-negotiation: Yes
            Advertised link modes:  10baseT/Half 10baseT/Full 
                                    100baseT/Half 100baseT/Full 
                                    1000baseT/Half 1000baseT/Full 
            Advertised pause frame use: Symmetric Receive-only
            Advertised auto-negotiation: Yes
            Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                                 100baseT/Half 100baseT/Full 
            Link partner advertised pause frame use: Symmetric
            Link partner advertised auto-negotiation: Yes
            Speed: 100Mb/s
            Duplex: Full
            Port: MII
            PHYAD: 0
            Transceiver: internal
            Auto-negotiation: on
            Supports Wake-on: pumbg
            Wake-on: d
            Current message level: 0x00000033 (51)
                                   drv probe ifdown ifup
            Link detected: yes
    Code:
    # hwinfo --network_ctrl
    31: PCI 200.0: 0200 Ethernet controller                         
      [Created at pci.319]
      Unique ID: rBUF.eRvPGez0JmE
      Parent ID: CvwD.plOtpExq958
      SysFS ID: /devices/pci0000:00/0000:00:05.0/0000:02:00.0
      SysFS BusID: 0000:02:00.0
      Hardware Class: network
      Model: "Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller"
      Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
      Device: pci 0x8168 "RTL8111/8168B PCI Express Gigabit Ethernet controller"
      SubVendor: pci 0x1849 "ASRock Incorporation"
      SubDevice: pci 0x8168 "Motherboard (one of many)"
      Revision: 0x03
      Driver: "r8169"
      Driver Modules: "r8169"
      Device File: eth0
      I/O Ports: 0xe800-0xe8ff (rw)
      Memory Range: 0xfbfff000-0xfbffffff (ro,non-prefetchable)
      Memory Range: 0xfbff8000-0xfbffbfff (ro,non-prefetchable)
      Memory Range: 0xfeae0000-0xfeafffff (ro,non-prefetchable,disabled)
      IRQ: 42 (146678 events)
      HW Address: 00:25:22:34:ae:71
      Link detected: yes
      Module Alias: "pci:v000010ECd00008168sv00001849sd00008168bc02sc00i00"
      Driver Info #0:
        Driver Status: r8169 is active
        Driver Activation Cmd: "modprobe r8169"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #10 (PCI bridge)
    If I missed some information, please, tell me it.

    roberto68
    try to set up statci route thorugh yast->network devices. try to read this thread https://forums.opensuse.org/showthre...t-script/page2
    Hi Roberto. I read the article. In fact, as a last try to solve my problem, I had assigned in my router a static IP for the MAC of my HTPC (as you can see in the image), but that didn't solve nothing. The problem persist and I must do the trick of "enable/disable" networking. I don't know if I can see detailed information in some log file about what's happening each time I enable or disable networking, cause maybe it will show any evidence about the error.

    Thank you in advance

  5. #5
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    568

    Default Re: Wired connection works on his own way

    Quote Originally Posted by faleloncio View Post



    Hi Roberto. I read the article. In fact, as a last try to solve my problem, I had assigned in my router a static IP for the MAC of my HTPC (as you can see in the image), but that didn't solve nothing. The problem persist and I must do the trick of "enable/disable" networking. I don't know if I can see detailed information in some log file about what's happening each time I enable or disable networking, cause maybe it will show any evidence about the error.

    Thank you in advance
    Hi faleloncio,
    I think you got that wrong. Roberto was referring to a static route from your HTPC to your router using YaST on your HTPC.
    The output of
    Code:
    route
    might then be of interest.

  6. #6
    Join Date
    Jul 2009
    Location
    Spain
    Posts
    52

    Unhappy Re: Wired connection works on his own way

    This is what route command show me:

    Code:
    # route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         10.0.0.1        0.0.0.0         UG    0      0        0 eth0
    10.0.0.0        *               255.255.255.0   U     1      0        0 eth0
    loopback        *               255.0.0.0       U     0      0        0 lo
    link-local      *               255.255.0.0     U     0      0        0 eth0
    I just wake up my HTPC from Suspend mode and, as I was guessing, NetworkManager said that there was not a wire attached . Taking a look to dmesg, we can see an entry for each time I enabled/disabled networking till magically NetworkManager accepted my wire is plugged .

    Code:
     # dmesg | grep -e eth0 -e bcm
    [  145.224014] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [  145.660241] r8169 0000:02:00.0 eth0: link down
    [  145.660312] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [  146.043655] r8169 0000:02:00.0 eth0: link down
    [  146.043729] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [  147.909449] r8169 0000:02:00.0 eth0: link up
    [  147.909459] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 7351.303668] r8169 0000:02:00.0 eth0: link down
    [ 7351.303740] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 7351.306167] r8169 0000:02:00.0 eth0: link down
    [ 7352.927601] r8169 0000:02:00.0 eth0: link up
    [ 7352.927621] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 7357.361399] r8169 0000:02:00.0 eth0: link down
    [ 7370.390194] r8169 0000:02:00.0 eth0: link down
    [ 7370.390239] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [72503.337892] r8169 0000:02:00.0 eth0: link down
    [72503.338043] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [72506.230290] r8169 0000:02:00.0 eth0: link down
    [72506.230336] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [72506.687657] r8169 0000:02:00.0 eth0: link down
    [72506.687702] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [72507.100007] r8169 0000:02:00.0 eth0: link down
    [72507.100053] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [72507.401245] r8169 0000:02:00.0 eth0: link down
    [72507.401327] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [72508.248962] r8169 0000:02:00.0 eth0: link down
    [72508.249009] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [72509.914808] r8169 0000:02:00.0 eth0: link up
    [72509.914821] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

    I begin to think is some kernel problem, cause is only happening from a version and not after that version.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •