Results 1 to 4 of 4

Thread: yast online update has error and wont update

  1. #1

    Default yast online update has error and wont update

    I use opensuse 13.1 64 bit on a toshiba satellite l355-s7902
    I ran online update and it finished with an error
    from the yast screen-- " Subprocess failed. Error: RPM failed: error: package kdepim4-4.11.3-48.4.x86_64 is not installed "

    I tried to install this package from a terminal with zypper
    Code:
    walter@linux-4z66:~> sudo zypper in kdepim4-4.11.3-48.4.x86_64
    root's password:
    Loading repository data...
    Reading installed packages...
    The selected package 'kdepim4-4.11.3-48.4.x86_64' from repository 'openSUSE-13.1-Update' has lower version than the installed one. Use 'zypper install --oldpackage kdepim4-4.11.3-48.4.x86_64' to force installation of the package.
    Resolving package dependencies...
    
    
    Nothing to do.
    I then tried to install the latest version to try and get it to update

    Code:
    walter@linux-4z66:~> sudo zypper in kdepim4-4.11.4-444.11
    Loading repository data...
    Reading installed packages...
    'kdepim4 = 4.11.4-444.11' is already installed.
    No update candidate for 'kdepim4-4.11.4-444.11.x86_64'. The highest available version is already installed.
    Resolving package dependencies...
    
    
    Nothing to do.
    walter@linux-4z66:~>
    So I see that the error is that an older package is not installed and that the newer package is
    I also think that not all of the kedpim packages were installed
    I suspect that I had an interruption in the internet connection during the update

    How can I clear out the error in the yast online updater without a reinstall of opensuse and rerun the updater ?

    thank you

    wsams

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: yast online update has error and wont update

    On 2014-01-29 22:26, wallybsams wrote:
    >
    > I use opensuse 13.1 64 bit on a toshiba satellite l355-s7902
    > I ran online update and it finished with an error
    > from the yast screen-- " Subprocess failed. Error: RPM failed: error:
    > package kdepim4-4.11.3-48.4.x86_64 is not installed "
    >
    > I tried to install this package from a terminal with zypper


    You have to run "zypper patch" to do the same thing as the online update
    does.


    > Code:
    > --------------------
    >
    > walter@linux-4z66:~> sudo zypper in kdepim4-4.11.4-444.11
    > Loading repository data...
    > Reading installed packages...
    > 'kdepim4 = 4.11.4-444.11' is already installed.
    > No update candidate for 'kdepim4-4.11.4-444.11.x86_64'. The highest available version is already installed.
    > Resolving package dependencies...
    >
    >
    > Nothing to do.
    > walter@linux-4z66:~>
    >
    > --------------------


    Apparently you already have the newest package available.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3

    Thumbs up Re: yast online update has error and wont update 'SOLVED'

    Thank you Carlos

    I did not know what the patch would do, I will likely use zypper to run the updates in the future ,

    I solved the issue of yast not working due to the older kdepim hanging in the cache by running
    as root

    Code:
     rpm --rebuilddb
    , then opening yast , online update and running it again it removed the old file and was happy

    wsams

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,143

    Default Re: yast online update has error and wont update

    Good solution! When, after some trials and debugging you still can not find what is wrong, in such a case as this, a rebuilddb may help and I guess it can not harm very much.

    And, like Carlos explained, zypper patch is for the patches (and the like) in the two Update repos. When you want to go for newer version in e.g. your Pcakman repo, zypper up will do that.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •