Results 1 to 4 of 4

Thread: How to set wireless USB headphones as default sound card for applciations

  1. #1

    Default How to set wireless USB headphones as default sound card for applciations

    I have Logitech wireless USB headphones. I have the system recognizing the headphones and I can play the test music clip in the sound setup under YAST. The problem is how do I get the application to recognize the headphones. YAST shows three sound cards as follows


    0 - Logitech USB headphones (this is set as default)
    1 - A HMDI port on the ATI card
    2 - SBx00 Azalia

    the driver for the Logitech headphones is snb-usb-audio

    When I try to play a wav file using Amarok or VLC there is no option for the headphones even if I try to configure the backend which BTW resets as soon as I apply and exit. The headphones also do not appear in Kmixer.

  2. #2

    Default Re: How to set wireless USB headphones as default sound card for applciations

    You may need to install pulse plugins.
    Go to yast2-software management and
    search for "pulse" and post back.
    People who do not break things first will never learn to create anything

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: How to set wireless USB headphones as default sound card for applciations

    You can configure the USB headphones in YaST.

    if the test sound works in YaST (which has root permissions) but not as a regular user there are a couple of possibilities that come to my mind.

    • there is a permissions problem, and/or
    • the applications are assigned in pulse to send the audio to a device other than the USB headphones


    One can control where pulse audio sends the audio, on an application basis, using the program pulse audio volume control (pavucontrol).

    Here are a couple of blog links with information on using pavucontrol:




    Good luck, and thankyou for posting.

  4. #4

    Default Re: How to set wireless USB headphones as default sound card for applciations

    Quote Originally Posted by oldcpu View Post
    You can configure the USB headphones in YaST.

    if the test sound works in YaST (which has root permissions) but not as a regular user there are a couple of possibilities that come to my mind.

    • there is a permissions problem, and/or
    • the applications are assigned in pulse to send the audio to a device other than the USB headphones


    One can control where pulse audio sends the audio, on an application basis, using the program pulse audio volume control (pavucontrol).

    Here are a couple of blog links with information on using pavucontrol:




    Good luck, and thankyou for posting.
    I think that the OP USB headphone maybe work just like a usb speaker.
    I have a bose usb speaker and I made it as the primary sound in yast
    enable the simultaneous sound in paprefs and use pavucontrol and xfce4-mixer
    to configure the sound output device and playback.
    People who do not break things first will never learn to create anything

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •