Results 1 to 3 of 3

Thread: Inconsistent /etc/passwd and /etc/shadow after 13.1 installation

  1. #1
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Inconsistent /etc/passwd and /etc/shadow after 13.1 installation

    A rather new 13.1 installation (in fact also on two other 13.1 systems):
    Code:
    boven:~ # pwck
    no matching password file entry in /etc/shadow
    add user 'avahi-autoipd' in /etc/shadow? n
    no matching password file entry in /etc/shadow
    add user 'mysql' in /etc/shadow? n
    user 'pulse': directory '/var/lib/pulseaudio' does not exist
    user 'usbmux': directory '/var/lib/usbmuxd' does not exist
    pwck: no changes
    boven:~ #
    IMHO the first should not be the case. Two users in /etc/passwd do not have a corresponding entry in /etc/shadow.

    Code:
    boven:~ # grep pulse /etc/passwd
    pulse:x:488:487:PulseAudio daemon:/var/lib/pulseaudio:/sbin/nologin
    boven:~ # grep usbmux /etc/passwd
    usbmux:x:497:65534:usbmuxd daemon:/var/lib/usbmuxd:/sbin/nologin
    boven:~ #
    And two users have a non-existing home directory. Now that is not realy a problem, but a bit strange (you could either leave the field empty, or put something usefull in here).

    Any ideas, specialy about the missing shadow entries? Should this be reported as a bug?
    Henk van Velden

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,681
    Blog Entries
    3

    Default Re: Inconsistent /etc/passwd and /etc/shadow after 13.1 installation

    Quote Originally Posted by hcvv View Post
    A rather new 13.1 installation (in fact also on two other 13.1 systems):
    [CODE]boven:~ # pwck
    no matching password file entry in /etc/shadow
    add user 'avahi-autoipd' in /etc/shadow? n
    no matching password file entry in /etc/shadow
    add user 'mysql' in /etc/shadow? n
    I am seeing that problem with "avahi-autoipd". But I do not see a problem with "mysql". On my system, there is an entry in "/etc/shadow".

    I am not at all troubled by the missing home directories. That could be the situation for most users, if "/home" is not mounted (perhaps during repairs).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: Inconsistent /etc/passwd and /etc/shadow after 13.1 installation

    Hm, strange that you do have mysql in the shadow file. I miss it in two systems. In one of them I installed the LAMP pattern and I use the MySQL database (well, I guess MariaDB) for the web-server. So that does not make any difference.

    As I said, the missing home directories are not that problematic. But when you, as package builder, fill in something, it better should be something real or nill. I would call this sloppy.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •