Results 1 to 3 of 3

Thread: Install vmware player 6 with kernel 3.13?

  1. #1

    Default Install vmware player 6 with kernel 3.13?

    Good afternoon,

    I am wanting to install vmware player 6.0.1 on opensuse 13.1 with kernel-desktop 3.13.0-1.g4b6e17a.
    Installed correctly but I get error:

    Log for VMware Workstation pid=6060 version=10.0.1 build=build-1379776 option=Release
    The process is 64-bit.
    Host codepage=UTF-8 encoding=UTF-8
    Host is Linux 3.13.0-1.g4b6e17a-desktop openSUSE 13.1 (Bottle) (x86_64)
    Msg_Reset:
    [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No existe el fichero o el directorio.
    ----------------------------------------
    PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
    Msg_Reset:
    [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No existe el fichero o el directorio.
    ----------------------------------------
    PREF Optional preferences file not found at /root/.vmware/config. Using default values.
    PREF Unable to check permissions for preferences file.
    Msg_Reset:
    [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No existe el fichero o el directorio.
    ----------------------------------------
    PREF Failed to load user preferences.
    Logging to /tmp/vmware-root/vmware-modconfig-6060.log
    System distribution is SuSE
    System version is 13.1
    Obtaining info using the running kernel.
    Created new pathsHash.
    Setting header path for 3.13.0-1.g4b6e17a-desktop to "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include".
    Validating path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for kernel release "3.13.0-1.g4b6e17a-desktop".
    Failed to find /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h
    /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    using /usr/bin/gcc for preprocess check
    Preprocessed UTS_RELEASE, got value "3.13.0-1.g4b6e17a-desktop".
    The header path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for the kernel "3.13.0-1.g4b6e17a-desktop" is valid. Whoohoo!
    Reading in info for the vmmon module.
    Reading in info for the vmnet module.
    Reading in info for the vmblock module.
    Reading in info for the vmci module.
    Reading in info for the vsock module.
    Setting vsock to depend on vmci.
    Invoking modinfo on "vmmon".
    "/sbin/modinfo" exited with status 0.
    Invoking modinfo on "vmnet".
    "/sbin/modinfo" exited with status 256.
    Invoking modinfo on "vmblock".
    "/sbin/modinfo" exited with status 256.
    Invoking modinfo on "vmci".
    "/sbin/modinfo" exited with status 256.
    Invoking modinfo on "vsock".
    "/sbin/modinfo" exited with status 0.
    o be installed: vmnet status: 0
    Obtaining info using the running kernel.
    Setting header path for 3.13.0-1.g4b6e17a-desktop to "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include".
    Validating path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for kernel release "3.13.0-1.g4b6e17a-desktop".
    Failed to find /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h
    /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    using /usr/bin/gcc for preprocess check
    Preprocessed UTS_RELEASE, got value "3.13.0-1.g4b6e17a-desktop".
    The header path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for the kernel "3.13.0-1.g4b6e17a-desktop" is valid. Whoohoo!
    Kernel header path retrieved from FileEntry: /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include
    Update kernel header path to /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include
    Validating path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for kernel release "3.13.0-1.g4b6e17a-desktop".
    Failed to find /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h
    /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    using /usr/bin/gcc for preprocess check
    Preprocessed UTS_RELEASE, got value "3.13.0-1.g4b6e17a-desktop".
    The header path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for the kernel "3.13.0-1.g4b6e17a-desktop" is valid. Whoohoo!
    Found compiler at "/usr/bin/gcc"
    Got gcc version "4.8".
    GCC minor version 4 does not match Kernel GCC minor version 4. But that is ok.
    Using user supplied compiler "/usr/bin/gcc".
    Got gcc version "4.8".
    GCC minor version 4 does not match Kernel GCC minor version 4. But that is ok.
    Trying to find a suitable PBM set for kernel "3.13.0-1.g4b6e17a-desktop".
    No matching PBM set was found for kernel "3.13.0-1.g4b6e17a-desktop".
    GCC minor version 4 does not match Kernel GCC minor version 4. But that is ok.
    Validating path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for kernel release "3.13.0-1.g4b6e17a-desktop".
    Failed to find /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h
    /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    using /usr/bin/gcc for preprocess check
    Preprocessed UTS_RELEASE, got value "3.13.0-1.g4b6e17a-desktop".
    The header path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for the kernel "3.13.0-1.g4b6e17a-desktop" is valid. Whoohoo!
    GCC minor version 4 does not match Kernel GCC minor version 4. But that is ok.
    Validating path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for kernel release "3.13.0-1.g4b6e17a-desktop".
    Failed to find /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h
    /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    using /usr/bin/gcc for preprocess check
    Preprocessed UTS_RELEASE, got value "3.13.0-1.g4b6e17a-desktop".
    The header path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for the kernel "3.13.0-1.g4b6e17a-desktop" is valid. Whoohoo!
    Using temp dir "/tmp".
    Obtaining info using the running kernel.
    Setting header path for 3.13.0-1.g4b6e17a-desktop to "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include".
    Validating path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for kernel release "3.13.0-1.g4b6e17a-desktop".
    Failed to find /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h
    /lib/modules/3.13.0-1.g4b6e17a-desktop/build/include/linux/version.h not found, looking for generated/uapi/linux/version.h instead.
    using /usr/bin/gcc for preprocess check
    Preprocessed UTS_RELEASE, got value "3.13.0-1.g4b6e17a-desktop".
    The header path "/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include" for the kernel "3.13.0-1.g4b6e17a-desktop" is valid. Whoohoo!
    Invoking modinfo on "vmnet".
    "/sbin/modinfo" exited with status 256.
    Setting destination path for vmnet to "/lib/modules/3.13.0-1.g4b6e17a-desktop/misc/vmnet.ko".
    Extracting the vmnet source from "/usr/lib/vmware/modules/source/vmnet.tar".
    Successfully extracted the vmnet source.
    Building module with command "/usr/bin/make -j8 -C /tmp/modconfig-yc3BKB/vmnet-only auto-build HEADER_DIR=/lib/modules/3.13.0-1.g4b6e17a-desktop/build/include CC=/usr/bin/gcc IS_GCC_3=no"
    Failed to build vmnet. Failed to execute the build command.



    I followed the steps on the following page: https://communities.vmware.com/thread/464815 but I get the following error:
    patching file filter.c
    Hunk # 2 FAILED at 204.
    Hunk # 3 succeeded at 257 (offset 4 lines).
    1 out of 3 hunks FAILED - saving rejects to file filter.c.rej

    What I can do? A greeting.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Install vmware player 6 with kernel 3.13?

    On 2014-01-27 21:26, guillep84 wrote:
    >
    > Good afternoon,
    >
    > I am wanting to install vmware player 6.0.1 on opensuse 13.1 with
    > kernel-desktop 3.13.0-1.g4b6e17a.
    > Installed correctly but I get error:
    >
    > LOG FOR VMWARE WORKSTATION PID=6060 VERSION=10.0.1 BUILD=BUILD-1379776
    > OPTION=RELEASE
    > THE PROCESS IS 64-BIT.


    Two requests or comments:

    Please use code tags for printouts and commands (the '#' button in the
    forum editor).

    View this post and the next

    Posting in
    Code Tags - A Guide



    The other.

    When the system language is not English, you should do,
    in order to post here, like this:


    Code:
    minas-tirith:~ # LANG=en_US.UTF-8 zypper info kvm
    Loading repository data...
    Warning: Repository 'openSUSE-11.4-Update' appears to outdated. Consider
    using a different mirror or server.
    Reading installed packages...

    or this:

    Code:
    minas-tirith:~ # LANG=C zypper info kvm
    Loading repository data...
    Warning: Repository 'openSUSE-11.4-Update' appears to outdated. Consider
    using a different mirror or server.
    Reading installed packages...
    ^C

    That way we can all read it, regardless of local languages of sender and
    reader. It is not a permanent change, it only applies to one command.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Install vmware player 6 with kernel 3.13?

    The VMware communities thread you referenced is a bit confusing.

    Important to note is that there are at least 3 downloadable versions of patches in that thread (that I've counted).

    I'm a bit unclear about some specifics in the thread, but the first patch listed <definitely> should not be used. Either the second or third patch should be used, the second is an update that obsoletes the first patch and I'm unclear if the third is a standalone patch or merely some kind of diff patch.

    If you stlll continue to have problems, maybe that thread is actually where you should post so that the authors of the patch can look at exactly what you're doing.

    HTH,
    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •