Results 1 to 10 of 10

Thread: No Internet Access

  1. #1

    Default No Internet Access

    Prior to installing opensuse (v12.3), I installed Ubuntu and Fedora. Both Ubuntu and Fedora automatically setup internet access but the opensuse installation did not. What is required to get opensuse to setup internet access?

  2. #2

    Default Re: No Internet Access

    Quote Originally Posted by aqualion View Post
    Prior to installing opensuse (v12.3), I installed Ubuntu and Fedora. Both Ubuntu and Fedora automatically setup internet access but the opensuse installation did not. What is required to get opensuse to setup internet access?
    More information, please.
    Do you connect with a wire or wireless?
    Waht hardware?
    Code:
    lspci -nnk
    A wired connection should be setup automatically.
    If you want to use the Desktop's NetworkManager applet you may have to enable NetworkManager first:
    YaST->Network Devices->Network Settings->Global Options.
    If this is set to "Traditional Method with ifup", you have to configure the connection in YaST.

  3. #3

    Default Re: No Internet Access

    I have a wired connection. I don't know what information you want by asking what hardware I have.
    Regarding YaST, I found that Traditional Method with ifup was selected. May I ask what steps I take next?

  4. #4

    Default Re: No Internet Access

    Quote Originally Posted by aqualion View Post
    I don't know what information you want by asking what hardware I have.
    Run the command I gave you in a terminal window and post the output.

    On second thought, you may have to run it this way though:
    Code:
    /sbin/lspci -nnk
    Regarding YaST, I found that Traditional Method with ifup was selected. May I ask what steps I take next?
    That should be fine for a wired connection.
    Is your interface shown in the "Overview" tab?
    And what does it say there when you select it?
    Maybe post a screenshot.

    Maybe you need to install a driver for your interface to work, that's why I asked for your hardware.

  5. #5

    Default Re: No Internet Access

    In the overview tab is the following: RTL8111/8168B PCI Express Gigabit Ethernet controller. Under IP Address it says "None."

    "Maybe post a screenshot." How would I do that? I'm communicating from a different computer.

    I don't know how to use a terminal window. I'm trying to move from WinXP to Linux and don't have that knowledge.

  6. #6

    Default Re: No Internet Access

    Well, I see now that you use 12.3 (don't know why I overlooked that... )
    There was a bug in 12.3 that could cause no working network after the installation. It should be enough to just restart your system though.
    Did you reboot already?

    If that doesn't help, try to switch to NetworkManager in YaST-Network Devices->Network Settings->Global Options and press OK.
    You may switch back to ifup afterwards, this should work as well, then. (there was another bug in which the network services weren't setup correctly. By switching between the methods this should get fixed.)

    If that doesn't help either, see the following answers.

    Quote Originally Posted by aqualion View Post
    In the overview tab is the following: RTL8111/8168B PCI Express Gigabit Ethernet controller. Under IP Address it says "None."
    OK. So apparently you just have no IP address.
    Select your network interface and click on Edit. Enable "Dynamic Address" and set it to "DHCP".
    Or set it to "Static Address" and enter a valid address below that if that's necessary in your network (but I guess not, since the network worked automatically in Fedora and Ubuntu).

    "Maybe post a screenshot." How would I do that? I'm communicating from a different computer.
    Press "PrintScr" on the keyboard and KSnapshot should start (if not you should be able to start it from the startmenu). Save the screenshot to an USB Stick or similar and transfer it to the other system.

    Or take a picture with a digital camera.

    But I think that screenshot is not necessary anymore. That was just a suggestion.

    I don't know how to use a terminal window. I'm trying to move from WinXP to Linux and don't have that knowledge.
    Just run "Konsole" from the start menu and enter the command I gave you (press "Return" afterwards).
    There is something similar in Windows, called CMD or PowerShell.

  7. #7

    Default Re: No Internet Access

    Yes, I saw that release note about rebooting but that is not helpful.
    Sorry, I can't find "Konsole" or a start button. Is there something in the System Settings that will give me a start button?
    On the Address tab, I selected Dynamic Address and then selected DHCP. That didn't give me a connection to the internet.

  8. #8

    Default Re: No Internet Access

    Quote Originally Posted by aqualion View Post
    Sorry, I can't find "Konsole" or a start button. Is there something in the System Settings that will give me a start button?
    What Desktop are you using then?
    In KDE the "start" button should be in the bottom-left corner.

    You can also press Alt+F2 and you should get a simple command line. Type "konsole" in there or "gnome-terminal" if you're using GNOME.
    If none of them work, try "xterm".

    On the Address tab, I selected Dynamic Address and then selected DHCP. That didn't give me a connection to the internet.
    And did you try to switch between ifup and NetworkManager as I suggested?

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: No Internet Access

    Trying not to step on any previous suggestions,

    After first installing, networking may not be automatically started. Rebooting is the simplest solution although it's possible to stop/restart networking services.

    After rebooting,
    If your networking is still down, then it's useful to see what your existing networking config is. Although the ifconfig command can be used, I prefer "ip addr"
    Code:
    ip addr
    It should list both your loopback network interface (lo) and any other interface (possibly eth0 but can also be named after your network device hardware).
    You're interested in this non-loopback interface, it will describe your MAC address. If a valid IP address in your network range is not listed, then for both "Classic" and "Network Manger" setups you can "ifup" to try to start up the interface
    Code:
    ifup <interfacename>
    If you run simply "ifup" without the interfacename, it should work but will try to apply to all interfaces instead of the single interface.

    If the above still hasn't gotten you a valid IP address, then you might want to check things like your physical network connection (Is the NIC light on? Should another cable be tried?) and whether DHCP is really working on your network if you've configured your interface that way.

    HTH,
    TSU

  10. #10

    Default Re: No Internet Access

    The desktop is Gnome.
    Typing "/sbin/lspci -nnk" into the Gnome-terminal results in pages of information.

    Yes, I switched between ifup and the other option, Network Manager (it actually says Network Connections in the title bar.) This resulted in a "Wired connection 1" in the Network Manager and a "x" at the top left of the Desktop. Clicking on the "x" results in a box that says "Wired" and "Network Settings." I now have internet access. Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •