Results 1 to 4 of 4

Thread: ATI 7770 HDMI audio ( Very rusty linux user)

  1. #1

    Default ATI 7770 HDMI audio ( Very rusty linux user)

    I used to use linux years back and am trying to use it again for my other PC's but I cannot seem to get the audio working when using HDMI. this setup is easier for me becasue my PC is hooked up to my LCD TV which has a digetal turner cable box hooked up to it and I really don't want to have to keep changing my settings in my TV back and forth to get audio working.
    the setup in Windows 7 works fine this way bujt in Open suse I cannot figure out how to get the HDMI sound to work.

    my system specs are AMD Sabertooth 990 fx motherboard 1100Ti be cpu with a ATI 7770 vidio card.
    I am using opensuse 13.1
    I am using HDMI and installed XMC but discovered that I wasn't getting any sound at all so I went into settings\sound and noticed that it only lists Digital output (S/PDIF)-built in audio and I cannot change this.
    I did the aplay-L

    Code:
    media@linux-khi3:~> aplay -L
    null
        Discard all samples (playback) or generate zero samples (capture)
    default
        Default ALSA Output (currently PulseAudio Sound Server)
    sysdefault:CARD=SB
        HDA ATI SB, ALC892 Analog
        Default Audio Device
    front:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        Front speakers
    surround40:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Digital
        IEC958 (S/PDIF) Digital Audio Output
    hdmi:CARD=HDMI,DEV=0
        HDA ATI HDMI, HDMI 0
        HDMI Audio Output
    hdmi:CARD=HDMI,DEV=1
        HDA ATI HDMI, HDMI 1
        HDMI Audio Output
    hdmi:CARD=HDMI,DEV=2
        HDA ATI HDMI, HDMI 2
        HDMI Audio Output
    hdmi:CARD=HDMI,DEV=3
        HDA ATI HDMI, HDMI 3
        HDMI Audio Output
    hdmi:CARD=HDMI,DEV=4
        HDA ATI HDMI, HDMI 4
        HDMI Audio Output
    hdmi:CARD=HDMI,DEV=5
        HDA ATI HDMI, HDMI 5
        HDMI Audio Output
    media@linux-khi3:~>
    any help would be appreciated

  2. #2

    Default Re: ATI 7770 HDMI audio ( Very rusty linux user)

    add "radeon.audio=1" to your kernel boot line ... with kernel 3.13, hdmi is enabled by default on most AMD adapters, so the boot option can then be dispensed with

    don't forget to switch output sources with your mixer or pulse

  3. #3

    Default Re: ATI 7770 HDMI audio ( Very rusty linux user)

    ok how do I do that , I know I sghoud remember but I don't

  4. #4

    Default Re: ATI 7770 HDMI audio ( Very rusty linux user)

    use the Yast bootloader module to make the change ... (or manually perform the necessary edits and steps)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •