Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: CUPS: CUPSD und CUPS inaktiv

  1. #1

    Default CUPS: CUPSD und CUPS inaktiv

    Hallo zusammen,
    ich habe hier Opensuse 13.1 und Cups 1.5.4 aus den Opensuse-Repos. Daran hängt am USB ein HP Photosmart und übers LAN ein Brother HL3070.

    Bis letzte Woche hat alles funktioniert. Anscheinend nach einem Update (es war letztens mal ein Cups-Update dabei) ist nach dem Hochfahren des Rechners zwar Cups und Cupsd "enabled" aber "Inactive". Des halb kann ich die Drucker weder über localhost:631 noch über z.B. Plaspool ansprechen.

    Also rufe ich Yast-System-Diensteverwaltung auf, schalte cups und cupsd ein und alles funktioniert wieder.

    Was läuft hier schief? Wo muss ich ein "Häkchen" dransetzen, damit die Dienste wieder automatisch aktiviert werden? Ich dachte eigentlich die Diesnsteverawaltung tut das, aber das hilft nur jeweils nach dem Hochfahren.

    Gruss


    Jürgen

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,721

    Default AW: CUPS: CUPSD und CUPS inaktiv

    Poste als root in separaten Code-Tags:
    Code:
    systemctl status cups.service
    Code:
    systemctl stop cups
    Code:
    systemctl disable cups.service
    Code:
    systemctl enable cups.service
    Code:
    systemctl start cups.service
    Danach einmal neustarten und die Ausgabe von:
    Code:
    systemctl status cups.service

  3. #3

    Default Re: CUPS: CUPSD und CUPS inaktiv

    Außerdem solltest du cups.socket disablen:
    Code:
    systemctl disable cups.socket
    Per default wird cupsd nämlich gar nicht beim Booten gestartet, sondern systemd lauscht auf dem socket und startet cups wenn eine Anfrage kommt.
    Das Update hat cups.socket dahingehend geändert, dass es (aus "Sicherheitsgründen") nur mehr am lokalen Rechner auf Anfragen lauscht.

    Cups selber kann aber gar nicht im Netzwerk lauschen wenn cups.socket aktiv ist.

    Wenn jetzt cups.socket disabled ist und cups.service enabled, dann wird cups ganz normal beim Booten gestartet, lauscht im Netzwerk (falls konfiguriert) und alles sollte wie gewünscht funktionieren.

    Eine andere Möglichkeit wäre cups.socket entsprechend zu ändern.
    Dazu /usr/lib/systemd/system/cups.socket nach /etc/systemd/system kopieren und dort editieren.

    Sh. dazu auch folgende Bugreports:
    https://bugzilla.novell.com/show_bug.cgi?id=857372 (der ursprüngliche, der uns dieses Update bescherte)
    https://bugzilla.novell.com/show_bug.cgi?id=860331
    https://bugzilla.novell.com/show_bug.cgi?id=860481

  4. #4

    Default Re: AW: CUPS: CUPSD und CUPS inaktiv

    Hallo Wolfi, hier erst mal die Outputs der einzelnen Befehle:
    Quote Originally Posted by Sauerland View Post
    Poste als root in separaten Code-Tags:
    Code:
    systemctl status cups.service cups.service - CUPS Printing Service    Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)    Active: inactive (dead)
    Code:
    systemctl stop cups Warning: Stopping cups, but it can still be activated by:   cups.path
    Code:
    systemctl disable cups.service rm '/etc/systemd/system/multi-user.target.wants/cups.path' rm '/etc/systemd/system/printer.target.wants/cups.service' rm '/etc/systemd/system/cupsd.service'
    Code:
    systemctl enable cups.service ln -s '/usr/lib/systemd/system/cups.service' '/etc/systemd/system/cupsd.service' ln -s '/usr/lib/systemd/system/cups.service' '/etc/systemd/system/printer.target.wants/cups.service' ln -s '/usr/lib/systemd/system/cups.socket' '/etc/systemd/system/sockets.target.wants/cups.socket' ln -s '/usr/lib/systemd/system/cups.path' '/etc/systemd/system/multi-user.target.wants/cups.path'
    Code:
    systemctl start cups.service keine Meldung
    nach dem start cups.service war der Netzwerkdrucker da. Den HP habe ich normalerweise ausgeschaltet. Ich fahr jetzt mal hoch und poste das Ergebnis. Übrigens hab ich vor dem Start noch das systemctl disable cups.socket rm '/etc/systemd/system/sockets.target.wants/cups.socket' duchgeführt. Danach einmal neustarten und die Ausgabe von:
    Code:
    systemctl status cups.service

  5. #5

    Default Re: AW: CUPS: CUPSD und CUPS inaktiv

    Hallo Wolfi,
    hier das Ergebnis nach Hochfahren (leider nicht wie erwartet/gewünscht):
    Code:
    systemctl status cups.service
    cups.service - CUPS Printing Service
       Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)
       Active: inactive (dead)
    nach einem systemctl start cups.service war wieder alles ok. Danach kommt folgender Status:

    Code:
    systemctl status cups.service
    cups.service - CUPS Printing Service
       Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)
       Active: active (running) since So 2014-01-26 11:54:20 CET; 1min 1s ago
     Main PID: 3543 (cupsd)
       CGroup: /system.slice/cups.service
               └─3543 /usr/sbin/cupsd -f
    
    Jan 26 11:54:20 linux-6o8d systemd[1]: Started CUPS Printing Service.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No limit for Validate-Job defined in policy allowallforanybody and no suitable template found.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No limit for Cancel-Jobs defined in policy allowallforanybody and no suitable template found.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No limit for Cancel-My-Jobs defined in policy allowallforanybody and no suitable template found.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No limit for Close-Job defined in policy allowallforanybody and no suitable template found.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No limit for CUPS-Get-Document defined in policy allowallforanybody and no suitable template found.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No JobPrivateAccess defined in policy allowallforanybody - using defaults.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No JobPrivateValues defined in policy allowallforanybody - using defaults.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No SubscriptionPrivateAccess defined in policy allowallforanybody - using defaults.
    Jan 26 11:54:20 linux-6o8d cupsd[3543]: No SubscriptionPrivateValues defined in policy allowallforanybody - using defaults.
    Gruss


    Jürgen

    Quote Originally Posted by Sauerland View Post
    Poste als root in separaten Code-Tags:
    Code:
    systemctl status cups.service
    Code:
    systemctl stop cups
    Code:
    systemctl disable cups.service
    Code:
    systemctl enable cups.service
    Code:
    systemctl start cups.service
    Danach einmal neustarten und die Ausgabe von:
    Code:
    systemctl status cups.service

  6. #6

    Default Re: AW: CUPS: CUPSD und CUPS inaktiv

    Update:

    Ich habe nun sowohl wie in

    https://bugzilla.novell.com/show_bug.cgi?id=860481

    beschrieben die cups.socket geändert als auch das Update von Cups rückgeängig gemacht und cups-1.5.4-12.1.3 wieder installiert. Ergebnis: es funktioniert nicht mehr!! Erst händisches Anschalten von Cups oder das Anschalten meines USB-Druckers (der normalerweise abgeschalten ist) hilft.

    Das ist alles sehr verwirrend! Wurde beim systemd auch was geändert oder wieso sieht er den Netzwerkdrucker nicht mehr? Wieso macht man solche Updates????

    Gruss


    Jürgen

  7. #7

    Default Re: CUPS: CUPSD und CUPS inaktiv

    Quote Originally Posted by beeblebrox421966 View Post
    Das ist alles sehr verwirrend! Wurde beim systemd auch was geändert oder wieso sieht er den Netzwerkdrucker nicht mehr?
    Nein, es wurde nur cups.socket geändert.

    Aber du hast das was ich geschrieben habe falsch gelesen.
    Du solltest cups.socket disablen, nicht cups.service.
    Also:
    Code:
    sudo systemctl disable cups.socket
    Wieso macht man solche Updates????
    Weil man der Meinung war, dass es ein Sicherheitsrisiko ist, wenn cups.socket per default auf allen Netzwerkinterfaces lauscht.
    Über die Konsequenzen auf bestehenden Default-Installationen (und die Verwirrung/Probleme für normale Benutzer) wurde anscheinend nicht nachgedacht...

  8. #8

    Default Re: CUPS: CUPSD und CUPS inaktiv

    Hi Wolfi,
    in meiner derzeitigen Konfiguration habe ich natürlich cups.service enabled und cups.socket disabled. Ist aber wie ich schon geschrieben habe ohne positive Wirkung gewesen.

    Status derzeit: nach dem Hochfahren entweder USB-Drucker anschalten oder cups von Hand starten.

    Gruss


    Jürgen

  9. #9

    Default Re: CUPS: CUPSD und CUPS inaktiv

    Quote Originally Posted by beeblebrox421966 View Post
    Hi Wolfi,
    in meiner derzeitigen Konfiguration habe ich natürlich cups.service enabled und cups.socket disabled. Ist aber wie ich schon geschrieben habe ohne positive Wirkung gewesen.

    Status derzeit: nach dem Hochfahren entweder USB-Drucker anschalten oder cups von Hand starten.
    Hm, und vor dem Update ists gegangen? Wie gesagt, die einzige Änderung im Update war in /usr/lib/systemd/system/cups.socket.
    Wenn cups.socket disabled ist, sollte das also absolut keine Auswirkung haben.
    Hattest du cups.socket vorher schon disabled? Wenn nicht, hats vielleicht gerade deswegen funktioniert...

    Was sagt "systemctl status cups.service" direkt nach dem Boot, also wenn es nicht geht? Wenn mans als root ausführt bekommt man etwas ausführlichere Meldungen aus dem Log.

    Evtl. wird die Netzwerkverbindung zu spät aufgebaut?
    Wie hängst du denn im Netzwerk? (über Kabel oder WLAN?)
    Wenn's eine WLAN-Verbindung über NetworkManager ist, solltest du vielleicht probieren, sie als "Systemverbindung" zu konfigurieren, damit sie schon beim Booten aufgebaut wird. (eine Benutzerverbindung wird erst beim Einloggen aufgebaut)

  10. #10

    Default Re: CUPS: CUPSD und CUPS inaktiv

    Hallo Wolfi,
    folgende Meldung als su:
    systemctl status cups.service
    cups.service - CUPS Printing Service
    Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled)
    Active: inactive (dead)

    Ich hänge über LAN am Netz und mache ifup... Daran hat sich nix geändert. Der Drucker hängt auch schon 1.5 Jahre über WLAN dran.
    Bzgl. Zeitpunkt bin ich mir nicht 100% sicher, aber in etwa seit der Zeit des Cups-Updates (müsste letzte Woche gewesen sein, kommt nach Start von KDE vom Plasmoid Plaspool die Fehlermeldung "Verbindung fehlgeschlagen".

    So gings dann los: ich hab die Diensteeinstellung überprüft und festgestellt, dass Cups zwar enabled aber inaktiv ist.

    im Cups-Log stehen nur meldungen NACH dem händischen aktivieren drin.

    Wo kann ich noch nachschauen,um das ganz zu lösen? Oder könnte ich

    systemctl start cups.service

    vor dem KDE start in irgendein Skript reinpacken und starten?

    Gruss


    Jürgen


    Quote Originally Posted by wolfi323 View Post
    Hm, und vor dem Update ists gegangen? Wie gesagt, die einzige Änderung im Update war in /usr/lib/systemd/system/cups.socket.
    Wenn cups.socket disabled ist, sollte das also absolut keine Auswirkung haben.
    Hattest du cups.socket vorher schon disabled? Wenn nicht, hats vielleicht gerade deswegen funktioniert...

    Was sagt "systemctl status cups.service" direkt nach dem Boot, also wenn es nicht geht? Wenn mans als root ausführt bekommt man etwas ausführlichere Meldungen aus dem Log.

    Evtl. wird die Netzwerkverbindung zu spät aufgebaut?
    Wie hängst du denn im Netzwerk? (über Kabel oder WLAN?)
    Wenn's eine WLAN-Verbindung über NetworkManager ist, solltest du vielleicht probieren, sie als "Systemverbindung" zu konfigurieren, damit sie schon beim Booten aufgebaut wird. (eine Benutzerverbindung wird erst beim Einloggen aufgebaut)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •