Results 1 to 6 of 6

Thread: Opensuse 13.1 KDE doesn't boot. Grub Problem?

  1. #1

    Default Opensuse 13.1 KDE doesn't boot. Grub Problem?

    Hi,

    I'm a total noob and have trouble to get Suse to boot. I have a Samsung Series 3 Laptop and Installed using DVD installation. However after the installation my laptop doesn't recognize an operating System and therefore doesn't boot. I deactivated fast boot and secure boot and activated CSM Mode (afaik also known as legacy bios).

    Installing Suse first and installing Ubuntu afterwards works. On bootin up I see the Grub-Bootloader and I can choose wether to boot ubuntu or Opensuse. When choosing Suse it works just fine.

    My question: How can I find out what went wrong with the grub installation during the installation of opensuse and how can i fix it?.

    Thanks in advance.

  2. #2
    Join Date
    Jan 2014
    Location
    United States
    Posts
    150

    Default Re: Opensuse 13.1 KDE doesn't boot. Grub Problem?

    Have you tried installing in UEFI mode? On my system, there are options to boot the DVD in "UEFI Mode" or in "Legacy BIOS Mode". Try the opposite mode of what you've already tried. From your post, it sounds like you installed in Legacy BIOS Mode. Try installing in UEFI mode, and format the disk with the GUID Parition Table. You don't need a very big swap space. Here is a good guide to help you out:

    http://www.cyberciti.biz/tips/linux-swap-space.html

    I don't know why your install failed. On my system, both Legacy BIOS Mode and UEFI mode work with GRUB2.

  3. #3

    Default Re: Opensuse 13.1 KDE doesn't boot. Grub Problem?

    Set BIOS to legacy only. There are known issues with secure boot and codesigned drivers. I ran into this as well and on my BIOS I set it to legacy or on some machines other OS. The UEFI boot is for Microsoft.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Opensuse 13.1 KDE doesn't boot. Grub Problem?

    On 2014-01-27 18:56, exponent wrote:
    > The UEFI boot is for Microsoft.


    No, that is not correct.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  5. #5

    Thumbs up Re: Opensuse 13.1 KDE doesn't boot. Grub Problem?

    Hi,

    thank you all for your answers.

    @pirithous:


    Have you tried installing in UEFI mode?
    No. In UEFI mode OpenSuse doesn't boot up from the DVD (even if DVD is boot priority one). How can I install Suse in UEFI mode?

    Try installing in UEFI mode, and format the disk with the GUID Parition Table
    Then I have to format my entire hard drive right? There are Windows 8 recovery partitions on it, which I would like to keep. Is there some other way to get Suse running?



    @exponent:

    Set BIOS to legacy only. There are known issues with secure boot and codesigned drivers. I ran into this as well and on my BIOS I set it to legacy or on some machines other OS.
    I switched from UEFI to CSM (Compatibility Support Module) which i think is the equivalent to legacy bios. Unfortunately it neither works with secure boot switched on nor off.


    Strange thing is: Ubuntu installation works perfectly fine. Whene I installed ubuntu after Suse i could enter suse via the Grub bootloader that came with the ubuntu installation. Just the mere OpenSuse installation doesn't provide a working grub bootloader.

    Thanks in advance for your help

  6. #6
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: Opensuse 13.1 KDE doesn't boot. Grub Problem?

    Gnampf12 wrote:

    >
    > Hi,
    >
    > thank you all for your answers.
    >
    > @pirithous:
    >
    >
    >> Have you tried installing in UEFI mode?

    >
    > No. In UEFI mode OpenSuse doesn't boot up from the DVD (even if DVD is
    > boot priority one). How can I install Suse in UEFI mode?
    >
    >>
    >> Try installing in UEFI mode, and format the disk with the GUID
    >> Parition Table
    >>

    >
    > Then I have to format my entire hard drive right? There are Windows 8
    > recovery partitions on it, which I would like to keep. Is there some
    > other way to get Suse running?
    >
    >
    >
    > @exponent:
    >
    >> Set BIOS to legacy only. There are known issues with secure boot and
    >> codesigned drivers. I ran into this as well and on my BIOS I set it
    >> to legacy or on some machines other OS.
    >>

    >
    > I switched from UEFI to CSM (-Compatibility Support Module-) which i
    > think is the equivalent to legacy bios. Unfortunately it neither works
    > with secure boot switched on nor off.
    >
    >
    > Strange thing is: Ubuntu installation works perfectly fine. Whene I
    > installed ubuntu after Suse i could enter suse via the Grub bootloader
    > that came with the ubuntu installation. Just the mere OpenSuse
    > installation doesn't provide a working grub bootloader.
    >
    > Thanks in advance for your help
    >

    Have you checked your BIOS Settings? Do you really mean Grub or are you
    using Grub2?

    I installed on a desktop (UEFI enabled and SecureBoot disabled in BIOS)
    using 13.1 DVD. It created the EFI boot partition as a FAT Partition
    with 156 MB's.

    I know laptops are different but this may give you some Ideas of
    something to check.
    --
    openSUSE 13.1(Linux 3.11.6-4-desktop x86_64|
    Intel(R) Quad Core(TM) i5-4440 CPU @ 3.10GHz|8GB DDR3|
    GeForce 8400GS (NVIDIA-Linux-x86_64-331.38)|KDE 4.12.1


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •