Results 1 to 7 of 7

Thread: Logitech H600 headphones and Skype

  1. #1

    Default Logitech H600 headphones and Skype

    I am trying to get the audio working with Skype. When I run the test in the YAST control panel I get a sound like a motorboat that doesn't go away. When I run Skype I get the same thing. The headphone is a wireless set with microphone and uses a USB key fob. The system sees the device but it doesn't work. I tried the one click multimedia install and get the following message. The fundamental problem is the audio - how do I test it and know it is working which it doesnt appear to be?

    #### YaST2 conflicts list - generated 2014-01-25 12:26:42 ####

    k3b-codecs-2.0.2-18.15.x86_64 requires k3b = 2.0.2-18.15, but this requirement cannot be provided
    uninstallable providers: k3b-2.0.2-18.15.i586[Packman Repository]
    k3b-2.0.2-18.15.x86_64[Packman Repository]
    [ ] Following actions will be done:
    downgrade of k3b-2.0.2-29.1.3.x86_64 to k3b-2.0.2-18.15.x86_64
    install k3b-2.0.2-18.15.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    [ ] break k3b-codecs-2.0.2-18.15.x86_64 by ignoring some of its dependencies

    [ ] do not install k3b-codecs-2.0.2-18.15.x86_64

    [ ] do not install k3b-codecs-2.0.2-18.15.x86_64



    ffmpeg-2.1.2-1.2.x86_64 requires libavutil52 = 2.1.2, but this requirement cannot be provided
    uninstallable providers: libavutil52-2.1.2-1.2.i586[Packman Repository]
    libavutil52-2.1.2-1.2.x86_64[Packman Repository]
    [ ] break ffmpeg-2.1.2-1.2.x86_64 by ignoring some of its dependencies

    [ ] Following actions will be done:
    do not install libxine2-codecs-1.2.3-89.4.x86_64
    do not install ffmpeg-2.1.2-1.2.x86_64
    [ ] Following actions will be done:
    do not install ffmpeg-2.1.2-1.2.x86_64
    do not install libxine2-codecs-1.2.3-89.4.x86_64
    [ ] install libavutil52-2.1.2-1.2.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de




    #### YaST2 conflicts list END ###

  2. #2

    Default Re: Logitech H600 headphones and Skype

    I am told that the Logitech H600 and other Logitech headphones are not supported in linux. I checked the website for Logitech and there is nothing there no can I find drivers anywhere. Perhaps this is the issue I am experiencing.

  3. #3

    Default Re: Logitech H600 headphones and Skype

    I got a little bit farther. I have the system recognizing the headphones and I can play the test music clip in the sound setup under YAST. The problem is how do I get the application to recognize the headphones. It shows three sound cards as follows


    0 - Logitech USB headphones (this is set as default)
    1 - A HMDI port on the ATI card
    2 - SBx00 Azalia

    the driver for the Logitech headphones is snb-usb-audio

    When I try to play a wav file using Amarok or VLC there is no option for the headphones even if I try to configure the backend which BTW resets as soon as I apply and exit.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Logitech H600 headphones and Skype

    While waiting for an openSUSE audiophile to respond, maybe you could tell us a bit more about your sound configuration
    Code:
    arecord -L
    Code:
    aplay -L
    Assuming you are using pulseaudio, this might be useful too

    Code:
    pacmd list-sinks
    Code:
    pacmd list-soucres
    Consider installing pavucontrol as well.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Logitech H600 headphones and Skype

    If the application is Skype, don't forget there was an entry in the release notes of a bug in GNU/Linux wrt a recent version of Skype. I blogged about it here, and posted information on a work around: https://forums.opensuse.org/entry.ph...-openSUSE-13-1

    I have not been tracking this since, so I do not know if a fix (such that the work around is not needed) has made it yet to the update repositories.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Logitech H600 headphones and Skype

    If the headphones are USB headphones, then they can be configured in YaST. That configuration 'might' not stick, especially if one reboot's their PC without the headphones installed.

    I strongly recommend installing pulse audio volume control (pavucontrol) which provides one control over which output audio device an application can use. There are two blog entries about this here:




    Good luck and thankyou for posting.

  7. #7
    Join Date
    Jul 2013
    Location
    United Kingdom
    Posts
    14

    Default Re: Logitech H600 headphones and Skype

    Hi,

    I got about as far as you did with a Logitech H800 on OpenSuSE 12.3 and a Dell 9010.

    Initially, YaST did not want to configure it at all, complaining about what sounded to me an IRQ or IO-parameter conflict (now THAT is something which I hadn't heard of since the early 1990s when I used to make hardware work on SVR4 Unix!). The problem turned out to be that I hadn't removed the configuration for my previous USB-headset, a wired FREETALK Everyman; allso unplugged, it seemed to conflict with the Logitech as long as it was configured. I suppose several USB-audio devices are not supported at the same time.

    With Pulseaudio off, I can now see the Logitech in the device list that Skype presents (under Options -> Audio), and after a reboot and/or logout/login, it works in Skype.

    I have not yet been able to get any sound other than from Skype or from YaST out of these head phones, but the at least I can do what I bought them for! Still, it would be nice to listen to the BBC on these headphones, too .

    Martin


    Quote Originally Posted by exponent View Post
    I got a little bit farther. I have the system recognizing the headphones and I can play the test music clip in the sound setup under YAST. The problem is how do I get the application to recognize the headphones. It shows three sound cards as follows


    0 - Logitech USB headphones (this is set as default)
    1 - A HMDI port on the ATI card
    2 - SBx00 Azalia

    the driver for the Logitech headphones is snb-usb-audio

    When I try to play a wav file using Amarok or VLC there is no option for the headphones even if I try to configure the backend which BTW resets as soon as I apply and exit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •