Results 1 to 4 of 4

Thread: Can not configure a static IP

  1. #1

    Default Can not configure a static IP

    Hi, I'm having a problem trying to configure a static IP with Suse. I have other computer with Debian working with a static IP, but, although I have done all the configurations by Yast and terminal (ifcfg-eth0), it remains dynamic IP.

    Here is my ifcfg-etho:
    BOOTPROTO='static'
    MTU=''
    REMOTE_IPADDR='192.168.1.39'
    STARTMODE='auto'
    And after restart the networks, even reboot, this is my ifconfig

    eth0 Link encap:Ethernet HWaddr C8:60:00:2C:BF:77
    inet addr:192.168.1.44 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::ca60:ff:fe2c:bf77/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:9340 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14970 errors:0 dropped:0 overruns:0 carrier:1
    collisions:0 txqueuelen:1000
    RX bytes:1029102 (1004.9 Kb) TX bytes:13945302 (13.2 Mb)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:3101 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3101 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:266452 (260.2 Kb) TX bytes:266452 (260.2 Kb)

    wlan0 Link encap:Ethernet HWaddr 78:92:9C:85:2F:22
    inet addr:192.168.1.36 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::7a92:9cff:fe85:2f22/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:102316 errors:0 dropped:0 overruns:0 frame:0
    TX packets:155860 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:22120843 (21.0 Mb) TX bytes:130660895 (124.6 Mb)
    I don't know what is wrong.
    P.D.: I'm using 13.1 version, but it was the same in 12.3.

  2. #2

    Default Re: Can not configure a static IP

    Quote Originally Posted by UnTallarin View Post
    Hi, I'm having a problem trying to configure a static IP with Suse. I have other computer with Debian working with a static IP, but, although I have done all the configurations by Yast and terminal (ifcfg-eth0), it remains dynamic IP.
    Well, if your IP remains dynamic, a DHCP client has to be running.
    Code:
    ps aux | grep dhc
    Maybe you have _both_ ifup _and_ NetworkManager active, and NetworkManager sets it up with DHCP?
    What does this say:
    Code:
    systemctl status NetworkManager.service

  3. #3

    Default Re: Can not configure a static IP

    Thank you very much wolfi323, you were right, the problem was that I had NetworkManger active, a noob mistake
    Thanks again.

  4. #4

    Default Re: Can not configure a static IP

    Quote Originally Posted by UnTallarin View Post
    Thank you very much wolfi323, you were right, the problem was that I had NetworkManger active, a noob mistake
    Well, actually there was a bug in 12.3, which could cause them both to be enabled.
    See here:
    https://www.suse.com/releasenotes/i3...123.systemd-nm

    But if you switch between ifup and NetworkManager in YaST (and then back), everything should be setup correctly.
    But I guess if you just disable NetworkManager you should be ok as well.

    But better check "systemctl status network.service" as well.
    This should give output similar to this if ifup is configured:
    Code:
    wolfi@linux-lf90:~/Desktop> systemctl status network.service
    network.service - LSB: Configure network interfaces and set up routing
       Loaded: loaded (/usr/lib/systemd/system/network.service; enabled)
       Active: active (exited) since Sam 2014-01-25 18:08:43 CET; 9s ago
      Process: 3697 ExecStart=/etc/init.d/network start (code=exited, status=0/SUCCESS)
     Main PID: 3697 (code=exited, status=0/SUCCESS)
    With NetworkManager enabled, it should look like this:
    Code:
    wolfi@linux-lf90:~/Desktop> systemctl status network.service
    NetworkManager.service - Network Manager
       Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
       Active: active (running) since Sam 2014-01-25 18:11:05 CET; 7s ago
     Main PID: 4741 (NetworkManager)
       CGroup: /system.slice/NetworkManager.service
               ├─4741 /usr/sbin/NetworkManager --no-daemon
               └─4746 /sbin/dhclient -d -sf /usr/lib/nm-dhcp-client.action -pf /v...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •