Results 1 to 7 of 7

Thread: [OpenSuse 13.1] only boot with nomodeset

  1. #1

    Exclamation [OpenSuse 13.1] only boot with nomodeset

    Hello everyone!

    I have a problem with my (first) new OpenSuse installation:
    My OpenSuse only starts with the parameter "nomodeset" in Grub2. I think its a graphic-driver problem, but I havn't fixed that problem yet.
    My graphic-card is an Intel HD Graphic 4000 (in an Acer Aspire M5-481T-33224G52Mass Ultrabook). I think thats probably the problem why my HDMI-port doesnt work.
    In OpenSuse is default installed the package "xf86-video-intel" for the graphic-chip...?
    I found this during my search: https://01.org/linuxgraphics/downloads -> is it useful?

    This Intel-packages are installed on my system:
    Code:
      | intel-SINIT            | Intel(R) SINIT AC modules                            | package   
    i | intel-gpu-tools        | Collection of tools for development and testing of-> | package   
    i | libdrm_intel1          | Userspace interface for Kernel DRM services for In-> | package   
    i | libdrm_intel1-32bit    | Userspace interface for Kernel DRM services for In-> | package   
    i | ucode-intel            | Microcode Updates for Intel x86/x86-64 CPUs          | package   
    i | vaapi-intel-driver     | Intel Driver for Video Acceleration (VA) API for L-> | package   
    i | xf86-video-intel       | Intel video driver for the Xorg X server             | package   
    i | xf86-video-intel-32bit | Intel video driver for the Xorg X server             | package
    I hope you can help me! If you need some more information just say it, please.
    Thank you very much!
    k2jj2k

  2. #2

    Default Re: [OpenSuse 13.1] only boot with nomodeset

    Quote Originally Posted by k2jj2k View Post
    In OpenSuse is default installed the package "xf86-video-intel" for the graphic-chip...?
    Yes.
    But "nomodeset" prevents the use of the intel driver, so you are using fbdev or vesa now.
    This implies of course that it is the intel driver that gives you problems.

    I found this during my search: https://01.org/linuxgraphics/downloads -> is it useful?
    No. You already have the intel driver installed, if you want to try out a newer version, better install it from an openSUSE repository.

    This Intel-packages are installed on my system:
    Code:
      | intel-SINIT            | Intel(R) SINIT AC modules                            | package   
    i | intel-gpu-tools        | Collection of tools for development and testing of-> | package   
    i | libdrm_intel1          | Userspace interface for Kernel DRM services for In-> | package   
    i | libdrm_intel1-32bit    | Userspace interface for Kernel DRM services for In-> | package   
    i | ucode-intel            | Microcode Updates for Intel x86/x86-64 CPUs          | package   
    i | vaapi-intel-driver     | Intel Driver for Video Acceleration (VA) API for L-> | package   
    i | xf86-video-intel       | Intel video driver for the Xorg X server             | package   
    i | xf86-video-intel-32bit | Intel video driver for the Xorg X server             | package
    This list is nice, but doesn't tell anything about the actual versions installed.
    Could you please post the output of:
    Code:
    rpm -q xf86-video-intel
    The driver included in 13.1 did have some problems, an update has been released in the official update repo (the latest version there is xf86-video-intel-2.99.906-12.1).
    So did you install all updates? (the above command will tell whether you have the updated intel driver or not)

    A common problem with the intel driver is the new SNA acceleration, which apparently doesn't work well on some chips yet.
    You could try to switch to the older but stable UXA acceleration, see here:
    https://wiki.archlinux.org/index.php...eration_method

  3. #3

    Default Re: [OpenSuse 13.1] only boot with nomodeset

    Thank you very much for your answer. The command "rpm -q xf86-video-intel" tells me, that I have already installed Version 2.99.906-12.1 (xf86-video-intel-2.99.906-12.1.x86_64).
    In this moment I'm not at home, so I can't test the problem with the new SNA acceleration. I will read this article tomorrow. Thank you.
    Do you mean, if I switch to the older acceleration it could work? (I will try it)
    Thanks!

  4. #4

    Default Re: [OpenSuse 13.1] only boot with nomodeset

    Quote Originally Posted by k2jj2k View Post
    Do you mean, if I switch to the older acceleration it could work? (I will try it)
    Yes.
    Of course I am not sure if it will help, but it's worth a try.

  5. #5

    Default Re: [OpenSuse 13.1] only boot with nomodeset

    Sry for my very late reply, but Im a bit under pressure with my work... (and I forget my logindata from my acc here ^_^) So... Your fix doesnt work. Do you know an other workaround? greetings k2jj2k

  6. #6

    Default Re: [OpenSuse 13.1] only boot with nomodeset

    Quote Originally Posted by k3jj3k View Post
    So... Your fix doesnt work.
    Hm. You did exactly as explained in that link? I.e. create a file /etc/X11/xorg.conf.d/20-intel.conf with exactly this content:
    Code:
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "uxa"
    EndSection
    Have you tried "glamor" instead of "uxa" as well?

    What actually happens when you don't use "nomodeset"?
    IIUYC the system doesn't boot then, right?
    But are there any messages on the screen, maybe after pressing ESC?
    Try to disable the splash screen to see the messages, by adding "plymouth.enable=0" to the boot options.

    Could you post your X log? Maybe that would provide a clue.
    To do this, boot _without_ "nomodeset", then after the boot failed just reboot _with_ "nomodeset" and post the file /var/log/Xorg.0.log.old.
    (maybe upload it to http://susepaste.org/ or similar and post a link)

    Btw, if you don't know that already, you can change the boot options for the current boot only by pressing 'e' at the boot menu, search for a line starting with "linux" and change it accordingly. Then press 'F10' to boot with the changed options, nothing gets saved in this case so the boot options will be the same as before again on the next boot.

  7. #7

    Lightbulb Re: [OpenSuse 13.1] only boot with nomodeset

    Thank you very much for your reply.
    I fixed the problem. The problem was, that the backlight doesnt work. So i couldnt see anything. I didnt recognized that because when I tried it, it was very dark in my room.

    Thank you!
    k3jj3k

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •