Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problems configuring Wifi internet connection with Yast.

  1. #1

    Default Problems configuring Wifi internet connection with Yast.

    I suppose the biggest problem is I do not know really what I am doing. After taking nearly a week to install linux my experience amounts to 2-3 hours this morning...so please please keep any answers simple. The stuff below is copied off the screen.....

    In Yast...

    Under “Global Options” tab:


    Network setup method is set to "traditional method with ipup"
    Ipv6 is enabled


    Under DHCP client options
    DHCP client ID......I added a short name
    Host name to send says AUTO
    Change default Route via DHCP is enabled

    Under “Overview” tab:


    My card is detected


    RT2500 802.11 Cardbus/miniPCI

    IP= DHCP


    At the bottom of the same page it gives the name of the card again but in brackets it says “not connected”
    It also gives a MAC address and a Bus id. It gives a device name and says the IP address assigned by DHCP...




    Under “Hostname/DNS” tab:


    There is a hostname..... the domain name says “site”


    “Change of hostname via DHCP” and“Assign hostname to loopback IP” are both enabled


    Modify DNS Configuration says use default policy


    The rest of the boxes are empty.




    Under “Routing” tab:


    IPv4 and Ipv6 gateways ...I typed inthe IP of my router


    In “device”... gives a choice of three, I guessed....wlano


    The rest of the boxes are empty




    In “Wireless Device Settings”


    Operation mode = managed
    Network Name ESSID....gives name that is correct


    Authentication WPA-PSK (is correct)


    I entered the pass which was accepted




    When I exit it rewrites everything andcloses but firefox still can not find a server...


    Any help most appriciated

  2. #2

    Default Re: Problems configuring Wifi internet connection with Yast.

    On 01/23/2014 09:46 AM, Lionel1020 pecked at the keyboard and wrote:
    > I suppose the biggest problem is I do not know really what I am doing.
    > After taking nearly a week to install linux my experience amounts to 2-3
    > hours this morning...so please please keep any answers simple. The stuff
    > below is copied off the screen.....
    >
    > In Yast...
    >
    > Under “Global Options” tab:
    >
    >
    > Network setup method is set to "traditional method with ipup"
    > Ipv6 is enabled
    >
    >
    > Under DHCP client options
    > DHCP client ID......I added a short name
    > Host name to send says AUTO
    > Change default Route via DHCP is enabled
    >
    > Under “Overview” tab:
    >
    >
    > My card is detected
    >
    >
    > RT2500 802.11 Cardbus/miniPCI
    >
    > IP= DHCP
    >
    >
    > At the bottom of the same page it gives the name of the card again but
    > in brackets it says “not connected”
    > It also gives a MAC address and a Bus id. It gives a device name and
    > says the IP address assigned by DHCP...
    >
    >
    >
    >
    > Under “Hostname/DNS” tab:
    >
    >
    > There is a hostname..... the domain name says “site”
    >
    >
    > “Change of hostname via DHCP” and“Assign hostname to loopback
    > IP” are both enabled
    >
    >
    > Modify DNS Configuration says use default policy
    >
    >
    > The rest of the boxes are empty.
    >
    >
    >
    >
    > Under “Routing” tab:
    >
    >
    > IPv4 and Ipv6 gateways ...I typed inthe IP of my router
    >
    >
    > In “device”... gives a choice of three, I guessed....wlano


    That should be wlan0 (zero as in the number, not o as in the letter).

    And please provide the output of:
    Code:
    cat /etc/resolv.conf
    in code tags please.


    Ken


  3. #3

    Default Re: Problems configuring Wifi internet connection with Yast.

    Quote Originally Posted by kensch View Post
    On 01/23/2014 09:46 AM,
    >


    That should be wlan0 (zero as in the number, not o as in the letter).

    And please provide the output of:
    Code:
    cat /etc/resolv.conf
    in code tags please.


    Ken


    Hello Ken, Thanks for the reply.


    I put in the code and this is the result:

    Code:
    lionel1020@linux-s0ra:~> cat/etc/resolv.conf 
    ### /etc/resolv.conf file autogeneratedby netconfig! 
    # 
    # Before you change this file manually,consider to define the 
    # static DNS configuration using thefollowing variables in the 
    # /etc/sysconfig/network/config file: 
    #     NETCONFIG_DNS_STATIC_SEARCHLIST 
    #     NETCONFIG_DNS_STATIC_SERVERS 
    #     NETCONFIG_DNS_FORWARDER 
    # or disable DNS configuration updatesvia netconfig by setting: 
    #     NETCONFIG_DNS_POLICY='' 
    # 
    # See also the netconfig(8) manual pageand other documentation. 
    # 
    # Note: Manual change of this filedisables netconfig too, but 
    # may get lost when this file containscomments or empty lines 
    # only, the netconfig settings are samewith settings in this 
    # file and in case of a "netconfigupdate -f" call. 
    # 
    ### Please remove (at least) this linewhen you modify the file! 
    lionel1020@linux-s0ra:~>


    Not sure what any of that means.....

  4. #4
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    695

    Default Re: Problems configuring Wifi internet connection with Yast.

    Hi Lionel1020,

    First you may try to ping your router. So you can check if is a network issue, or rather routing / DNS.
    In a terminal type
    Code:
    ping -c3 'ip-address of your router'
    If you get a reply you are connected. You could then try open a website not by the domain name but the IP address, e.g. 130.57.5.70.

    Two more options:
    I am not sure if that helps, but you can try and disable IPv6. I have heard that IPv6 may cause issues and you are definitely not using it in your local network, are you?.

    You can also try and use networkmanager. It may be more suitable for wlan.

    (And yes, it must be wlan0 not wlano.)

    Good luck!

    kasi

  5. #5

    Default Re: Problems configuring Wifi internet connection with Yast.

    On 01/23/2014 01:16 PM, Lionel1020 pecked at the keyboard and wrote:
    > kensch;2618783 Wrote:
    >> On 01/23/2014 09:46 AM,
    >> That should be wlan0 (zero as in the number, not o as in the letter).
    >>
    >> And please provide the output of:

    > Code:
    > --------------------
    > > >

    > > cat /etc/resolv.conf
    > >

    > --------------------
    >> in code tags please.
    >>
    >>
    >> Ken

    >
    >
    > Hello Ken, Thanks for the reply.
    >
    >
    > I put in the code and this is the result:
    >
    >
    > Code:
    > --------------------
    > lionel1020@linux-s0ra:~> cat/etc/resolv.conf
    > ### /etc/resolv.conf file autogeneratedby netconfig!
    > #
    > # Before you change this file manually,consider to define the
    > # static DNS configuration using thefollowing variables in the
    > # /etc/sysconfig/network/config file:
    > # NETCONFIG_DNS_STATIC_SEARCHLIST
    > # NETCONFIG_DNS_STATIC_SERVERS
    > # NETCONFIG_DNS_FORWARDER
    > # or disable DNS configuration updatesvia netconfig by setting:
    > # NETCONFIG_DNS_POLICY=''
    > #
    > # See also the netconfig(8) manual pageand other documentation.
    > #
    > # Note: Manual change of this filedisables netconfig too, but
    > # may get lost when this file containscomments or empty lines
    > # only, the netconfig settings are samewith settings in this
    > # file and in case of a "netconfigupdate -f" call.
    > #
    > ### Please remove (at least) this linewhen you modify the file!
    > lionel1020@linux-s0ra:~>
    >
    >
    > --------------------
    >
    >
    >
    >
    > Not sure what any of that means.....
    >
    >


    It actually it tells us a lot. You do not have any DNS servers setup
    which is why you cannot resolve host names (web pages). There should be
    at least one line like the following:

    Code:
    nameserver 8.8.8.8
    8.8.8.8 and 8.8.4.4 are two nameservers provided by Google.

    Ken

  6. #6

    Default Re: Problems configuring Wifi internet connection with Yast.

    Quote Originally Posted by kensch View Post
    On 01/23/2014 01:16 PM, Lionel1020 pecked at the keyboard and wrote:
    > kensch;2618783 Wrote:
    >> On 01/23/2014 09:46 AM,
    >> That should be wlan0 (zero as in the number, not o as in the letter).
    >>
    >> And please provide the output of:

    > Code:
    > --------------------
    > > >

    > > cat /etc/resolv.conf
    > >

    > --------------------
    >> in code tags please.
    >>
    >>
    >> Ken

    >
    >
    > Hello Ken, Thanks for the reply.
    >
    >
    > I put in the code and this is the result:
    >
    >
    > Code:
    > --------------------
    > lionel1020@linux-s0ra:~> cat/etc/resolv.conf
    > ### /etc/resolv.conf file autogeneratedby netconfig!
    > #
    > # Before you change this file manually,consider to define the
    > # static DNS configuration using thefollowing variables in the
    > # /etc/sysconfig/network/config file:
    > # NETCONFIG_DNS_STATIC_SEARCHLIST
    > # NETCONFIG_DNS_STATIC_SERVERS
    > # NETCONFIG_DNS_FORWARDER
    > # or disable DNS configuration updatesvia netconfig by setting:
    > # NETCONFIG_DNS_POLICY=''
    > #
    > # See also the netconfig(8) manual pageand other documentation.
    > #
    > # Note: Manual change of this filedisables netconfig too, but
    > # may get lost when this file containscomments or empty lines
    > # only, the netconfig settings are samewith settings in this
    > # file and in case of a "netconfigupdate -f" call.
    > #
    > ### Please remove (at least) this linewhen you modify the file!
    > lionel1020@linux-s0ra:~>
    >
    >
    > --------------------
    >
    >
    >
    >
    > Not sure what any of that means.....
    >
    >


    It actually it tells us a lot. You do not have any DNS servers setup
    which is why you cannot resolve host names (web pages). There should be
    at least one line like the following:

    Code:
    nameserver 8.8.8.8
    8.8.8.8 and 8.8.4.4 are two nameservers provided by Google.

    Ken

    Thanks Ken,


    I printed out the details from my router,
    From the printout I discovered Ipv6 is deactivated on the router...so I will deactivate it in Yast.


    From the same printout there are entries on DNS:
    One entry reads: “Servers DNS” it then gives two IP numbers like: 123.01.12.23, 122.0.33.00.
    These are example numbers but it follows the same form.


    How do I get these IP numbers from the router into Yast program? Do they have to go in Yast?

    Lionel

  7. #7

    Default Re: Problems configuring Wifi internet connection with Yast.

    On 01/23/2014 08:26 PM, Lionel1020 pecked at the keyboard and wrote:
    > kensch;2618844 Wrote:
    >> On 01/23/2014 01:16 PM, Lionel1020 pecked at the keyboard and wrote:


    >> Thanks Ken,
    >>
    >>
    >> I printed out the details from my router,
    >> From the printout I discovered Ipv6 is deactivated on the router...soI
    >> will deactivate it in Yast.
    >>
    >>
    >> From the same printout there are entries on DNS:
    >> One entry reads: “Servers DNS” it then gives two IP numbers like:
    >> 123.01.12.23, 122.0.33.00.
    >> These are example numbers but it follows the same form.
    >>
    >>
    >> How do I get these IP numbers from the router into Yast program? Do they
    >> have to go in Yast?
    >>
    >> Lionel
    >>
    >>


    If your router is set up correctly and you are using DHCP they should be
    supplied automatically. Go back through all of the DHCP settings on the
    router again and make sure you have set DNS entries.

    Ken


  8. #8
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,859
    Blog Entries
    20

    Default Re: Problems configuring Wifi internet connection with Yast.

    Why not switch to Network Manager controlled
    It's much easier with wifi
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Problems configuring Wifi internet connection with Yast.

    Hi Ken, Caf and everyone,


    Thanks for your patience. I have been mucking about, building, repairing, reconfiguring computers for the last twenty years (all on windows) but with linux it's like the first day at school. People are polite here but I think this leads to them giving me credit where no credit is due. Please don't assume I know what I am doing or that I understand what you are talking about. I am trying but this is literally my first couple of days with this OS.


    Back to the problem:


    Quote: “If your router is set up correctly and you are using DHCP they should be
    supplied automatically. Go back through all of the DHCP settings on the
    router again and make sure you have set DNS entries.

    Ken”


    I think the router must be set up correctly, there are three other computers using it at this moment including the one I’m using to tap this message. In the printout from the router the protocol is defined as “Mix (PPPoE + DHCP)". Nothing needs to be or should be changed on the router all the problems are in the computer setup. To be clear here I am assuming by 'router' you mean the box that came from our internet suppler?? Here in France they are supplied by your internet provider, they control the telephone, internet and TV. Set up is fully automatic. Mine is called a neufbox it can be seen here:http://http://assistance.sfr.fr/inte...x/fc-454-50161


    Any and all set-up must be done on the computer I'm trying to connect to the 'neufbox' via 'Yast' or some other bit.


    Lionel

  10. #10
    Join Date
    Jun 2008
    Location
    Ardrishaig, Argyll. Scotland UK - GMT/BST
    Posts
    36,859
    Blog Entries
    20

    Default Re: Problems configuring Wifi internet connection with Yast.

    Forget the router
    It's very unlikely the issue

    In the network settings - switch to network manager controlled

    Trouble is though, you seem to have been messing with stuff best left alone and I'd be inclined to write a clean install over it and be sure to use network manager from the start. You might have to install it if your are not using a Laptop.

    Are you using KDE or Gnome?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •