Results 1 to 2 of 2

Thread: XBMC startet nicht, openSUSE 13.1

  1. #1

    Question XBMC startet nicht, openSUSE 13.1

    Hallo,

    wenn ich XBMC starte erhalte ich folgende Meldung:
    Code:
    XBMC  needs hardware accelerated OpenGL rendering
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied)
    Ausgabe von: glxinfo | grep direct
    Code:
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
    Ausgabe vo: glxinfo | grep -i opengl
    Code:
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce 6150/integrated/SSE2
    OpenGL version string: 2.1.2 NVIDIA 304.108
    OpenGL shading language version string: 1.20 NVIDIA via Cg compiler
    OpenGL extensions:
    Wenn ich die Berechtigung von "/dev/nvidia0" auf "777" setze kann ich XBMC starten.
    Beim nächsten Start von openSUSE ist die Berechtigung "777" von "/dev/nvidia0" aber nicht mehr vorhanden.
    Wie kann ich die Berechtigung von "/dev/nvidia0" dauerhaft ändern ?
    Oder gibt es noch eine andere Lösung ?

    MfG

    Juergen B.

  2. #2

    Default AW: XBMC startet nicht, openSUSE 13.1

    Quote Originally Posted by baben_j View Post
    Wie kann ich die Berechtigung von "/dev/nvidia0" dauerhaft ändern ?
    Oder gibt es noch eine andere Lösung ?
    Den Benutzer der Gruppe "video" hinzufügen sollte das Problem beheben, sh. auch die 12.3 Versionshinweise:
    https://www.suse.com/releasenotes/x8...47462154153376

    Hast du alle Updates installiert? Dieses Problem sollte eigentlich mit einem systemd Update für 13.1 im Dezember behoben worden sein.
    (logind gibt jetzt dem eingeloggten User die benötigten Rechte für /dev/nvidia0)

    Außerdem: wieso hast du noch den 304.108 Treiber? Das nvidia repo enthält mittlerweile die Version 304.117.
    Ruf doch mal "sudo zypper up" auf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •