Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Repo Site Error Message - Any Suggestions?

  1. #1
    Join Date
    Nov 2008
    Posts
    2,198
    Blog Entries
    1

    Default Repo Site Error Message - Any Suggestions?

    I have just started getting a pop up message as follows:-

    Code:
     Problem connecting to a software origin
    File '/repodata/repomd.xml' not found on medium 'http://download.opensus.org/repositories/Virtualization/openSUSE_2.2/'
    The popup is a pain but worse, I have no idea what has gone wrong. Is it repo server issue or a problem at my end?
    Can anybody help please?
    Last edited by hcvv; 24-Jan-2014 at 03:45. Reason: Repaired CODE tags

  2. #2

    Default Re: Repo Site Error Message - Any Suggestions?

    Quote Originally Posted by Budgie2 View Post
    I have just started getting a pop up message as follows:-

    Code:
     Problem connecting to a software origin
    File '/repodata/repomd.xml' not found on medium 'http://download.opensus.org/repositories/Virtualization/openSUSE_2.2/'
    Is _this_ exactly the message you get?
    I see 2 obvious errors in that URL:
    - First, it is download.opensuse.org
    - Second, it is openSUSE_12.2

    But anyway, that repo has been removed for 12.2.
    You should think about upgrading to a newer version (12.3 f.e.), since 12.2 is out of support already since a week.
    From http://en.opensuse.org/index.php?title=Lifetime:
    The following distributions are expected to receive updates until the specified date:
    ...
    openSUSE 12.2
    - Jan 15th 2014 which is in -7 days (2 months after release of 13.1)
    You could use this repo instead for now:
    http://download.opensuse.org/reposit...openSUSE_12.2/
    But this only contains older versions of the software.

  3. #3
    Join Date
    Nov 2008
    Posts
    2,198
    Blog Entries
    1

    Default Re: Repo Site Error Message - Any Suggestions?

    Quote Originally Posted by wolfi323 View Post
    Is _this_ exactly the message you get?
    I see 2 obvious errors in that URL:

    Now you mention it so do I. I had to type it in in haste as it is not possible (for me) to cut and paste from the pop up.

    - First, it is download.opensuse.org
    - Second, it is openSUSE_12.2

    But anyway, that repo has been removed for 12.2.
    You should think about upgrading to a newer version (12.3 f.e.), since 12.2 is out of support already since a week.
    From http://en.opensuse.org/index.php?title=Lifetime:

    I should have known this. I have been putting off the upgrade because of the time it takes to get back to work. I guess I shall have to get to it this weekend.

    You could use this repo instead for now:
    http://download.opensuse.org/reposit...openSUSE_12.2/
    But this only contains older versions of the software.
    Thanks but not critical now I have to face up to reality!!! I shall upgrade to 13.1 (or 13.2?).

    Thanks again,
    Budgie2

  4. #4

    Default Re: Repo Site Error Message - Any Suggestions?

    Quote Originally Posted by Budgie2 View Post
    Thanks but not critical now I have to face up to reality!!! I shall upgrade to 13.1 (or 13.2?).
    Well, 13.2 is still far away (the Roadmap says July 2014), so it's either 12.3 or 13.1.

    12.3 should be safer since it is only officially supported to upgrade to the next version.
    If you do want to upgrade directly to 13.1, you should use the offline method, though. (via Installation-DVD or NET-Install CD)

    There is a problem in the dbus upgrade procedure that could cause an online upgrade via "zypper dup" to hang somewhere in the middle (you should have a fully updated 12.3 system before the upgrade to prevent that).
    If you do a fresh install anyway, this doesn't matter of course.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Repo Site Error Message - Any Suggestions?

    And please next time use copy/paste to post between CODE tags. We others trust that you do not cheat there by inventing, changing, removing things there (unless you explicetly tell so, e.g. when you ** out a password).
    Henk van Velden

  6. #6
    Join Date
    Nov 2008
    Posts
    2,198
    Blog Entries
    1

    Default Re: Repo Site Error Message - Any Suggestions?

    Quote Originally Posted by hcvv View Post
    And please next time use copy/paste to post between CODE tags. We others trust that you do not cheat there by inventing, changing, removing things there (unless you explicetly tell so, e.g. when you ** out a password).
    Hi Henk,

    I accept the slap on the wrist but I have been a visitor here long enough to know what is required. I did try to get it right but couldn't copy and paste as previously advised and trackball is playing up. In the same way as one can make spelling errors I guess!
    Regards,
    Budgie2

  7. #7
    Join Date
    Nov 2008
    Posts
    2,198
    Blog Entries
    1

    Default Re: Repo Site Error Message - Any Suggestions?

    Quote Originally Posted by wolfi323 View Post
    Well, 13.2 is still far away (the Roadmap says July 2014), so it's either 12.3 or 13.1.

    12.3 should be safer since it is only officially supported to upgrade to the next version.
    If you do want to upgrade directly to 13.1, you should use the offline method, though. (via Installation-DVD or NET-Install CD)

    There is a problem in the dbus upgrade procedure that could cause an online upgrade via "zypper dup" to hang somewhere in the middle (you should have a fully updated 12.3 system before the upgrade to prevent that).
    If you do a fresh install anyway, this doesn't matter of course.
    Hi Wolfi323,
    Well I have finally found time to try to upgrade. I wonder if you have a few moments to give me some further advice please as I ahve run into problem:-

    In order to start with a "clean" machine I rebooted before doing anything else. Oddly, grub reported openSUSE 12.1 installed. I guess I did something wrong last time but checking with
    Code:
    cat /etc/*-release
    confirms openSUSE 12.2 so, taking your advice I tried a Network install of 12.3. For reasons I do not yet understand this stalls. I get the screen asking if I want to boot from hard drive, install, check media etc and if I select "Installation" I get a few lines of text on the console and then screen goes dark and nothing further. Strange because I always use Network Installation and that is how I installed 12.2 as a fresh install on this machine, not an upgrade.

    So my question is can I do a zypper dup to go from 12.2 to 12.3 without risk?

    Budgie2

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Repo Site Error Message - Any Suggestions?

    To maximize safety, I recommend upgrading using the DVD (I don't know what medium you're using for a "Network Install").
    That way, if something happens to your network connection you'll still have enough source on your DVD to recover.

    On the other hand, if you do a network upgrade (you take your chances, but you d/l only the packages you need to upgrade), then I'd recommend you use the command line zypper method. If you want to consider this option, be sure to follow the official documentation
    http://en.opensuse.org/SDB:System_upgrade

    In general though, whatever method you use to upgrade involves the following steps
    - Update your existing system with the latest available patches.
    - Backup if you value what you have in case this get very bad (shouldn't, but if a mistake is made you can certainly lose everything)
    - If you're jumping more than one distro version, you may be advised to add a special repository
    - Disable your repositories pointing to your current distro version and configure new repositories that point to the new distro version
    - Execute the upgrade. It should swap out your old system files for new. Although mentioned by others, I doubt that it makes a diff whether your /home directory is on a special partition or not but of course it's always safer if partitions are used to separate files that are used differently.

    For the inexperienced, d/l the DVD and execute the upgrade from it. You will have an option to connect to online sources if you wish (like a network based upgrade) but I wouldn't recommend it for the less experienced. It'll take more time installing old files for the new distro and then replacing those with updated files, but it'll get you from one step to another with more certainty and less complexity (safer than sorry).

    HTH,
    TSU

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,834

    Default Re: Repo Site Error Message - Any Suggestions?

    Hello budgie2,

    No hard feelings, but as you see, making typos in what others think is a straight copy, leads to misinterpretations and useless discussions. In nobodies favour
    As I suggested: next time better.

    BTW, the case of GRUB saying 12.2 and the system in fact being 12.3 (and variations) was here in the forums a few times. IIRC, during an Upgrade (thus not a fresh install), the text in the grub menu is not changed. Confusing.

    I guess that this happens whith an update using changed repos and zypper dup. Because IMHO that would only install newer packages and not change configuration fiiles like that of Grub. Flaw or Bug?
    Henk van Velden

  10. #10

    Default Re: Repo Site Error Message - Any Suggestions?

    Quote Originally Posted by hcvv View Post
    HBTW, the case of GRUB saying 12.2 and the system in fact being 12.3 (and variations) was here in the forums a few times. IIRC, during an Upgrade (thus not a fresh install), the text in the grub menu is not changed. Confusing.

    I guess that this happens whith an update using changed repos and zypper dup. Because IMHO that would only install newer packages and not change configuration fiiles like that of Grub. Flaw or Bug?
    No, that happens on any upgrade, even offline using the DVD.
    The text is not changed on purpose, because it is a user-editable configuration item. You can change it to your likings in YaST->System->Boot Loader->Boot Loader Options ("Distributor").
    There was some discussion about that after the 13.1 release again, with a proposed patch to fix it, but I don't know if this will be changed for 13.2 then or not.
    https://bugzilla.novell.com/show_bug.cgi?id=810055

    Quote Originally Posted by Budgie2 View Post
    For reasons I do not yet understand this stalls. I get the screen asking if I want to boot from hard drive, install, check media etc and if I select "Installation" I get a few lines of text on the console and then screen goes dark and nothing further. Strange because I always use Network Installation and that is how I installed 12.2 as a fresh install on this machine, not an upgrade.
    You may have to select "No KMS" on the boot screen (F4 it is I think).


    So my question is can I do a zypper dup to go from 12.2 to 12.3 without risk?
    Well, an upgrade always bears a certain risk, depending on how customized your installation is.
    But if you follow the instructions in the link tsu2 gave you, it should work.

    That said, my last clean installation on the system I'm sitting at the moment was SuSE 8.1.
    Since then I only upgraded. (most of the time with "zypper dup" since it is available)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •