Results 1 to 2 of 2

Thread: how to change the repository of the packages in an update

  1. #1

    Default how to change the repository of the packages in an update

    note moderators: maybe the title have to be changed, I don't know if I writed right. thank you

    hi guys
    I installed opensuse 13.1 some days ago, and I'm doing some experiments just to learn a lit of bit more about the system.
    the thing is that I want to update all the packages changing the vendor, I mean I want new packages to come from packman repository if available
    I changed the repositories's priority with yast, I set packman with an 80 and the rest of repositories with a 90 so that packman repository would have more priority.
    then as found in here and here I modified the file
    Code:
    /etc/zypp/zypp.conf
    and writed the next line at the end of the file
    Code:
    solver.allowVendorChange = true
    I refreshed the repositories and loged out
    Code:
    zypper ref
    when I loged in back, I ran
    Code:
    zypper update
    OK, now what I expected to happen was that new packages had come from the packman repository if available. but I got the next output instead

    Code:
    Loading repository data...
    Reading installed packages...
    
    The following 56 package updates will NOT be installed:
      gstreamer gstreamer-0_10 gstreamer-0_10-plugin-esd 
      gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-bad 
      gstreamer-0_10-plugins-bad-lang gstreamer-0_10-plugins-base 
      gstreamer-0_10-plugins-good gstreamer-0_10-plugins-ugly gstreamer-0_10-utils 
      gstreamer-0_10-utils-unversioned gstreamer-plugins-bad gstreamer-plugins-base 
      gstreamer-plugins-good gstreamer-plugins-ugly libdirac_encoder0 
      libgstapp-0_10-0 libgstapp-1_0-0 libgstaudio-1_0-0 
      libgstbasecamerabinsrc-0_10-23 libgstbasecamerabinsrc-1_0-0 
      libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 libgstcodecparsers-1_0-0 
      libgstfft-1_0-0 libgstinterfaces-0_10-0 libgstpbutils-1_0-0 
      libgstphotography-0_10-23 libgstphotography-1_0-0 libgstreamer-0_10-0 
      libgstreamer-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0 libgstrtsp-1_0-0 
      libgstsdp-1_0-0 libgstsignalprocessor-0_10-23 libgsttag-1_0-0 
      libgstvdp-0_10-23 libgstvideo-1_0-0 libmjpegutils-2_0-0 libopus0 
      libquicktime0 libSDL-1_2-0 libvpx1 libxmmsclient6 libxmmsclient-glib1 
      mjpegtools phalanx python-gstreamer-0_10 typelib-1_0-Gst-1_0 
      typelib-1_0-GstAudio-1_0 typelib-1_0-GstPbutils-1_0 typelib-1_0-GstTag-1_0 
      typelib-1_0-GstVideo-1_0 xmms2 xmms2-plugin-base 
    
    Nothing to do.
    I checked out some of the packages (like gstreamer and typelib-1_0-GstVideo-1_0 xmms2) in the output, and obviously the vendor did not change. I see there is a packman repository version in the ones I checked out but they are not installed, instead the version installed continues being the one on the official repositories

    so guys, what did I do wrong??
    thanks in advance

  2. #2

    Default Re: how to change the repository of the packages in an update

    Quote Originally Posted by neyson_v View Post
    so guys, what did I do wrong??
    Could you post the whole /etc/zypp/zypp.conf? (upload it to http://susepaste.org/ and post a link)
    Maybe you made a mistake there. Maybe the option "solver.allowVendorChange" is set twice or something?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •