Results 1 to 5 of 5

Thread: Opensuse 13.1 boot issue

  1. #1

    Default Opensuse 13.1 boot issue

    I just did an install of opensuse 13.1 on a new disk and when it boots i get the message "multiple active partitions" then it tells me to reboot. I have installed with GRUB2 and reinstalled with the older GRUB but i still get the same issue. I tried reinstalling with multiple different options but i still get the same error. This is the only disk in the computer. Any ideas how to fix this?

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Opensuse 13.1 boot issue

    UEFI or BIOS?

    Also if you can boot to a live Linux cd/dvd can you show us as root

    fdisk -l

    That is a lower case L not a one

    Sound like you did a mbr install and you have multiple partitions marked as boot

    If you are not dual booting you may set teh MBR to contain grub. That should eliminate the problem since grub mbr does not rely on boot flags.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: Opensuse 13.1 boot issue

    Quote Originally Posted by magusyilie View Post
    Any ideas how to fix this?
    Boot the install media. If you used the install DVD, then boot into rescue mode. If you installed from live media, then get a terminal prompt, and use the "su" command to become root.

    As root, in a terminal, run "fdisk" on your hard drive. That's probably
    Code:
    fdisk /dev/sda
    though it is possible that the hard drive will be "/dev/sdb".
    You should see something like this:
    Code:
    # fdisk -l /dev/sdd
    
    Disk /dev/sdd: 4041 MB, 4041211904 bytes, 7892992 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0xa893698d
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1            4084       12275        4096   ef  EFI (FAT-12/16/32)
    /dev/sdd2   *       12276     1929215      958470   83  Linux
    /dev/sdd3         1929216     7890944     2980864+  83  Linux
    Note that the above is "fdisk" on a live KDE install USB for 13.1. That's not important here. The last few lines are the partitions. Notice the "Boot" column. That tells me that the second partition is marked as active. I expect that you will see two or more "*" there. That's your problem. So you need to turn off the active flag for all partitions except the real boot partition.

    To turn off the active flag for partition 2, in the above listing, I would use:
    Code:
    # fdisk /dev/sdd
    Welcome to fdisk (util-linux 2.23.2).
    
    Changes will remain in memory only, until you decide to write them.
    Be careful before using the write command.
    
    
    Command (m for help): p
    
    Disk /dev/sdd: 4041 MB, 4041211904 bytes, 7892992 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0xa893698d
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1            4084       12275        4096   ef  EFI (FAT-12/16/32)
    /dev/sdd2   *       12276     1929215      958470   83  Linux
    /dev/sdd3         1929216     7890944     2980864+  83  Linux
    
    Command (m for help): a
    Partition number (1-3, default 3): 2
    
    Command (m for help): p
    
    Disk /dev/sdd: 4041 MB, 4041211904 bytes, 7892992 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk label type: dos
    Disk identifier: 0xa893698d
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdd1            4084       12275        4096   ef  EFI (FAT-12/16/32)
    /dev/sdd2           12276     1929215      958470   83  Linux
    /dev/sdd3         1929216     7890944     2980864+  83  Linux
    
    Command (m for help): w
    In the above: the "p" command prints (displays) the partition table.
    the "a" command toggles (or flips) an active bit.

    When I used the "a" command, it asked me which partition. I entered "2" (without the quotes). I then used "p" again to print the revised partition table. Finally, the "w" command writes the changes and quits. I did not do that. I instead used the "q" command to quit without writing.

    I hope that helps. Ask if you still have questions.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Opensuse 13.1 boot issue

    Quote Originally Posted by magusyilie View Post
    I just did an install of opensuse 13.1 on a new disk and when it boots i get the message "multiple active partitions" then it tells me to reboot. I have installed with GRUB2 and reinstalled with the older GRUB but i still get the same issue. I tried reinstalling with multiple different options but i still get the same error. This is the only disk in the computer. Any ideas how to fix this?
    Boot with GParted (or partitioner of your choice).

    It will probably show either 2 partitions with "boot" flags or 2 partitions with "active" flags, depending on the partitioner you use.

    Leave the flag turned on for the correct boot partition, turn the other flag off.

    -fb
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  5. #5

    Default Re: Opensuse 13.1 boot issue

    Did another reinstall and seemed to have fixed the issue. I unchecked the automatically configure box at the start of the install and when i got the the partition part i did an edit and told it to use the whole drive. When i did that i noticed it deleted 4 partitions and gave me 3 this time instead of 4. All is working fine now. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •