Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Samba and guest access

  1. #1

    Default Samba and guest access

    I'm setting up a simple samba share on my home network. I would like guest access (no prompt for username & pass) and write access on my /home dir. Right now, when I browse to my samba share it prompts for a username and pass despite having the allow guest options in my conf. It won't even let me login to my own share with my current username and pass. I've tried many other options and commenting various lines in the global part but nothing works. Here's my smb.conf
    Code:
    [global]
        workgroup = WORKGROUP
        netbios name = Devbook
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = No
        domain logons = Yes
        domain master = Yes
        security = user
        wins support = No
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        local master = Yes
        os level = 65
        preferred master = Yes
        wins server =
    [users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
        browseable = Yes
        create mask = 755
        directory mask = 755
        guest ok = Yes
        guest only = Yes

  2. #2
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba and guest access

    On 1/22/2014 2:36 PM, own3dbydsquared wrote:
    >
    > I'm setting up a simple samba share on my home network. I would like
    > guest access (no prompt for username & pass) and write access on my
    > /home dir. Right now, when I browse to my samba share it prompts for a
    > username and pass despite having the allow guest options in my conf. It
    > won't even let me login to my own share with my current username and
    > pass. I've tried many other options and commenting various lines in the
    > global part but nothing works. Here's my smb.conf



    own3dbydsquared;

    What version of Samba are you using?
    Code:
    /usr/sbin/smbd -V
    Is there any reason you have Samba configured as a PDC on a NT style domain? Seems like a bit of over kill for simple
    file sharing.

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  3. #3

    Default Re: Samba and guest access

    Quote Originally Posted by venzkep View Post
    What version of Samba are you using?
    Code:
    /usr/sbin/smbd -V
    Is there any reason you have Samba configured as a PDC on a NT style domain? Seems like a bit of over kill for simple
    file sharing.
    Running
    Code:
    Version 4.1.3-3.12.1-3127-SUSE-oS13.1-x86_64
    As for the PDC, there's no reason except it was the way I could get it configured through YaST. If I do 'Not a DC' and join the domain anonymously I get the message 'Error getting session_key of SAM pipe. Error was NT_STATUS_NO_USER_SESSION_KEY. Unable to join domain WORKGROUP.' I mean whatever works, I'm ok with.

  4. #4
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba and guest access

    On 1/22/2014 6:26 PM, own3dbydsquared wrote:
    >
    > venzkep;2618595 Wrote:
    >>
    >> What version of Samba are you using?
    >>>

    > Code:
    > --------------------
    > > >

    > > /usr/sbin/smbd -V
    > >

    > --------------------
    >>>

    >>
    >> Is there any reason you have Samba configured as a PDC on a NT style
    >> domain? Seems like a bit of over kill for simple
    >> file sharing.

    > Running
    > Code:
    > --------------------
    > Version 4.1.3-3.12.1-3127-SUSE-oS13.1-x86_64
    > --------------------
    >
    > As for the PDC, there's no reason except it was the way I could get it
    > configured through YaST. If I do 'Not a DC' and join the domain
    > anonymously I get the message 'Error getting session_key of SAM pipe.
    > Error was NT_STATUS_NO_USER_SESSION_KEY. Unable to join domain
    > WORKGROUP.' I mean whatever works, I'm ok with.
    >
    >

    own3dbydsquared;

    This HowTo is getting is a bit out of date but gives the basics for configuring Samba as a Workgroup computer.
    http://www.swerdna.net.au/suselanprimer.html
    There are a few adjustments you need to make for systemd.

    When you access a share on the Linux machine, before a user can be mapped to guest, Samba must know that this is guest
    access. There is no way to know unless you first try to authenticate. See the writeup on the security parameter in man
    smb.conf. In particular this paragraph:
    Note that the name of the resource being requested is not sent to the server until after the server has successfully
    authenticated the client. This is why guest shares don't work in user level security without allowing the server to
    automatically map unknown users into the guest account. See the map to guest parameter for details on doing this.
    Since you wish to access shares in your home directory. The Linux permissions must allow the Samba users to read/write
    the files in the share. Since the Samba guest user is "nobody" in the "nobody" group, you will need to make the shared
    files/directories world accessible.

    The best way by far to handle this is to make sure you setup Samba users properly so you have proper authentication when
    you log on and do not rely on "guest" access. The swerdna's HowTo will give the details on creating samba users with
    smbpasswd. The password you create with smbpasswd should be the Windows password. Your Windows machine will by default
    pass the username/password of the logged on user. You can override this from the "Users" tab of the Control Panel.
    You might be requested to authenticate the first time you try to access a share, but after that you should never get a
    prompt. If you have Linux Clients, then KDE can be configured (Configure Desktop) to pass a given name and password.
    Not sure about gnome.





    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  5. #5
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba and guest access

    On 1/22/2014 6:26 PM, own3dbydsquared wrote:
    > As for the PDC, there's no reason except it was the way I could get it
    > configured through YaST. If I do 'Not a DC' and join the domain
    > anonymously I get the message 'Error getting session_key of SAM pipe.
    > Error was NT_STATUS_NO_USER_SESSION_KEY. Unable to join domain
    > WORKGROUP.' I mean whatever works, I'm ok with.


    Is there an AD in this mix? If not why are you trying to join a domain?
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  6. #6

    Default Re: Samba and guest access

    Quote Originally Posted by venzkep View Post
    Since you wish to access shares in your home directory. The Linux permissions must allow the Samba users to read/write
    the files in the share. Since the Samba guest user is "nobody" in the "nobody" group, you will need to make the shared
    files/directories world accessible.

    The best way by far to handle this is to make sure you setup Samba users properly so you have proper authentication when
    you log on and do not rely on "guest" access. The swerdna's HowTo will give the details on creating samba users with
    smbpasswd. The password you create with smbpasswd should be the Windows password. Your Windows machine will by default
    pass the username/password of the logged on user. You can override this from the "Users" tab of the Control Panel.
    You might be requested to authenticate the first time you try to access a share, but after that you should never get a
    prompt. If you have Linux Clients, then KDE can be configured (Configure Desktop) to pass a given name and password.
    Not sure about gnome.
    Hmm this is not quite what I had in mind. I'd rather not have to make everything 777. So in this case, I'll do what you said first and create a samba user with smbpasswd. From this command:
    Code:
    sudo pdbedit -L
    I can list all users. Right now, only root is listed, not my linux user. So I tried to login to the share using root but that didn't work...interesting. I also tried to do what swerdna's HowTo said:
    Code:
    sudo smbpasswd -a william
    but I can't login with that newly created user either. Another issue, the password I use can't be the same as the current linux user's. Odd.

    Quote Originally Posted by venzkep View Post
    Is there an AD in this mix? If not why are you trying to join a domain?
    Nope, no active directory. Just a simple home network share.

  7. #7
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba and guest access

    On 1/23/2014 11:36 PM, own3dbydsquared wrote:
    >
    > venzkep;2618638 Wrote:
    >>

    <snip>
    >>

    > Hmm this is not quite what I had in mind. I'd rather not have to make
    > everything 777. So in this case, I'll do what you said first and create
    > a samba user with smbpasswd. From this command:
    > Code:
    > --------------------
    > sudo pdbedit -L
    > --------------------
    > I can list all users. Right now, only root is listed, not my linux
    > user. So I tried to login to the share using root but that didn't
    > work...interesting. I also tried to do what swerdna's HowTo said:
    > Code:
    > --------------------
    > sudo smbpasswd -a william
    > --------------------
    > but I can't login with that newly created user either. Another issue,
    > the password I use can't be the same as the current linux user's. Odd.
    >
    > venzkep;2618644 Wrote:
    >>
    >> Is there an AD in this mix? If not why are you trying to join a domain?

    > Nope, no active directory. Just a simple home network share.
    >
    >

    The Samba user you add with "smbpasswd -a" must be a valid Linux user name, but the password created is arbitrary. Make
    your smb.conf conforms with Swerdna's HowTo. The firewall has "Samba Server", "Netbios Server" and "Samba Client" as
    allowed services. Restart (or Start if not running) smbd and nmbd.
    Code:
    systemctl restart smb.service
    systemctl restart nmb.service
    If authentication is still a problem for you, add this parameter to /etc/samba/smb.conf
    Code:
    log level = 0 auth:3
    Restart smbd and then check /var/log/samba/log.smbd to see why your user is not being authenticated.

    When everything is working properly you should see something like the following in your logs:
    Code:
    [2014/01/24 00:26:22.355331,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    check_ntlm_password:  Checking password for unmapped user [SAL2]\[venzke]@[SAL2] with the new password interface
    [2014/01/24 00:26:22.355657,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    check_ntlm_password:  mapped user is: [EULER3]\[venzke]@[SAL2]
    [2014/01/24 00:26:22.358376,  3] ../source3/auth/auth.c:226(auth_check_ntlm_password)
    check_ntlm_password: sam authentication for user [venzke] succeeded
    [2014/01/24 00:26:22.358697,  2] ../source3/auth/auth.c:278(auth_check_ntlm_password)
    check_ntlm_password:  authentication for user [venzke] -> [venzke] -> [venzke] succeeded
    In the above log segment the user name is venzke, the client computer is SAL2 (Vista) and the Samba4 server is EULER3
    (openSUSE 13.1)
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  8. #8

    Default Re: Samba and guest access

    Quote Originally Posted by venzkep View Post
    The firewall has "Samba Server", "Netbios Server" and "Samba Client" as
    allowed services.
    Yup I have both Samba server and client as allowed services. There is no Netbios server option.

    Quote Originally Posted by venzkep View Post
    If authentication is still a problem for you, add this parameter to /etc/samba/smb.conf
    Code:
    log level = 0 auth:3
    Restart smbd and then check /var/log/samba/log.smbd to see why your user is not being authenticated.
    Ok I added that line and here is the output with my smbpasswd -a created user which has to same username as my linux user but different password. (couldnt create with the same)
    Code:
    [2014/01/25 14:06:36.147885,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
      check_ntlm_password:  Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    [2014/01/25 14:06:36.148089,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
      check_ntlm_password:  mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    [2014/01/25 14:06:36.148330,  3] ../source3/auth/check_samsec.c:399(check_sam_security)
      check_sam_security: Couldn't find user 'anonymous' in passdb.
    [2014/01/25 14:06:36.148464,  3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
      check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    [2014/01/25 14:06:36.148556,  2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
      check_ntlm_password:  Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    [2014/01/25 14:06:36.148681,  3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
      No such user anonymous [WORKGROUP] - using guest account
    [2014/01/25 14:06:37.403671,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
      check_ntlm_password:  Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    [2014/01/25 14:06:37.403831,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
      check_ntlm_password:  mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    [2014/01/25 14:06:37.403954,  3] ../source3/auth/check_samsec.c:399(check_sam_security)
      check_sam_security: Couldn't find user 'anonymous' in passdb.
    [2014/01/25 14:06:37.404030,  3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
      check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    [2014/01/25 14:06:37.404085,  2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
      check_ntlm_password:  Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    [2014/01/25 14:06:37.404148,  3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
      No such user anonymous [WORKGROUP] - using guest account
    [2014/01/25 14:06:41.519280,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
      check_ntlm_password:  Checking password for unmapped user [WORKGROUP]\[linux_user]@[DEVBOOK] with the new password interface
    [2014/01/25 14:06:41.519433,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
      check_ntlm_password:  mapped user is: [WORKGROUP]\[linux_user]@[DEVBOOK]
    [2014/01/25 14:06:41.520513,  3] ../source3/auth/auth.c:226(auth_check_ntlm_password)
      check_ntlm_password: sam authentication for user [linux_user] succeeded
    [2014/01/25 14:06:41.520635,  2] ../source3/auth/auth.c:278(auth_check_ntlm_password)
      check_ntlm_password:  authentication for user [linux_user] -> [linux_user] -> [linux_user] succeeded
    So it succedded yet when I hit enter it stills prompts me for a username and password...

    Now when I use my linux username and password here's the output.
    Code:
    [2014/01/25 14:17:51.270453,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
      check_ntlm_password:  Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    [2014/01/25 14:17:51.270577,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
      check_ntlm_password:  mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    [2014/01/25 14:17:51.270691,  3] ../source3/auth/check_samsec.c:399(check_sam_security)
      check_sam_security: Couldn't find user 'anonymous' in passdb.
    [2014/01/25 14:17:51.270750,  3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
      check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    [2014/01/25 14:17:51.270794,  2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
      check_ntlm_password:  Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    [2014/01/25 14:17:51.270869,  3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
      No such user anonymous [WORKGROUP] - using guest account
    [2014/01/25 14:17:53.392674,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
      check_ntlm_password:  Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    [2014/01/25 14:17:53.392809,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
      check_ntlm_password:  mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    [2014/01/25 14:17:53.392957,  3] ../source3/auth/check_samsec.c:399(check_sam_security)
      check_sam_security: Couldn't find user 'anonymous' in passdb.
    [2014/01/25 14:17:53.393036,  3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
      check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    [2014/01/25 14:17:53.393083,  2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
      check_ntlm_password:  Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    [2014/01/25 14:17:53.393143,  3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
      No such user anonymous [WORKGROUP] - using guest account
    [2014/01/25 14:17:57.889053,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
      check_ntlm_password:  Checking password for unmapped user [WORKGROUP]\[linux_user]@[DEVBOOK] with the new password interface
    [2014/01/25 14:17:57.889171,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
      check_ntlm_password:  mapped user is: [WORKGROUP]\[linux_user]@[DEVBOOK]
    [2014/01/25 14:17:57.890003,  3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
      check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    [2014/01/25 14:17:57.890064,  2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
      check_ntlm_password:  Authentication for user [linux_user] -> [linux_user] FAILED with error NT_STATUS_WRONG_PASSWORD
    [2014/01/25 14:17:57.890828,  3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
      check_ntlm_password:  Checking password for unmapped user []\[]@[] with the new password interface
    [2014/01/25 14:17:57.890889,  3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
      check_ntlm_password:  mapped user is: [WORKGROUP]\[]@[]
    [2014/01/25 14:17:57.890960,  3] ../source3/auth/auth.c:226(auth_check_ntlm_password)
      check_ntlm_password: guest authentication for user [] succeeded
    So this one also succeed but stills prompts me after I entered correct authentication. Very strange.

  9. #9
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Samba and guest access

    On 1/25/2014 1:26 PM, own3dbydsquared wrote:
    >
    > venzkep;2618913 Wrote:
    >> The firewall has "Samba Server", "Netbios Server" and "Samba Client" as
    >> allowed services.

    > Yup I have both Samba server and client as allowed services. There is no
    > Netbios server option.


    Well you should have the netbios server (nmb) started and allowed.
    >
    > venzkep;2618913 Wrote:
    >> If authentication is still a problem for you, add this parameter to
    >> /etc/samba/smb.conf
    >>>

    > Code:
    > --------------------
    > > >

    > > log level = 0 auth:3
    > >

    > --------------------
    >>>

    >> Restart smbd and then check /var/log/samba/log.smbd to see why your
    >> user is not being authenticated.
    >>

    > Ok I added that line and here is the output with my smbpasswd -a created
    > user which has to same username as my linux user but different password.
    > (couldnt create with the same)

    What error message do you get when you try to make them the same? In any event the password you submit to the Samba4
    server is the one created with smbpasswd.

    >
    > Code:
    > --------------------
    > [2014/01/25 14:06:36.147885, 3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    > check_ntlm_password: Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    > [2014/01/25 14:06:36.148089, 3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    > check_ntlm_password: mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    > [2014/01/25 14:06:36.148330, 3] ../source3/auth/check_samsec.c:399(check_sam_security)
    > check_sam_security: Couldn't find user 'anonymous' in passdb.
    > [2014/01/25 14:06:36.148464, 3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
    > check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    > [2014/01/25 14:06:36.148556, 2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
    > check_ntlm_password: Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    > [2014/01/25 14:06:36.148681, 3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
    > No such user anonymous [WORKGROUP] - using guest account
    > [2014/01/25 14:06:37.403671, 3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    > check_ntlm_password: Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    > [2014/01/25 14:06:37.403831, 3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    > check_ntlm_password: mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    > [2014/01/25 14:06:37.403954, 3] ../source3/auth/check_samsec.c:399(check_sam_security)
    > check_sam_security: Couldn't find user 'anonymous' in passdb.
    > [2014/01/25 14:06:37.404030, 3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
    > check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    > [2014/01/25 14:06:37.404085, 2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
    > check_ntlm_password: Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    > [2014/01/25 14:06:37.404148, 3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
    > No such user anonymous [WORKGROUP] - using guest account
    > [2014/01/25 14:06:41.519280, 3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    > check_ntlm_password: Checking password for unmapped user [WORKGROUP]\[linux_user]@[DEVBOOK] with the new password interface
    > [2014/01/25 14:06:41.519433, 3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    > check_ntlm_password: mapped user is: [WORKGROUP]\[linux_user]@[DEVBOOK]
    > [2014/01/25 14:06:41.520513, 3] ../source3/auth/auth.c:226(auth_check_ntlm_password)
    > check_ntlm_password: sam authentication for user [linux_user] succeeded
    > [2014/01/25 14:06:41.520635, 2] ../source3/auth/auth.c:278(auth_check_ntlm_password)
    > check_ntlm_password: authentication for user [linux_user] -> [linux_user] -> [linux_user] succeeded
    > --------------------
    >
    >
    > So it succedded yet when I hit enter it stills prompts me for a username
    > and password...


    >
    > Now when I use my linux username and password here's the output.
    >
    > Code:
    > --------------------
    > [2014/01/25 14:17:51.270453, 3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    > check_ntlm_password: Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    > [2014/01/25 14:17:51.270577, 3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    > check_ntlm_password: mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    > [2014/01/25 14:17:51.270691, 3] ../source3/auth/check_samsec.c:399(check_sam_security)
    > check_sam_security: Couldn't find user 'anonymous' in passdb.
    > [2014/01/25 14:17:51.270750, 3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
    > check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    > [2014/01/25 14:17:51.270794, 2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
    > check_ntlm_password: Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    > [2014/01/25 14:17:51.270869, 3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
    > No such user anonymous [WORKGROUP] - using guest account
    > [2014/01/25 14:17:53.392674, 3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    > check_ntlm_password: Checking password for unmapped user [WORKGROUP]\[anonymous]@[DEVBOOK] with the new password interface
    > [2014/01/25 14:17:53.392809, 3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    > check_ntlm_password: mapped user is: [WORKGROUP]\[anonymous]@[DEVBOOK]
    > [2014/01/25 14:17:53.392957, 3] ../source3/auth/check_samsec.c:399(check_sam_security)
    > check_sam_security: Couldn't find user 'anonymous' in passdb.
    > [2014/01/25 14:17:53.393036, 3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
    > check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    > [2014/01/25 14:17:53.393083, 2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
    > check_ntlm_password: Authentication for user [anonymous] -> [anonymous] FAILED with error NT_STATUS_NO_SUCH_USER
    > [2014/01/25 14:17:53.393143, 3] ../source3/auth/auth_util.c:1593(do_map_to_guest_server_info)
    > No such user anonymous [WORKGROUP] - using guest account
    > [2014/01/25 14:17:57.889053, 3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    > check_ntlm_password: Checking password for unmapped user [WORKGROUP]\[linux_user]@[DEVBOOK] with the new password interface
    > [2014/01/25 14:17:57.889171, 3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    > check_ntlm_password: mapped user is: [WORKGROUP]\[linux_user]@[DEVBOOK]
    > [2014/01/25 14:17:57.890003, 3] ../source3/auth/auth_winbind.c:60(check_winbind_security)
    > check_winbind_security: Not using winbind, requested domain [WORKGROUP] was for this SAM.
    > [2014/01/25 14:17:57.890064, 2] ../source3/auth/auth.c:288(auth_check_ntlm_password)
    > check_ntlm_password: Authentication for user [linux_user] -> [linux_user] FAILED with error NT_STATUS_WRONG_PASSWORD
    > [2014/01/25 14:17:57.890828, 3] ../source3/auth/auth.c:177(auth_check_ntlm_password)
    > check_ntlm_password: Checking password for unmapped user []\[]@[] with the new password interface
    > [2014/01/25 14:17:57.890889, 3] ../source3/auth/auth.c:180(auth_check_ntlm_password)
    > check_ntlm_password: mapped user is: [WORKGROUP]\[]@[]
    > [2014/01/25 14:17:57.890960, 3] ../source3/auth/auth.c:226(auth_check_ntlm_password)
    > check_ntlm_password: guest authentication for user [] succeeded
    > --------------------
    >
    >
    > So this one also succeed but stills prompts me after I entered correct
    > authentication. Very strange.
    >
    >

    What OS is being run on your clients? Start nmb and allow it through your firewall. Does your smb.conf conform to what
    is outlined in Swerdna's article? Perhaps you need to post your current /etc/samba/smb.conf.

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  10. #10

    Default Re: Samba and guest access

    Quote Originally Posted by venzkep View Post
    What error message do you get when you try to make them the same? In any event the password you submit to the Samba4
    server is the one created with smbpasswd.
    Hmm I removed my user and added it again, this time it worked.
    Quote Originally Posted by venzkep View Post
    What OS is being run on your clients? Start nmb and allow it through your firewall. Does your smb.conf conform to what
    is outlined in Swerdna's article? Perhaps you need to post your current /etc/samba/smb.conf.
    OS is suse 13.1 and Windows 7. There is no option for netbios server in software management or firewall. Apart from logon paths, yes it conforms to Swerdna's guide. If I comment them out, it makes no difference.
    Here is my current smb.conf
    Code:
    [global]
        workgroup = WORKGROUP
        netbios name = Devbook
        passdb backend = tdbsam
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        usershare allow guests = No
        domain logons = Yes
        domain master = Yes
        security = user
        wins support = No
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        local master = Yes
        os level = 65
        preferred master = Yes
        wins server = 
        log level = 0 auth:3
    [users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
        browseable = Yes
        create mask = 755
        directory mask = 755
        guest ok = Yes
        guest only = Yes
    [netlogon]
        comment = Network Logon Service
        path = /var/lib/samba/netlogon
        write list = root

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •