Results 1 to 7 of 7

Thread: VSFTPD service wont start or detect

  1. #1

    Default VSFTPD service wont start or detect

    Hi,
    In one of my machines vsftp will not start, can anyone help?
    the vsftpd is installed.
    using: opensuse 13.1 64 bits

    this is what i get:

    falsename:/usr/sbin # vsftpd status
    500 OOPS: missing value in config file for: import re, os, sys


    falsename:/usr/sbin # rcvsftpd start
    rcvsftpd: no such service vsftpd

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: VSFTPD service wont start or detect

    On 2014-01-22 13:16, velhodechapeu wrote:
    >
    > Hi,
    > In one of my machines vsftp will not start, can anyone help?
    > the vsftpd is installed.
    > using: opensuse 13.1 64 bits
    >
    > this is what i get:
    >
    > falsename:/usr/sbin # vsftpd status
    > 500 OOPS: missing value in config file for: import re, os, sys


    vsftp can be configured as a daemon or via xinit. Which one have you
    configured?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3

    Default Re: VSFTPD service wont start or detect

    Hi robin,

    I use it manually, with your question I decided to try it set to start at boot and it worked. I will fall back to manual start to see how it goes and will post the result.

  4. #4

    Default Re: VSFTPD service wont start or detect

    Back!
    vsftpd works normally when loaded at boot. rcvsftpd start, stop, reload, all normal.

    But, it does not work when set to start manually.

    looks like you are right the problem seem to be in the inicialization method.

    what you suggest?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,496

    Default Re: VSFTPD service wont start or detect

    Quote Originally Posted by velhodechapeu View Post
    Back!
    vsftpd works normally when loaded at boot. rcvsftpd start, stop, reload, all normal.
    I do not think that is handled with what you suggest. It is all systemd nowadays.
    Henk van Velden

  6. #6

    Default Re: VSFTPD service wont start or detect [solved]

    Hi hcvv,


    Following your suggestion I found this article.

    using systemctl worked perfectly.

    thank you hcvv and robin for your help.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: VSFTPD service wont start or detect

    On 2014-01-22 16:46, velhodechapeu wrote:
    >
    > Hi hcvv,
    >
    >
    > Following your suggestion I found this 'article.'
    > (http://tinyurl.com/alj8e74)
    >
    > using systemctl worked perfectly.
    >
    > thank you hcvv and robin for your help.



    There are two ways to start vsftpd. As a service, all the time present,
    via systemd. Or, when an outside internet request comes to use the ftp
    server, it is started automatically by the xinit daemon, which makes a
    lot of sense for occasional use.

    The configuration settings are just a bit different, and trying to use
    the wrong one produces error messages similar to those you got.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •