Results 1 to 10 of 10

Thread: Unable to install latest updates due to conflict

  1. #1

    Default Unable to install latest updates due to conflict

    I am unable to install the latest updates to 13.1 due to the following conflict:

    patchpenSUSE-2014-61-1.noarch conflicts with libreoffice-icon-theme-oxygen.noarch < 4.1.4.2-13.1 provided by libreoffice-icon-theme-oxygen-4.1.4.2-6.1.noarch

    I have tried unchecking this update, but the conflict still comes up. I have tried uninstalling libreoffice, but the conflict still comes up.

    Any suggestions as to how I can solve this are most welcome.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,607
    Blog Entries
    3

    Default Re: Unable to install latest updates due to conflict

    I just ran those updates, and they were fine for me. There was version 4.1.4.2-13.1 of libreoffice-icon-theme-oxygen.noarch in the repos.

    Two possibilities: perhaps you have something else installed that is blocking that version;

    or, perhaps your update attempt connected to a bad mirror (not fully updated). I'm guessing the second of those. In that case, wait a few hours and try again.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Unable to install latest updates due to conflict

    Thanks for the suggestion.

    Having already waited for about 12 hours, I decided to try reinstalling libreoffice, but still had the same problem with updating. So I uninstalled libreoffice again, this time with all the icon themes. After this I was able to perform the updates with no problems. I've been using calligra more and more of late - and quite liking it - so I don't think I'll miss libreoffice.

  4. #4

    Default Re: Unable to install latest updates due to conflict

    Quote Originally Posted by maiqiang View Post
    Thanks for the suggestion.

    Having already waited for about 12 hours, I decided to try reinstalling libreoffice, but still had the same problem with updating. So I uninstalled libreoffice again, this time with all the icon themes. After this I was able to perform the updates with no problems. I've been using calligra more and more of late - and quite liking it - so I don't think I'll miss libreoffice.
    Apparently you had libreoffice-icon-theme-oxygen from the LibreOffice:Stable repo installed. Since vendor changes are not done automatically, you got that conflict.
    Remove that repo and you should be able to install libreoffice from the update repo. It is the same version anyway (4.1.4.2).

  5. #5

    Default Re: Unable to install latest updates due to conflict

    Thanks for the help!

  6. #6

    Default Re: Unable to install latest updates due to conflict

    Same problem here, have added the opensuse libreoffice repo, but still the same conflict. The 4 icon themes (galaxy, crystal, oxygen, hicontrast) are to be removed, but this is not possible because they are reported as 'not installed', even though they are installed. I cannot get rid of Apper, because it permanently finds this security update for LibreOffice.
    None of this is really important - it does not restrict use of the system in any way - but it is puzzling. Using 64-bit OpenSuse 13.1, KDE, 6GB working memory, 2TB harddisk.

    Any ideas, or have I (as usual) left out all important infos?

    Thanks in advance in any case!



  7. #7

    Default Re: Unable to install latest updates due to conflict

    Quote Originally Posted by eidos2 View Post
    Any ideas, or have I (as usual) left out all important infos?
    Remove the LibreOffice:Stable repo, and switch all LibreOffice packages to the versions from the standard update repo.
    You don't need that repo anyway, as the same version has been released as standard update for 13.1.

  8. #8

    Default Re: Unable to install latest updates due to conflict

    PS, I somehow missed this earlier, but it might be significant:
    Quote Originally Posted by eidos2 View Post
    The 4 icon themes (galaxy, crystal, oxygen, hicontrast) are to be removed, but this is not possible because they are reported as 'not installed', even though they are installed.
    There seems to be a mismatch between the installed packages and PackageKit or zypper's cache.
    Try to remove the latter:
    Code:
    sudo rm -r /var/cache/zypp
    Then run "sudo zypper patch" and post any error message you might get.

  9. #9

    Default Re: Unable to install latest updates due to conflict

    Quote Originally Posted by wolfi323 View Post
    PS, I somehow missed this earlier, but it might be significant:

    There seems to be a mismatch between the installed packages and PackageKit or zypper's cache.
    Try to remove the latter:
    Code:
    sudo rm -r /var/cache/zypp
    Then run "sudo zypper patch" and post any error message you might get.
    Thanks wolfi - but no error messages after all that (it just says "keine auszuführenden Aktionen"). I think I must just have messed up the repos. Don't have time at the moment, but I shall be taking your advice and changing the repos. Or not - I intend to go on to 13.2 soon anyhow. I should know better than to muck about with the repos, but there it is. One day maybe I will learn. . It's about time I did!

  10. #10

    Default Re: Unable to install latest updates due to conflict

    Have now got rid of the offending repo, problem solved. Wolfi was quite right of course - many thanks! (Let this be a warning to people like me who don't bother informing themselves properly about repos..... mea culpa!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •