Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to enable atheros wlan

  1. #1
    Join Date
    Jan 2014
    Location
    Nijmegen
    Posts
    64

    Default How to enable atheros wlan

    I'm new to Opensuse, and don't know a lot about it.
    My problem is that my network adapter seems to be disabled, I checked this file: /var/log/NetworkManager, this tells me the following, Wifi hardware radio set enabled and than wifi disabled by radio killswitch; enabled by state file.
    Next I checked Yast2 hardware information: Atheros WLAN controller, under drivers it says, Hwcfg bus: pci, Kernal Driver: ath9k, Model: Atheros WLAN controller, Old unique key: AVTU.H5RAfYdeFm9 and Parent Unique ID: qTvu.E08RIX_0lM2
    The Enable wireless option does not do anything upon clicking.
    I read the sticky threads but I still don't know what to do.
    Out of this line: wifi disabled by radio killswitch; enabled by state file. i guess, the radio killswitch disabled WIFI and that it can be enabled by the state file, but I don't know how to do this.
    Any help will be greatly appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,350
    Blog Entries
    15

    Default Re: How to enable atheros wlan

    Hi
    You need to install the package called rfkill;
    Code:
    zypper in rfkill
    rfkill list
    rfkill unblock n
    Where n is the identifies from the list.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jan 2014
    Location
    Nijmegen
    Posts
    64

    Default Re: How to enable atheros wlan

    how do I install rfkill without internet?
    do you mean n=ath9k?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,350
    Blog Entries
    15

    Default Re: How to enable atheros wlan

    Quote Originally Posted by AndrewAmmerlaan View Post
    how do I install rfkill without internet?
    do you mean n=ath9k?
    Hi
    From the install medium. just open a terminal, switch to root user (su -) and run the zypper command and the others indicated in the previous post.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jan 2014
    Location
    Nijmegen
    Posts
    64

    Default Re: How to enable atheros wlan

    After completely unplugging everything, I managed to move it all closer to the router, and after a long search i found a spare LAN cable. Installing now, but the installer also wants to install 200 other packages so it's going to take a while.
    Thanks for your help

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,350
    Blog Entries
    15

    Default Re: How to enable atheros wlan

    Quote Originally Posted by AndrewAmmerlaan View Post
    After completely unplugging everything, I managed to move it all closer to the router, and after a long search i found a spare LAN cable. Installing now, but the installer also wants to install 200 other packages so it's going to take a while.
    Thanks for your help
    Hi
    Yes, probably some updates etc
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jan 2014
    Location
    Nijmegen
    Posts
    64

    Default Re: How to enable atheros wlan

    the konsole says rfkill command not found

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,350
    Blog Entries
    15

    Default Re: How to enable atheros wlan

    Quote Originally Posted by AndrewAmmerlaan View Post
    the konsole says rfkill command not found
    Hi
    So, switch to root user and install it
    Code:
    su -
    password:
    zypper in rfkill
    It does need to be run as root user as well.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Jan 2014
    Location
    Nijmegen
    Posts
    64

    Default Re: How to enable atheros wlan

    Oke found that, now the konsole says: 1: phy0 Wireless LAN
    soft blocked: no
    hard blocked: yes
    unblock 1 does not work

  10. #10
    Join Date
    Jan 2014
    Location
    Nijmegen
    Posts
    64

    Default Re: How to enable atheros wlan

    OOOOOMMMMGGG i am so stupid, i pressed fn f12 and now there is no hard blocked anymore
    thanks for your help

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •