Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Slow NIS/NFS-Login on Suse 13.1

  1. #1

    Default Slow NIS/NFS-Login on Suse 13.1

    Hey dear Community!
    This is my first post here so please be indulgent
    A few days ago I set up a server and a client running Suse 13.1 using NIS and NFS. In principle everything is working: I am able to login from the client, I can see all users and the home partitions are where they should be. The problem is the time that is needed for the graphical login: After typing in the user password it takes about 20-30 secs to reach the graphical surface (this is annoyingly long because thanks to ssds the complete boot up only takes a few seconds).
    So my first idea was that NIS or NFS are not working properly.
    Here is what I did so far:

    • First i checked the yp services: everything is running fine.
    • Second i disabled the nfs auto-mounter and logged in as root. Then I mounted the nfs-exported directory via console. This was happening instantanously and any working on the mounted partition was happening fast (so i think nfs works fine).
    • Third i enabled nfs auto-mounter again and logged in via ssh. This is working without delay too (this means to me nis is fine too).


    So I think it is a problem with the kde plasma desktop which maybe has some timeout or so. Unfortunately I have no idea how to go on from here. This is how my dmesg looks on the client side after login of the user christoph:
    Code:
    2014-01-20T19:37:26.842630+01:00 t1 kernel: [ 7334.530033] nvidia 0000:01:00.0: irq 47 for MSI/MSI-X
    2014-01-20T19:37:27.236828+01:00 t1 kdm[1399]: Quitting Plymouth with transition
    2014-01-20T19:37:27.238574+01:00 t1 kdm[1399]: Is Plymouth still running? no
    2014-01-20T19:37:27.430553+01:00 t1 kdm_greet[3918]: Cannot load /usr/share/kde4/apps/kdm/faces/.default.face: Datei oder Verzeichnis nicht gefunden
    2014-01-20T19:37:29.096978+01:00 t1 systemd-logind[598]: Removed session 12.
    2014-01-20T19:37:45.727438+01:00 t1 kdm: :0[3917]: pam_unix(xdm:session): session opened for user christoph by (uid=0)
    2014-01-20T19:37:45.728663+01:00 t1 systemd[1]: Starting Session 13 of user christoph.
    2014-01-20T19:37:45.728877+01:00 t1 systemd-logind[598]: New session 13 of user christoph.
    2014-01-20T19:37:45.729042+01:00 t1 systemd-logind[598]: Linked /tmp/.X11-unix/X0 to /run/user/1000/X11-display.
    2014-01-20T19:37:45.729173+01:00 t1 systemd[1]: Started Session 13 of user christoph.
    2014-01-20T19:37:49.020997+01:00 t1 dbus[595]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
    2014-01-20T19:37:49.032922+01:00 t1 dbus[595]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
    2014-01-20T19:38:02.401601+01:00 t1 dbus[595]: [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
    2014-01-20T19:38:02.412146+01:00 t1 dbus[595]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
    2014-01-20T19:38:05.633666+01:00 t1 polkitd[625]: Registered Authentication Agent for unix-session:13 (system bus name :1.125 [/usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale de_DE.UTF-8)
    2014-01-20T19:38:16.917122+01:00 t1 su: (to christoph) christoph on none
    2014-01-20T19:38:16.917582+01:00 t1 su: pam_unix(su:session): session opened for user root by christoph(uid=1000)
    2014-01-20T19:38:16.918999+01:00 t1 su: pam_systemd(su:session): pam_putenv: delete non-existent entry; XDG_RUNTIME_DIR
    Don't get confused by the backlighthelper, I already tried to switch that off.This increases speed a little but the problem still remains. My candidate is the line where "polkit" is mentioned (It seems to take really long to complete this registration process). Does anyone have a idea how I can solve this? Can this issue be related to a slow network? How can I figure out where exactly the system hangs (/var/log/message output is little bit poor here)?
    Thank you for any advice!

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    Hi welcome, here,

    I do use NIS and NFS, though the server side not on 13.1 yet. Re. the client, I never used the automounter, but NFS on it's own, i.e. I export /home from the server, mount it on the clients, that are also connected through NIS. In 13.1 access to NFS configuration has been integrated in the NIS module. Re. NFS I've only used NFS version 3 so far.

    A thing to consider here is that /home is on the server, so the SSD on your laptop can be fast as lightning, your ~/.kde4 is on the server, so speed depends on how fast the server can deliver the ~/.kde4 to the client. I assume the server doesn't have /home on an SSD.
    Another thing is the network itself. Mine is Gigabit network cards, cat6 ethernet,

    Just experimented, by mounting my server's /home on my laptop. Getting to the desktop requires ~20 secs, where normally it's just a couple of secs.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    Meschi wrote:
    > Hey dear Community!
    > This is my first post here so please be indulgent


    Hello and welcome.

    > So I think it is a problem with the kde plasma desktop which maybe has
    > some timeout or so. Unfortunately I have no idea how to go on from here.


    You can test this in a different way by just switching the session type
    at login so you login to a different desktop. I'd pick a simpler one
    such as LXDE.

    Also, your subject line is very misleading if you think the problem is
    with KDE. Not many people understand NFS so probably most people won't
    read your post. And even fewer understand NIS! I did read it because I
    understand a little about those two, but unfortunately I know nothing
    about KDE! Similarly, anybody who tries to help with KDE problems is not
    likely to read this thread.

  4. #4

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    Quote Originally Posted by djh-novell View Post
    Also, your subject line is very misleading if you think the problem is
    with KDE. Not many people understand NFS so probably most people won't
    read your post. And even fewer understand NIS! I did read it because I
    understand a little about those two, but unfortunately I know nothing
    about KDE! Similarly, anybody who tries to help with KDE problems is not
    likely to read this thread.
    Hm ok you are right, this is good point. I am not completely sure about the plasma desktop. Maybe some NIS/NFS specialist would have found that it is a NIS problem indeed I'll change the title if I am able to

  5. #5

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    Meschi wrote:
    > djh-novell;2618084 Wrote:
    >> Also, your subject line is very misleading if you think the problem is
    >> with KDE. Not many people understand NFS so probably most people won't
    >> read your post. And even fewer understand NIS! I did read it because I
    >> understand a little about those two, but unfortunately I know nothing
    >> about KDE! Similarly, anybody who tries to help with KDE problems is not
    >> likely to read this thread.

    > Hm ok you are right, this is good point. I am not completely sure about
    > the plasma desktop. Maybe some NIS/NFS specialist would have found that
    > it is a NIS problem indeed I'll change the title if I am able to


    Knurpht suggests that what you're experiencing might be quite normal.

    FWIW, I used to NFS mount my home directory for many years. In more
    recent times I've taken to having a local home directory with symlinks
    to subdirectories on an NFS-mounted home. There are two reasons for that
    design:

    (1) Your session doesn't immediately lock up if there's a problem with
    NFS, so you stand some chance of fixing the problem and carrying on.

    (2) It's easier to install multiple OS versions. Installing a new or
    different Linux version creates a new home directory with new dot files
    that don't disturb your working system. Then you create new symlinks
    Pictures, Documents etc to your existing data and so on

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    BTW, and not knowing if this is of any importance re. speed: did you add your server and client to eachother's /etc/hosts ?

    Another thing: googling "kde nfs shared home" gives a lot of hits, for most linux distros, so there might be something here. I don't have the time to read them all.
    IMHO this should work. NFS has been there for a long time, it belongs to linux. KDE should work fine.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    Quote Originally Posted by Knurpht View Post
    Hi welcome, here,

    I do use NIS and NFS, though the server side not on 13.1 yet. Re. the client, I never used the automounter, but NFS on it's own, i.e. I export /home from the server, mount it on the clients, that are also connected through NIS. In 13.1 access to NFS configuration has been integrated in the NIS module. Re. NFS I've only used NFS version 3 so far.

    A thing to consider here is that /home is on the server, so the SSD on your laptop can be fast as lightning, your ~/.kde4 is on the server, so speed depends on how fast the server can deliver the ~/.kde4 to the client. I assume the server doesn't have /home on an SSD.
    Another thing is the network itself. Mine is Gigabit network cards, cat6 ethernet,

    Just experimented, by mounting my server's /home on my laptop. Getting to the desktop requires ~20 secs, where normally it's just a couple of secs.
    Hi Knurpht, thanks for your replies! I'll answer them step by step

    It seems like my setup is interesting for you guys so here it is:
    The server has i7,16Gb ram with a ssd for the system (/) and a hdd on which the home directory is located. The clients (i5,8Gb ram) do have an own ssd where their local system is installed without home directory (this is mounted via nfs from the server). Therefore the limiting factor for NIS should be our network (because the ssds are fast). For the NFS it could be either the slower hdd (as you said) or the network but I do not believe it is the hdd because manual mounting or ssh from the client works very fast (just like writing to it).

  9. #9

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    Quote Originally Posted by Knurpht View Post
    BTW, and not knowing if this is of any importance re. speed: did you add your server and client to eachother's /etc/hosts ?
    I did this eventhough I do not really think it should matter (I did not have to do this in suse 12.3). I added them to /etc/hosts on the server which i map via NIS.
    Quote Originally Posted by Knurpht View Post
    Another thing: googling "kde nfs shared home" gives a lot of hits, for most linux distros, so there might be something here. I don't have the time to read them all.
    IMHO this should work. NFS has been there for a long time, it belongs to linux. KDE should work fine.
    I really spend much time googling on this Forum is my last hope

  10. #10

    Default Re: Slow NIS/NFS-Login on Suse 13.1

    Quote Originally Posted by Knurpht View Post
    I already thought about the async option but it does not solve the problem. (Actually I am glad that it does not because I really would prefer to stay with sync)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •