Results 1 to 5 of 5

Thread: How to disable/modify the terminal-box of grub2

  1. #1

    Default How to disable/modify the terminal-box of grub2

    I use grub2 with the theme openSUSE, graphical mode and a (custom) background image.
    after selecting the boot mode, grub creates a black terminal-box of size about 70% of
    the screen, and writes two lines:
    Code:
    Loading Linux 3.11.6-4-desktop ...
    Loading initial ramdisk ...
    (by the way: The lines are pretty useless, since they disappear too fast and can't be properly read. It seems that
    they are not stored in any logfile either. I listed out what they say by looking into /boot/grub2/grub.cnf )

    I would like to:
    (a) get rid of this black box (I can accept keeping the displayed text or warning messages that may appear in the future) or
    (b) modify it.
    Things I tried but did not work:
    (a) adding a line GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/bkg.png to /etc/default/grub
    (b) modifying all files terminal*.png in /boot/grub2/themes/openSUSE to custom files
    in either case, the modifications make no difference and the black terminal box still appears on top of the background image.
    Any hint? Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: How to disable/modify the terminal-box of grub2

    No

    But it happens on my machines

    It doesn't upset me though. I only see it once in a while, after a reboot.

    FYI: You could be tempting fate messing with it IMO
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Sep 2012
    Posts
    7,106

    Default Re: How to disable/modify the terminal-box of grub2

    Quote Originally Posted by mnatiello View Post
    I would like to:
    (a) get rid of this black box (I can accept keeping the displayed text or warning messages that may appear in the future)
    Did you test whether removing "echo ..." in grub.cfg helps? I do not see anything that would explicitly display terminal box during boot, so I suspect it happens simply as result of output from commands (which implicitly does terminal box refresh).
    (a) adding a line GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/bkg.png to /etc/default/grub
    That applies to terminal background when you do not use themes. When themes are in use, whatever is defined in theme file is applied.
    (b) modifying all files terminal*.png in /boot/grub2/themes/openSUSE to custom files
    Terminal box background is drawn by stretching terminal_box_c.png. If you remove terminal-box property from theme definition, you in theory should get transparent terminal window.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: How to disable/modify the terminal-box of grub2

    Quote Originally Posted by arvidjaar View Post
    Did you test whether removing "echo ..." in grub.cfg helps? I do not see anything that would explicitly display terminal box during boot, so I suspect it happens simply as result of output from commands (which implicitly does terminal box refresh).
    Arvid, I tried that (I don't care about the box, but wanted to know), even after removal of all the "echo" statements, an empty black box is shown

    EDIT: to the OP: Mind, this box is the place where errors/warnings are shown. If you would be able to remove the box, you wouldn't see these warnings / errors.
    Last edited by Knurpht; 22-Jan-2014 at 03:11.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: How to disable/modify the terminal-box of grub2

    Quote Originally Posted by Knurpht View Post
    Arvid, I tried that (I don't care about the box, but wanted to know), even after removal of all the "echo" statements, an empty black box is shown
    Yes, I tried that as well. Does not work.

    Quote Originally Posted by Knurpht View Post
    EDIT: to the OP: Mind, this box is the place where errors/warnings are shown. If you would be able to remove the box, you wouldn't see these warnings / errors.
    Of course. If the box were "transparent" so that the background below is visible (but grub still can echo its information), it would be ok for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •