Results 1 to 10 of 10

Thread: OpenSuse will not advance beyond GRUB screen

  1. #1

    Default OpenSuse will not advance beyond GRUB screen

    Hi,

    I have Opensuse installed on dual boot with windows 7. Today I wanted to log into Opensuse but it did not work. The grub selection shows up but when I select opensuse it just produces a blank screen and does not advance from there.

    Thanks for reading

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,286

    Default Re: OpenSuse will not advance beyond GRUB screen

    Did you update recently? are you using a propritary driver? If so how was it installed? Cane you boot to rescue mode (hint look in advanced in grub)

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: OpenSuse will not advance beyond GRUB screen

    Quote Originally Posted by farazk86 View Post
    Hi,

    I have Opensuse installed on dual boot with windows 7. Today I wanted to log into Opensuse but it did not work. The grub selection shows up but when I select opensuse it just produces a blank screen and does not advance from there.

    Thanks for reading
    ... as well as gogalthorp's questions:

    Have you had openSUSE running successfully until now?

    -fb
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  4. #4

    Default Re: OpenSuse will not advance beyond GRUB screen

    Hi,

    Yes I had installed opensuse a couple months ago. I logged into it, used it for a day and then after that have used Windows. Yesterday when I tried logging in it gave this problem.

    When I login using advanced options the same problem occurs. It shows up a bunch of lines and then stops.

    It doesnt freeze though as I can type at the command prompt after advanced startup fails

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse will not advance beyond GRUB screen

    On 2014-01-22 14:36, farazk86 wrote:

    > It doesnt freeze though as I can type at the command prompt after
    > advanced startup fails


    Maybe you got to the text mode login, where you can enter your name and
    password. Please verify.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #6

    Default Re: OpenSuse will not advance beyond GRUB screen

    No, it just stays at command prompt doing nothing.

    This is what I get when I select recovery mode. It just stays there and does not advance. If I select to startup via notmal mode, I get a blank flickering screen.


  7. #7

    Default Re: OpenSuse will not advance beyond GRUB screen

    Quote Originally Posted by farazk86 View Post
    No, it just stays at command prompt doing nothing.
    Press Ctrl+Alt+F1 and you should get to a text mode login prompt.
    Does this work?

    If it gets as far as on your picture, there's definitely no problem with grub...
    Most likely the graphics driver. Which graphics card do you have?

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse will not advance beyond GRUB screen

    On 2014-01-23 12:46, farazk86 wrote:

    > [image: http://i.imgur.com/sw3n721.jpg]


    Grub did certainly succeed booting the system. Your system is running,
    with graphics failing, it seems.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  9. #9

    Default Re: OpenSuse will not advance beyond GRUB screen

    Right. I tried alt + ctrl + f1 and it did bring up a login prompt. I logged in I was presented with a prompt where I can enter commands.

    My graphics card is ati radeon HD 6570. It worked perfectly before. Why did the driver just decide to get up and leave while I was not using my computer?

    Thanks

  10. #10

    Default Re: OpenSuse will not advance beyond GRUB screen

    Quote Originally Posted by farazk86 View Post
    Right. I tried alt + ctrl + f1 and it did bring up a login prompt. I logged in I was presented with a prompt where I can enter commands.

    My graphics card is ati radeon HD 6570. It worked perfectly before. Why did the driver just decide to get up and leave while I was not using my computer?

    Thanks
    Hi farazk,

    I also use a Radeon graphics card on my openSUSE Machine. The standard radeon drivers shipped with openSUSE should work fine at any time. However, if you use AMDs proprietary driver, it will fail to load after kernel updates. Just reinstall your driver out of your prompt. Maybe you still have the downloaded install files somewhere? If you don't know, how to install the proprietary driver using the promt, visit: http://en.opensuse.org/SDB:AMD_fglrx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •