Results 1 to 6 of 6

Thread: KNetworkManager does not store my WPA password

  1. #1

    Default KNetworkManager does not store my WPA password

    Hi,

    I have recently upgraded my PC to Opensuse 13.1 (from 12.3)... I also had to move to a different room, so I have to use wifi rather than an internet cable.

    I use Knetwork manager to connect to my wifi network. Things are working except that I have to provide my WPA password everytime I boot my computer.

    Any idea what I should do to setup an automatic connection?

    Thanks

  2. #2

    Default Re: KNetworkManager does not store my WPA password

    Quote Originally Posted by pomchip View Post
    I use Knetwork manager to connect to my wifi network. Things are working except that I have to provide my WPA password everytime I boot my computer.

    Any idea what I should do to setup an automatic connection?
    The password should be saved by default.
    But if something goes wrong with connecting, it will ask you anyway.

    What are your password save settings in "Manage Connections"->"Other"?

    Try to make the wireless connection a "system connection" (select the connection in "Manage Connections"->Wireless and click on "Edit", then enable "System connection"). Does it work then?

  3. #3

    Default Re: KNetworkManager does not store my WPA password

    Thanks a bunch!

    Selecting "System connection" solved this issue.

  4. #4

    Default Re: KNetworkManager does not store my WPA password

    Hopefully this solved my problem also. I was pulling my hair out trying to get rid of the unspeakably annoying kwallet prompts constantly popping up.

  5. #5

    Default Re: KNetworkManager does not store my WPA password

    I also know an other story: by setting the password on a fresh install it becomes persistent, doing it later, after the first updates, doesn't work any more.
    Laptop: MSI 60 2PC | OpenSUSE 13.1 (x86_64) | KDE Current| Compiz 8.8 | Intel(R) Core(TM) i7-4700HQ CPU 3.2GHz | GTX850M | 8GB RAM

  6. #6

    Default Re: KNetworkManager does not store my WPA password

    Upon changing from opensuse 13.1 to 13.2 my networkmanager also forgot all passwords and kept asking for them always.

    I did not have to set this to a system connection. Entering the passwords in the "Wireless Security" Tab under Connection Manager -> Edit was all it took to get it running again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •