Results 1 to 3 of 3

Thread: openSUSE 13.1 keyboard wakeup from sleep

  1. #1
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    96

    Default openSUSE 13.1 keyboard wakeup from sleep

    I recently built a newer system to replace an older Pentium 4 based one. On the old system (openSUSE 12.3/XFCE) I was able to wakeup via keyboard press (the keyboard was/is a Logitech K800 USB wireless). The newer system (openSUSE 13.1/KDE) is built on Asus H81M-PLUS motherboard with UEFI. I have verified the two applicable jumper settings and believe the UEFI settings to be correct (this is my first experience with UEFI). I've read quite a few threads related to this issue but have not found the answer yet. I have also noticed that on regular start from cold boot there seems to be a delay at login screen before keyboard output is accepted. This seems to affect the first character typed which generates no output, then the output to password dialog is as expected. Not sure if that delay is helpful in diagnosing the wakeup issue or not. Other than these issues I have been very pleased with 13.1, and especially KDE performance since I had moved away from it several years ago due to the older hardware I was running.

    System "lspci" and "cat /proc/acpi/wakeup":

    office:/home/fuscop # lspci
    00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
    00:02.0 VGA compatible controller: Intel Corporation Device 041e (rev 06)
    00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)
    00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)
    00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)
    00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d5)
    00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d5)
    00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)
    00:1f.0 ISA bridge: Intel Corporation C220 Series Chipset Family H81 Express LPC Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 05)
    00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
    04:00.0 USB controller: ASMedia Technology Inc. Device 1142

    office:/home/fuscop # cat /proc/acpi/wakeup
    Device S-state Status Sysfs node
    RP01 S4 *disabled pci:0000:00:1c.0
    PXSX S4 *disabled
    RP03 S4 *disabled pci:0000:00:1c.2
    PXSX S4 *enabled pci:0000:03:00.0
    RP05 S4 *disabled pci:0000:00:1c.4
    PXSX S4 *enabled pci:0000:04:00.0
    GLAN S4 *disabled
    EHC1 S4 *enabled pci:0000:00:1d.0
    EHC2 S4 *enabled pci:0000:00:1a.0
    XHC S4 *enabled pci:0000:00:14.0
    HDEF S4 *disabled pci:0000:00:1b.0
    PEG0 S4 *disabled pci:0000:00:01.0
    PEGP S4 *disabled
    PEG1 S4 *disabled
    PEG2 S4 *disabled

  2. #2
    Join Date
    Mar 2013
    Location
    Bari (Italy)
    Posts
    58

    Default Re: openSUSE 13.1 keyboard wakeup from sleep

    Same issue on my config, solved with this trick:
    https://forums.opensuse.org/showthre...10#post2223810
    Give it a try!

  3. #3
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    96

    Default Re: openSUSE 13.1 keyboard wakeup from sleep

    Quote Originally Posted by ezio84 View Post
    Same issue on my config, solved with this trick:
    https://forums.opensuse.org/showthre...10#post2223810
    Give it a try!
    Thanks. I read through and looked at it from the command line but decided it was a little beyond my Linux skills. I'll live with having to use the power button to bring it out of sleep. I do find it strange that I never had this issue with XFCE. Also have noticed that besides one character keyboard delay at login screen the wireless seems slightly delayed. I suppose KDE isn't going to get to ready state as quickly as XFCE did. Guess it could also be 13.1 as well. Mostly just minor irritations though. And thankfully the system quit asking for my login every time I tried to put it to sleep, which cropped up after some update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •