Results 1 to 8 of 8

Thread: VLC error - NOT playing multimedia files now

  1. #1

    Default VLC error - NOT playing multimedia files now

    Well, I've reinstalled my 13.1 KDE 32-bit setup on my box and cannot get VLC to play my multimedia files anymore. These have played before but I don't know what I've done wrong on this install.

    The error messages are as follows:

    Code:
     No suitable decoder module:
     VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.
     No suitable decoder module:
     VLC does not support the audio or video format "mp4a". Unfortunately there is no way for you to fix this.
    and I don't want to be bumping around trying to fix this by myself. Would anyone have a suggestion about this? Thanks!

  2. #2

    Default Re: VLC error - NOT playing multimedia files now

    Quote Originally Posted by chuckenheimer View Post
    Well, I've reinstalled my 13.1 KDE 32-bit setup on my box and cannot get VLC to play my multimedia files anymore. These have played before but I don't know what I've done wrong on this install.

    The error messages are as follows:

    Code:
     No suitable decoder module:
     VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.
     No suitable decoder module:
     VLC does not support the audio or video format "mp4a". Unfortunately there is no way for you to fix this.
    and I don't want to be bumping around trying to fix this by myself. Would anyone have a suggestion about this? Thanks!
    Add the Packman repository, if you haven't done so yet, by running YaST->Software Repositories->Add->Community Repositories.
    Then install "vlc-codecs" via YaST->Software Management.

    Afterwards, it should work...

  3. #3

    Default Re: VLC error - NOT playing multimedia files now

    Quote Originally Posted by wolfi323 View Post
    Add the Packman repository, if you haven't done so yet, by running YaST->Software Repositories->Add->Community Repositories.
    Then install "vlc-codecs" via YaST->Software Management.

    Afterwards, it should work...
    That did it. Thanks again and I'm back in business to this extent.

  4. #4

    Default Re: VLC error - NOT playing multimedia files now

    Quote Originally Posted by wolfi323 View Post
    Add the Packman repository, if you haven't done so yet, by running YaST->Software Repositories->Add->Community Repositories.
    Then install "vlc-codecs" via YaST->Software Management.

    Afterwards, it should work...
    Unfortunately this didn't work for me, still getting the same error message as chuckenheimer, tried suggestion by caf4926
    https://forums.opensuse.org/entry.ph...allation-Guide followed instructions for gnome, installed and switched to packman and then installed vlc-codecs but still no luck. Mplayer works for music but can't get DVD's to play at all, The default program for DVD's in Gnome seems to be the player called videos but that doesn't work either. I've openSUSE 13.1 (Bottle) (x86_64) 64-bit running on AMD Athlon(tm) 64 X2 Dual Core Processor 4000+ × 2, Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits), with Gnome version 3.10.2. I don't have a great deal of knowledge when it comes to SuSe and would really appreciate some expert help, thanks.

  5. #5

    Default Re: VLC error - NOT playing multimedia files now

    Quote Originally Posted by Sosaidh View Post
    Unfortunately this didn't work for me, still getting the same error message as chuckenheimer, tried suggestion by caf4926
    https://forums.opensuse.org/entry.ph...allation-Guide followed instructions for gnome, installed and switched to packman and then installed vlc-codecs but still no luck.

    Please post a list of all vlc packages you have installed:
    Code:
    rpm -qa | grep vlc
    And please post a list of your repos:
    Code:
    zypper lr -d
    Mplayer works for music but can't get DVD's to play at all,
    For DVDs you most likely need libdvdcss2. This is available in its own repo, you can find that in YaST->Software Repositories->Add->Community Reposiories. Add the libdvdcss repo and install "libdvdcss2".

    The default program for DVD's in Gnome seems to be the player called videos but that doesn't work either.
    Totem ("videos") uses gstreamer, so most likely you miss the codecs for that.

    Check that all your gstreamer-plugins packages come from Packman, and install gstreamer-plugins-ugly-orig-addon and gstreamer-gstreamer-plugins-libav if you don't have them already. (use YaST->Software Management)

    I've openSUSE 13.1 (Bottle) (x86_64) 64-bit running on AMD Athlon(tm) 64 X2 Dual Core Processor 4000+ × 2, Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits), with Gnome version 3.10.2.
    Which graphics card do you have?
    llvmpipe means that you're using the software renderer, i.e. you might not use the right graphics driver.
    This can of course cause problems with playing back videos as well.

    Maybe upload the file /var/log/Xorg.0.log to http://susepaste.org and post a link.

  6. #6

    Default Re: VLC error - NOT playing multimedia files now

    thanks for reply & help, apologies but didn't do a restart after installing vlc-codecs before posting but now realize it did improve things, although out of sync can now play DVD's with 'videos' player and vlc now starting and no error message but still not playing. Think that might be something to do with settings within the player though, so will have a look at that. The guide for multimedia installation from caf4926 includes libdvdcss repo & installation of libdvdcss2 & gstreamer-ugly-plugins, think i have everything needed but here's installed vlc
    Code:
    sosaidh@linux-9md0:~> rpm -qa | grep vlc
    vlc-gnome-2.1.2-193.2.x86_64
    vlc-2.1.2-193.2.x86_64
    vlc-qt-2.1.2-193.2.x86_64
    vlc-noX-2.1.2-193.2.x86_64
    vlc-noX-lang-2.1.2-193.2.noarch
    vlc-codecs-2.1.2-193.2.x86_64
    libvlc5-2.1.2-193.2.x86_64
    libvlccore7-2.1.2-193.2.x86_64
    and repositories

    Code:
    1 | download.opensuse.org-Stable | openSUSE BuildService - LibreOffice | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_13.1/ |        
     2 | download.opensuse.org-oss    | Main Repository (Sources)           | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.1/repo/oss/              |        
     3 | libdvdcss                    | libdvdcss                           | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                         |        
     4 | openSUSE-13.1-1.10           | openSUSE-13.1-1.10                  | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-PHILIPS_DVD+_-RW_DVD8881,/dev/sr0         |        
     5 | packman                      | packman                             | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/                                  |        
     6 | repo-debug                   | openSUSE-13.1-Debug                 | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/               |        
     7 | repo-debug-update            | openSUSE-13.1-Update-Debug          | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                              |        
     8 | repo-debug-update-non-oss    | openSUSE-13.1-Update-Debug-Non-Oss  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                      |        
     9 | repo-non-oss                 | openSUSE-13.1-Non-Oss               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                 |        
    10 | repo-oss                     | openSUSE-13.1-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                     |        
    11 | repo-source                  | openSUSE-13.1-Source                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/              |        
    12 | repo-update                  | openSUSE-13.1-Update                | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                    |        
    13 | repo-update-non-oss          | openSUSE-13.1-Update-Non-Oss        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/
    my graphics card is Nvidia GeForce 6150 LE, have problems with display unless i boot in recovery mode so wondering if that is because i have wrong driver too?
    thanks again

  7. #7

    Default Re: VLC error - NOT playing multimedia files now

    Quote Originally Posted by Sosaidh View Post
    thanks for reply & help, apologies but didn't do a restart after installing vlc-codecs before posting but now realize it did improve things, although out of sync can now play DVD's with 'videos' player and vlc now starting and no error message but still not playing. Think that might be something to do with settings within the player though, so will have a look at that.
    The vlc packages and your repo list look ok.
    You could try to delete vlc's configuration. Remove the directory ~/.config/vlc/. It would start with the default config then.

    my graphics card is Nvidia GeForce 6150 LE, have problems with display unless i boot in recovery mode so wondering if that is because i have wrong driver too?
    I guess you haven't installed any driver?
    You are using the open source nouveau driver then, which doesn't work too well depending of the card.

    If you can only use recovery mode, I would definitely recommend to install the proprietary nvidia driver.
    Add the nvidia repo in YaST->Software Repositories->Add->Community Repositories, then install those packages in YaST->Software Management:
    nvidia-gfxG02-kmp-desktop, x11-video-nvidiaG02, nvidia-computeG02.

    The try a normal boot.
    Chances are that your videos play better then...

  8. #8

    Default Re: VLC error - NOT playing multimedia files now

    I guess you haven't installed any driver?
    You are using the open source nouveau driver then, which doesn't work too well depending of the card.

    If you can only use recovery mode, I would definitely recommend to install the proprietary nvidia driver.
    Add the nvidia repo in YaST->Software Repositories->Add->Community Repositories, then install those packages in YaST->Software Management:
    nvidia-gfxG02-kmp-desktop, x11-video-nvidiaG02, nvidia-computeG02.

    The try a normal boot.
    Chances are that your videos play better then...
    found nouveau worked better than nvidia in 12.2 but had been thinking i should try install it, your advice worked perfectly, many thanks, delighted to say everything looking good & seems to be solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •