Results 1 to 2 of 2

Thread: Problems with deduplication on windows 2012 server and samba

  1. #1
    Join Date
    Aug 2008
    Location
    Reykjavik, Iceland
    Posts
    75

    Default Problems with deduplication on windows 2012 server and samba

    I'm experiencing a problem with shared drives from a windows 2012 server using deduplication. The shared drives are mount to a Linux machine as:

    Code:
    //koffort/smidja$  /mnt/smidja  cifs iocharset=utf8,credentials=/home/andri/.smbpasswd,rw,user,dir_mode=0775,file_mode=0775,gid=1001 0 0
    The Linux machine is:
    Code:
    > uname -a
    Linux byfluga 3.12.0-rc5-4.gac42dba-desktop #1 SMP PREEMPT Wed Oct 16 10:17:14 UTC 2013 (ac42dba) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    > cat /etc/SuSE-*
    openSUSE
    VERSION = 12.3
    openSUSE 12.3 (x86_64)
    VERSION = 12.3
    CODENAME = Dartmouth
    The problem is that some of the files are shown as links to nothing in Linux. If I check there Attributes it is set to APL so my guess it has something to do with the deduplication.

    The same setup works perfectly on a Debian (Stable) machine. The only difference I can see is that there I can use the "directio" option with mount.

  2. #2
    Join Date
    Aug 2008
    Location
    Reykjavik, Iceland
    Posts
    75

    Default Re: Problems with deduplication on windows 2012 server and samba

    Ok, it's solved for now - it needed a kernel update

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •