I am not sure if this is the right place for this thread, I apologise if I've got it wrong. I am a very fresh Opensuse convert (just installed it today) and trying to protect myself from a hacker inside my building complex, please be kind

So, I have just moved from a very buggy Vista Home Basic system after having myriad issues with internet speeds and especially after most of my social media accounts had their passwords changed. (I know, I know, they are not related but please bear with me). After my passwords were changed it sent me on a wild hunt to secure my system and network. Initially I wanted to have a dual-boot system (Vista and openSUSE) so I could ease into the transition but it was next to impossible to stabilize the system, anything I would download to install would be damaged or corrupted. Even the ISO files for the distro were damaged and I had to ask a friend to make the LiveUSB.

So as of now the system is running openSUSE 13.1. As soon as I installed it and after I updated the packages through Install/Remove software, I wanted to secure my machine. I also ran Yast a few other times when I was going through different articles, so I know that it was working. But, all of a sudden now it is inaccessible.

I am using Gnome desktop. When I search for it, I can see it, but clicking on it brings me back to the browser window. Trying to access it from the terminal, and I paste the output here:

zen@linux-3g7l:~> yast
Absolute path to 'yast' is '/sbin/yast', so running it may require superuser privileges (eg. root).
zen@linux-3g7l:~> sudo yast
sudo: effective uid is not 0, is sudo installed setuid root?

I searched around for why I would be locked out of sudo (if that's the right way to put it), and I found that you might need the output of the following command to help:

zen@linux-3g7l:~> mount | grep '/'
devtmpfs on /dev type devtmpfs (rw,relatime,size=1537720k,nr_inodes=210371,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/mapper/system-root on / type btrfs (rw,relatime,space_cache)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=29,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/mapper/system-home on /home type btrfs (rw,relatime,space_cache)
/dev/sda1 on /usr/local type ext4 (rw,relatime,data=ordered)
/dev/sda2 on /boot type ext4 (rw,relatime,data=ordered)
vmware-vmblock on /var/run/vmblock-fuse type fuse.vmware-vmblock (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other)
vmware-vmblock on /run/vmblock-fuse type fuse.vmware-vmblock (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)
gvfsd-fuse on /var/run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)

I installed nmap and Zenmap so I could monitor the network and look for open ports. The first time I ran nmap, the default telnet port was open, but subsequently it closed (didn't show up on Zenmap on consequent runs, even though I have not done anything to close it).

I was looking into installing DenyHost to secure the ssh port, and then I was planning to work my way to closing all the extra open ports I could see on Zenmap (which I didn't need, atleast as far as my basic knowledge tells me), when I encountered this problem with Yast.

My main question to you at this point is, is there anything I can do to secure my system before that hacker gets into it? He seems to be way more knowledgeable and even though I can work my way around, I am not a professional. I tried talking to my friend about it but he thinks I am being paranoid. Nobody believes me.

Please help, this is slowly driving me to despair.