Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 36

Thread: Unable to access Yast

  1. #11

    Default Re: Unable to access Yast

    Quote Originally Posted by gogalthorp View Post
    Get any error with init 5??

    What video card and what driver?

    Did you try yast command line logged in or changed (su -) to root?
    No, the system freezes totally. It does not do anything at all. And also there is no error.
    My videocard details:
    NVIDIA GeForce 9200
    Driver: NVIDIA GeForce9200M Graphics Driver http://h10025.www1.hp.com/ewfrf/wc/s...07972&sw_lang=

  2. #12
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,784

    Default Re: Unable to access Yast

    That is a Windows driver you need a Linux driver. I think you need the GO3 flavor but to be honest I have gotten lost in the NVIDIA naming conventions

  3. #13

    Default Re: Unable to access Yast

    Quote Originally Posted by gogalthorp View Post
    That is a Windows driver you need a Linux driver. I think you need the GO3 flavor but to be honest I have gotten lost in the NVIDIA naming conventions
    Not a problem at all. The display seems to be working fine so far, so it is alright. My main concern right now is that I cannot get into sudo, and consequently YaST, because of busted file permissions.

    At this point I strongly doubt that I'll be able to fix this with my skillset, even if you kind folk are more than willing to help me out =)

  4. #14

    Default Re: Unable to access Yast

    Quote Originally Posted by RoadRunner2014 View Post
    This is what I have tried so far. Please bear with me:

    1. Pressed Ctrl+Alt+F1 to get to the command line
    2. Tried several times to enter with username: root, and the password, but no success.
    3. Hard rebooted the system, tried again, and this time I was able to login.
    4. Ran chkstat --system. No output. The command just went to the next prompt.
    5. Tried to exit the text console by typing init5 but system crashed. Had to hard reboot again.

    Still cannot get into sudo, Yast. Telnet port on router (not localhost) has opened up again, along with another unknown port with a red signal behind it.
    Let's forget the router for a moment.
    One problem at a time.

    So, you cannot login as "root"?
    Then your only chance is to either boot a LiveCD and change to the system via "chroot".
    Or try this:
    At the boot prompt, type 'e', search for the line starting with "linux", and append "init=/bin/sh".
    Press F10 to boot.

    You should then get to a minimal text system without having to enter any password. Run the command I gave you before to get sudo going at least.

    PS: you should be able to use the G03 driver...

  5. #15
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to access Yast

    On 2014-01-20 21:16, RoadRunner2014 wrote:

    > 4. Ran chkstat --system. No output. The command just went to the next
    > prompt.


    Try:

    Code:
    chkstat --system --set
    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  6. #16
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to access Yast

    On 2014-01-20 17:06, RoadRunner2014 wrote:

    > That is a fluke! I wanted to overwrite all of the HDD space but the installer's default partition settings wanted to keep the Windows partition.
    > So I checked the option to format it, but then was not sure about where to mount it. So I chose a mount point just so I could retrieve all that
    > HDD space later. About the encryption, that too was an option in the installer, I just checked it



    During the install, you can just tell the installer to use the entire
    disk if you so wish.

    Besides that, you can choose any mount point in the list or just write
    up a new one entirely of your choice, because those in the list have
    specific uses.



    >> You should not even have the telnet daemon installed. The telnet client,
    >> yes, maybe, but the daemon (server) certainly not.
    >>
    >> sshd yes - if you have more computers, or if your friend does remote
    >> maintenance on your machine.



    > That is exactly what has been bothering me all this while. I have not intentionally installed telnet as a server,
    > which is what makes me suspicious. As I said I have a feeling the hacker neighbor has installed a script which
    > maybe gets copied to my LiveUSB somehow (this is where I am lost). Nobody is actually accessing my machine remotely
    > (not to my knowledge or my consent), which is what makes the appearance of telnet even more worrisome, and which
    > I went a little overboard with the sshd_config file. Logically I have absolutely no use for any remote services
    > (as I am not receiving any help through those channels).


    I forgot that you were using nmap running from the same machine, and as
    wolfi323 said, it has to be run from another computer. Running it
    locally it tests the "lo" network interface, which is not protected from
    external access as it has no plug to connect a cable to. It is a virtual
    device only, so it is not dangerous to have ports open in there. Just
    ignore whatever you found on that run.




    > >
    > > A scan of the router shows port 23 open with telnet running on it as of now. How can I fix this?


    But that is probably from the inside of your network, so not dangerous.
    To close it, you have to enter your router configuration, either by
    telnet or by its web page.

    What is dangerous is whatever your router has open to the outside (some
    have some by default). If your router is suspect, then what I would do
    is take notes of its configs, and do a full hardware reset to factory
    defaults - while disconnected from internet. Each router has its own
    method for doing this. Then you have to reconfigure it from scratch,
    making sure it does not have any configuration ports allowed from
    outside (not even by your ISP). And of course, change the default
    password to a strong one. If it has wifi, disable it.

    Only after all this is done I would reconnect it to the outside network.

    Notice that while you do all this, if you do, you have no internet and
    no help. If you fail to finish it, you might have to call in someone or
    buy another router... so be careful.

    There are web pages and forums dedicated to help with home routers. Here
    we can not help you much on that.


    >> Just make sure that the firewall is up and secured, that closes
    >> everything you don't explicitly open.

    >
    > So as wolfi323 advised, setting up the Firewall should technically be good.


    It is by default done from install.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  7. #17

    Default Re: Unable to access Yast

    Quote Originally Posted by wolfi323 View Post
    Let's forget the router for a moment.
    One problem at a time.
    Agreed.

    I took a break after yesterday and started fresh today, and here are my results:

    Quote Originally Posted by wolfi323 View Post
    Then your only chance is to either boot a LiveCD and change to the system via "chroot".
    LiveUSB route
    1. I needed the partition information, but the Terminal would not allow fdisk, saying it needed root permissions. I found out the partitions via System Monitor>File Systems (not sure if this was the right way). This is what was displayed:
      /dev/dm-2 / btrfs 42.9GB
      /dev/sda2 /boot ext4 397.8 MB
      /dev/mapp/ /home btrfs 53.7 GB
      /dev/sda1/ /usr/local ext4 99.4 GB
    2. Then logged in via LiveUSB.
    3. I created a mount point, then tried to mount /dev/dm-2 (which I believe is the partition with the filesystems), but the error was "special device /dev/dm-2 does not exist".

      I read up further on this and realise this is due to the encryption I set during install, and to fix this would require be a time-intensive process.


    Quote Originally Posted by wolfi323 View Post
    Or try this:
    At the boot prompt, type 'e', search for the line starting with "linux", and append "init=/bin/sh".
    Press F10 to boot.

    You should then get to a minimal text system without having to enter any password. Run the command I gave you before to get sudo going at least.
    Editing the Boot Loader
    1. I got into the Edit mode by pressing 'esc' and then 'e', and followed the steps as outlined.
    2. Then I pressed F10 to boot, but the system spewed out code and then got stuck. I forcibly shutdown the machine and then started again.


    Quote Originally Posted by wolfi323 View Post
    So, you cannot login as "root"?
    Logging in as root
    Attempt 1

    1. I tried this again after facing issues with the other two methods.
    2. I pressed Ctrl+Alt+F1, then successfully logged in to root.
    3. Typed chkstat --system. Output follows:
      Code:
       # Checking permissions and ownerships - using the permission files
          /etc/permissions
          /etc/permissions.paranoid
          /etc/permissions.d/mail-server
          /etc/permissions.d/mail-server.paranoid
          /etc/permissions.d/postfix
          /etc/permissions.d/postfix.paranoid
          /etc/permissions.local
      setting /home to root:root 0755 (wrong owner/group root:users)
      setting /boot to root:root 0755 (wrong owner/group root:users)
      setting /var/run/utmp to root:utmp 0664 (wrong owner/group root:users permission 0664)
    4. But I typed init 5 again and the system crashed. So restarted again.


    Attempt 2
    1. Chkstat did not work.
    2. I typed chmod +s /usr/bin/sudo
    3. Then pressed Ctrl+Alt+F7 and got to the GUI.
    4. Opened a Terminal window, and output follows
      Code:
      zen@linux-3g7l:~> sudo chkstat --system
      root's password:
      Checking permissions and ownerships - using the permissions files
          /etc/permissions
          /etc/permissions.paranoid
          /etc/permissions.d/mail-server
          /etc/permissions.d/mail-server.paranoid
          /etc/permissions.d/postfix
          /etc/permissions.d/postfix.paranoid
          /etc/permissions.local
      setting /usr/bin/sudo to root:root 0755. (wrong permissions 6755)
      I think I went overboard with the "paranoid" restriction!

    Quote Originally Posted by wolfi323 View Post
    PS: you should be able to use the G03 driver...
    I ran an update for packages via Yast as soon as I finished installing the system, so I believe I am using the GO3 drivers (unless I need look for them manually).
    The link to the Windows drivers yesterday was my overanxious brain, my bad.

    For now it looks like encrypting the whole disk was not such a great idea. It is especially painful while booting multiple times during trouble-shooting for example. I think I may have to do a fresh install at some point (without the encryption this time).

  8. #18

    Default Re: Unable to access Yast

    Quote Originally Posted by RoadRunner2014 View Post
    Typed chkstat --system. Output follows:
    Code:
     # Checking permissions and ownerships - using the permission files    /etc/permissions
        /etc/permissions.paranoid
        /etc/permissions.d/mail-server
        /etc/permissions.d/mail-server.paranoid
        /etc/permissions.d/postfix
        /etc/permissions.d/postfix.paranoid
        /etc/permissions.local
    setting /home to root:root 0755 (wrong owner/group root:users)
    settin /boot to root:root 0755 (wrong owner/group root:users)
    setting /var/run/utmp to root:utmp 0664 (wrong owner/group root:users permission 0664)
    Sorry the command I typed here was chkstat --system --set

  9. #19
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,672
    Blog Entries
    2

    Default Re: Unable to access Yast

    Quote Originally Posted by RoadRunner2014 View Post
    Agreed.

    For now it looks like encrypting the whole disk was not such a great idea. It is especially painful while booting multiple times during trouble-shooting for example. I think I may have to do a fresh install at some point (without the encryption this time).
    Just a comment on encrypting drives.
    Remember, you're only securing data <at rest>.
    When your system is up and running and can/needs to gain access to data on the disk, the data is completely accessible.

    So, you should consider your reasons for encrypting.
    If the data on the disk is generic and contains no sensitive information, there is no need to encrypt.
    If the drive is physically secured/securable, then there is no need to encrypt (eg in a locked room when no one is present).

    Encrypting drives is useful if in a portable device (eg laptop) or securing highly sensitive data someone would try to physically break in and steal the physical disks.

    IMO,
    TSU

  10. #20

    Default Re: Unable to access Yast

    Quote Originally Posted by RoadRunner2014 View Post
    1. I think I went overboard with the "paranoid" restriction!
    Yes. With "paranoid" settings a user is not able to gain root privileges.

    Try switching this back to "secure" or "easy" in /etc/sysconfig/permissions.
    Use "sudo vim /etc/sysconfig/permissions" to edit the file and change the "PERMISSION_SECURITY" value to "secure local" or "easy local" (the default, best suited for desktop use).
    Then run "chkstat" again and YaST should work as user again.

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •