Results 1 to 7 of 7

Thread: Disable ethernet port permanently opensuse 13.1

  1. #1

    Default Disable ethernet port permanently opensuse 13.1

    I have an usused ethernet port that causes chatter in one of the log files. I know the command
    ifconfig "port" down
    will turn off the port. Where is the proper place (director/file) to add this command so it will be done upon booting?

    Note there is no place in the bios to turn off this port.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Disable ethernet port permanently opensuse 13.1

    If you blacklist the kernel module that drives it? Is that an option?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Disable ethernet port permanently opensuse 13.1

    I don't know how to blacklist anything, but it seems to me I need the module for the other ethernet port to work.
    Code:
     2014-01-20T00:50:31.089662-08:00 linux-wh01 dhcpcd[6352]: enp2s0: timed out
     2014-01-20T00:50:31.091918-08:00 linux-wh01 dhcpcd[6352]: enp2s0: trying to use old lease in `/var/lib/dhcpcd/dhcpcd-enp2s0.info'
     2014-01-20T00:50:31.109895-08:00 linux-wh01 dhcpcd[6352]: enp2s0: broadcasting for a lease
    The system log will fill up with "broadcasting for a lease" messages unless I do the "ifconfig enp2s0 down". If I knew where to put the command so it would be executed upon start up, that would just leave the error message only on boot up.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: Disable ethernet port permanently opensuse 13.1

    You could use YaST to disable the interface. Instead of activating at boot time, you could select 'Manually' or 'Never'.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Disable ethernet port permanently opensuse 13.1

    You don't want to block that port (DHCP client).
    If you do, your DHCP lease will expire.
    Then another machine booting on your network can be assigned your IP address and your machine will be SOL.

    Read up on how DHCP works, particularly DHCP lease TTL and why renewal is necessary.

    Do as Deano suggests,
    Disable (or remove) the interface. If you're running NM, you can go into the network connection properties in NM and remove. If you're running "classic ifup/ifdown) then you can disable in YAST as Deano describes.

    HTH,
    TSU

  6. #6

    Default Re: Disable ethernet port permanently opensuse 13.1

    I found the "never" selection. Perfect. Thanks.

    I have nothing plugged into that port. The mobo has two ethernet ports and I only use one. However, I don't recall similar mobos with multiple ethernet ports filling up the system log with chatter.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: Disable ethernet port permanently opensuse 13.1

    Quote Originally Posted by gariac View Post
    I found the "never" selection. Perfect. Thanks.

    I have nothing plugged into that port. The mobo has two ethernet ports and I only use one. However, I don't recall similar mobos with multiple ethernet ports filling up the system log with chatter.
    I have the same messages regarding my ethernet interface.. To be honest, I usually don't concern myself with informational messages like that, as I know the cause. I predominantly use my wireless LAN , but my ethernet does get used at work for connecting to various network appliances, and the ethernet interface is set to 'At Boot Time', although I could just as easily set it to 'On Cable Connection' or 'On Hotplug'. (Once NM starts up, the both interfaces are managed by that anyway.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •