Results 1 to 6 of 6

Thread: Audio not working on Asus X750J

  1. #1

    Default Audio not working on Asus X750J

    I get my audio to work consistently. It doesn't work on YouTube, and VMWare Player can't pick up the device.

    Log: http://www.alsa-project.org/db/?f=95...ac1da535c35af5

    Specifics:
    1) I can rearrange the devices from the audio (Kmixer) icon and select which work, but the default and all the HDMI ones don't work.
    > HDA Intel PCH (ALC269VC Analog)
    > HDA Intel PCH, ALC269VC Analog (DefaultAudio Device)
    X HDA Intel MID, HDMI 0 (HDMI Audio Output)
    X HDA Intel MID, HDMI 1 (HDMI Audio Output)
    X HDA Intel MID, HDMI 2 (HDMI Audio Output)
    X Default
    2) After rearranging the devices, I can get Amarok to work.
    3) Still, the initial "welcome" tune upon sign-in isn't produced.
    4) Youtube fails.
    5) VMWare Player cannot connect to the device.
    6) I tried to disconnect & connect drivers through YaST. It works /sometimes/. I see two Intel devices with 'snd-hda-intel' drivers.
    7) If I delete and configure the drivers in the right way, I will get an Intel error message. Once I get that, that channel works but not the other one. The configuration that has worked to cause the error is setting power save to any number of seconds. If I get a device-insert error, I have to start all over. Also, this funny configuration sometimes gets reset between reboots.
    8) I have been able to get sound from all three (above) apps, but it now doesn't work at all, so I know it's possible to get it to work.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Audio not working on Asus X750J

    Quote Originally Posted by metalgimp View Post
    I get my audio to work consistently. It doesn't work on YouTube, and VMWare Player can't pick up the device.
    Do you have 'flash-player' installed so to play YouTube videos ?

    Do you have 'pavucontrol' installed so as to tune pulse audio with VMWare Player ?

    Quote Originally Posted by metalgimp View Post
    3) Still, the initial "welcome" tune upon sign-in isn't produced.
    If using KDE, that is disabled by default. One needs to go into the KDE settings to change that.

    Quote Originally Posted by metalgimp View Post
    6) I tried to disconnect & connect drivers through YaST. It works /sometimes/. I see two Intel devices with 'snd-hda-intel' drivers.
    This does not read to be a driver problem, but rather it appears you may be missing some applications and your pulse audio may not be tuned and your desktop may not be tuned. If you mess too much with your audio drivers you could break the sound completely if you do not understand what you are doing.

    Thank you and best wishes.

  3. #3

    Default Re: Audio not working on Asus X750J

    Quote Originally Posted by oldcpu View Post
    Do you have 'flash-player' installed so to play YouTube videos ?

    Do you have 'pavucontrol' installed so as to tune pulse audio with VMWare Player ?

    This does not read to be a driver problem, but rather it appears you may be missing some applications and your pulse audio may not be tuned and your desktop may not be tuned. If you mess too much with your audio drivers you could break the sound completely if you do not understand what you are doing.

    Thank you and best wishes.
    Flash - installed.
    Pavucontrol - no idea.
    Broken sound - I think I ready did that. I believe the only recourse is to reinstall SuSE. Wish me luck.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Audio not working on Asus X750J

    Quote Originally Posted by metalgimp View Post
    I get my audio to work consistently. It doesn't work on YouTube, and VMWare Player can't pick up the device.

    Log: http://www.alsa-project.org/db/?f=95...ac1da535c35af5

    Specifics:
    1) I can rearrange the devices from the audio (Kmixer) icon and select which work, but the default and all the HDMI ones don't work.
    > HDA Intel PCH (ALC269VC Analog)
    If we assume a good install and if audio does not work, then it appears the hardware audio codec was identified as an ALC269VC. It is possible to try to tune that by forcing an audio configuration upon the start of the alsa driver. There is a list in the alsa documentation for the alc269, which is this:
    Code:
    ALC269/270/275/276/28x/29x
    ======
      laptop-amic        Laptops with analog-mic input
      laptop-dmic        Laptops with digital-mic input
      alc269-dmic        Enable ALC269(VA) digital mic workaround
      alc271-dmic        Enable ALC271X digital mic workaround
      inv-dmic        Inverted internal mic workaround
      lenovo-dock       Enables docking station I/O for some Lenovos
      dell-headset-multi    Headset jack, which can also be used as mic-in
      dell-headset-dock    Headset jack (without mic-in), and also dock I/O
    while the labels do not suggest so, its possible one of those (even if it says lenovo, or dell) may work better with your PC.

    I recommend if sound does not work after a re-install that you raise a bug report, and also possibly try forcing one of those codes. I can help you with the technique as to how the codes are applied.

  5. #5

    Default Re: Audio not working on Asus X750J

    Ok, tell me what to do. The list of drivers... do I redirect the module loader to load one of those?
    -Sean

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,569
    Blog Entries
    38

    Default Re: Audio not working on Asus X750J

    Quote Originally Posted by metalgimp View Post
    Ok, tell me what to do. The list of drivers... do I redirect the module loader to load one of those?
    -Sean
    1st BEFORE trying ANY of what I have below, you should go to YaST and install pavucontrol application. Then launch that application, and try to use it to tune your audio. I provided some guidance here on that in a blog: https://forums.opensuse.org/entry.ph...th-pavucontrol. Its important IMHO to try this before otherwise wasting your time.

    Only if no success there you could try different codecs. The idea would be to try each and every one of those codes, one at a time, with a test in between each one.

    For example, lets consider " alc269-dmic " .

    To do such a test, with root permissions and your favourite text editor, go into your PC's /etc/modprobe.d/50-sound.conf file, and at the START of that file, add a line which is (but without the quotes): "options snd-hda-intel model=alc269-dmic" , save the change.

    Then restart your PC, and test.

    If that does not work, edit the 50-sound.conf file and try another code instead of alc269-dmic. ie for example to try now the codec "laptop-amic" , replace that 1st line with: options snd-hda-intel model=laptop-amic , save the change, reboot and test.

    If all the testing is complete and NONE worked, then remove that first line and restore everything back to the way it was when you first started.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •