Results 1 to 4 of 4

Thread: Realtek ALC1150 alsa driver problem

  1. #1

    Default Realtek ALC1150 alsa driver problem

    There are many threads on the internet regarding the Realtek ALC1150 driver and alsa, with most ending up buying some other soundcard. ;-)

    I'm running 13.1 64bit on intel iron, specifically the supermicro X10SAE. I have successfully run the Realtek 5.18 driver tarball, well presuming successful means it looks like the driver was installed. [Some would say success means it actually works.]

    Regarding the Realtek driver, here are the tricks to get the installation to run to completion. First, the driver is found here:
    http://www.realtek.com.tw/downloads/
    Go to high definition audio codecs, then pick the driver for linux driver 3.0 .
    The installation is the usual ./configure make make install. However the make will crash due to an error explained here:
    http://stackoverflow.com/questions/1...n-ubuntu-13-10
    The webpage is for an error with the wifi driver, but it is the same basic error. The make will indicate the line with the error. Just edit the text as explained on the webpage and the make will work. The driver installation requires the linux kernel source to be installed.

    Since I can't get the official Realtek driver to work, the alsa-users list suggested I reinstall the desktop kernel. Fortunately there is a thread on the opensuse forum specific to doing this, and the only successful thread I found on using the ALC1150 chip.
    http://forums.opensuse.org/showthrea...-OpenSuse-13-1

    However modprobe snd-hda-intel just locks up the terminal window until I control C out of it.

    Since it is easy to reinstall the Realtek driver with a "make install", I did that. The results are the same. The modprobe command just hangs.

    I ran the yast2 hardware sniffer with these results regarding sound:
    Code:
    20: PCI 03.0: 0403 Audio device
      [Created at pci.319]
      Unique ID: 3hqH.bQjzHrSTHK8
      SysFS ID: /devices/pci0000:00/0000:00:03.0
      SysFS BusID: 0000:00:03.0
      Hardware Class: sound
      Model: "Intel Audio device"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x0c0c
      SubVendor: pci 0x8086 "Intel Corporation"
      SubDevice: pci 0x2010
      Revision: 0x06
      Driver: "snd_hda_intel"
      Memory Range: 0xf0730000-0xf0733fff (rw,non-prefetchable)
      IRQ: 55 (54 events)
      Module Alias: "pci:v00008086d00000C0Csv00008086sd00002010bc04sc03i00"
      Driver Info #0:
        Driver Status: snd_hda_intel is active
        Driver Activation Cmd: "modprobe snd_hda_intel"
      Config Status: cfg=yes, avail=yes, need=no, active=unknown
    Note that the opensuse thread I referenced has dashes in snd-hda-intel rather than snd_hda_intel as shown in the hardware probe. However modprobe snd_intel_hda still locks.

    If I go to yast2 then sound, it indicates the drive is indeed snd-hda-intel. Atempting to run alsamixer yields "cannot open mixer: No such file or directory"

    If I go into yast2 then sound and delete the sound card then try to add one, I do find snd-hda-intel, but there are a number of choices for drivers. Since the X10SAE has 7 channel sound, I assume I need ICH7. Trying to add that soundcard (ICH7) then going to quick installation just locks up the sound installation so badly that only booting kills the process. I tried using kill -9 with no luck.

    I'm not completely sure the sound installtion is finding the new realtek driver or the default kernel driver. Nothing in the sound installtion indicated Realtek.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Realtek ALC1150 alsa driver problem

    I've also read of a number of users having problem with the ALC1150 in GNU/Linux.

    I recommend you don't waste any more time, but rather go straight to writing a bug report on openSUSE-13.1 having no audio with the ALC1150. There is guidance on writing bug reports here: http://en.opensuse.org/openSUSE:Submitting_bug_reports .

    Please run the following command:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    and then attach the created file /temp/alsa-info.txt.xxxxxx to the bug report (where xxxxxx is some number).

    You can use your openSUSE forum username and password when logging on to bugzilla.

    Please check the bug report every day or two. The bug report will get the attention of the openSUSE sound packager, who is also an 'alsa' developer. They may ask you to run various commands to try and fix the problem. If anyone in the GNU/Linux community (and not just openSUSE) can solve this, they can.

    Good luck.

    Thankyou.

  3. #3

    Default Re: Realtek ALC1150 alsa driver problem

    I'm going to bang my head against the wall a bit more with the realtek driver, but will go back to the official opensuse desktop kernel before filing a bug report. I found a flag in the realtek configuration file for suse installation, so I suspect they have worked on this a bit. No reply from Realtek support yet.

    The various threads on this chip have been interesting. Some put the audio on the hdmi port, which I have no easy way of checking. Some say the audio doesn't go out the "green" jack. This is across all flavors of linux.

  4. #4
    Join Date
    Jun 2008
    Location
    Amsterdam
    Posts
    57

    Question Re: Realtek ALC1150 alsa driver problem

    I am running 'vanilla' openSUSE 13.1 here with some standard OBS repositories like Packman (no Realtek drivers installed) and I seem to have the same audio device as you.

    Code:
    24: PCI 1b.0: 0403 Audio device
      [Created at pci.319]
      Unique ID: u1Nb.WcuVGGQpij0
      SysFS ID: /devices/pci0000:00/0000:00:1b.0
      SysFS BusID: 0000:00:1b.0
      Hardware Class: sound
      Model: "Intel Audio device"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x8c20 
      SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
      SubDevice: pci 0x855f 
      Revision: 0x04
      Driver: "snd_hda_intel"
      Driver Modules: "snd_hda_intel"
      Memory Range: 0xf7330000-0xf7333fff (rw,non-prefetchable)
      IRQ: 49 (683 events)
      Module Alias: "pci:v00008086d00008C20sv00001043sd0000855Fbc04sc03i00"
      Driver Info #0:
        Driver Status: snd_hda_intel is active
        Driver Activation Cmd: "modprobe snd_hda_intel"
      Config Status: cfg=yes, avail=yes, need=no, active=unknown
    My motherboard is "ASUSTeK COMPUTER INC Z87-PRO.Rev 1" and my audio jack is plugged into the front panel.

    Have you tried the solution as documented here in this forum?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •