Results 1 to 4 of 4

Thread: Button2 as chord

  1. #1
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    311

    Default Button2 as chord

    Just installed 13.1 on my laptop (Thinkpad X200s) which was running 12.2 for ages.

    All seems well except that the use of button1+button3 as button2 is not working. This is a serious problem as the middle button is not really working. It was OK on 12.2

    I run X with fvwm as window manager; no gnome or kde. Where should this be configured?

    ==John ff

  2. #2
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    311

    Default Re: Button2 as chord [SOLVED]

    OK found a solution on other Linux forum. Just surprised that the update did not preserve that option.

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Button2 as chord [SOLVED]

    Quote Originally Posted by jpff View Post
    OK found a solution on other Linux forum. Just surprised that the update did not preserve that option.
    and ...

    What was the solution???
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  4. #4
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    311

    Default Re: Button2 as chord [SOLVED]

    Quote Originally Posted by Fraser_Bell View Post
    and ...

    What was the solution???
    The answer is to edit /etc/X11/xorg.d.conf/11-ecdev.conf to read

    Section "InputClass"
    # Novell Bugs #597214, #780626, #843333
    Identifier "IBM TPPS/2 TrackPoint|ThinkPad USB Keyboard with TrackPoint"
    MatchProduct "TPPS/2 IBM TrackPoint"
    MatchIsPointer "on"
    Driver "evdev"
    Option "EmulateWheel" "on"
    Option "EmulateWheelButton" "2"
    Option "Emulate3Buttons" "on"
    EndSection

    Note penultimate line

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •