Results 1 to 3 of 3

Thread: What to change in order to keep master.cf in order

  1. #1

    Default What to change in order to keep master.cf in order

    I have modified /etc/sysconfig/postfix file to produce almost correct configuration. main.cf is fine but master.cf gets modified incorrectly to my needs. For some reason option

    Code:
    -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
    gets commented out every time I run (or yast runs) config.postfix. These options get to main.cf but not exactly the way I want. Also, if the option is commented out from master.cf the postfix does not work regardless what I have for this in main.cf.

    This probably is an easy case but cannot figure it out.. hope someone can help me out with this.

    I'm using dovecot instead cyrus so yast probably is out of the question. I'd like not to use yast for this as this moment but to manually configure to make sure I get what I want exactly.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: What to change in order to keep master.cf in order

    On 2014-01-19 19:16, paju2000 wrote:
    >
    > I have modified /etc/sysconfig/postfix file to produce almost correct
    > configuration. main.cf is fine but master.cf gets modified incorrectly
    > to my needs. For some reason option


    I normally use yast to get an initial configuration, then I switch to
    configure postfix on my own. You have to set this in
    "/etc/sysconfig/mail" this:

    MAIL_CREATE_CONFIG="no"

    to stop yast interfering.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3

    Default Re: What to change in order to keep master.cf in order

    Works! Excellent! Thanks for the tip.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •