Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: steam no sound AT ALL

  1. #1

    Angry steam no sound AT ALL

    hello,

    ive been looking for days about this issue. All i could find is people reporting about not having sound on valve games.

    but my issue is bigger. steam does not have any sound at all. no sound notifications when a new chat msg comes in etc.

    i have tried this so far:

    i have tried installing as suggested in other topics nspluginwrapper, alsa-plugins, gnome-media and pulseaudio.

    and to add the lines (one per try..) to the usr/bin/steam file:
    SDL_AUDIODRIVER=pulseaudio
    SDL_AUDIODRIVER=alsa audio
    SDL_AUDIODRIVER=dsp
    SDL_AUDIODRIVER=oss

    and if i add the line "SDL_AUDIODRIVER=[any sound service] steam" it makes my cpu go crazy and my pc unresponsive.

    running 13.1 x64

    thanks in advance

  2. #2

    Default Re: steam no sound AT ALL

    Quote Originally Posted by docpariolo View Post
    i have tried installing as suggested in other topics nspluginwrapper, alsa-plugins, gnome-media and pulseaudio.
    pulseaudio should be installed by default, and I don't see why gnome-media or nspluginwrapper should be needed for sound in steam...

    But check that you have alsa-plugins-pulse and alsa-plugins-pulse-32bit installed.

    and to add the lines (one per try..) to the usr/bin/steam file:
    SDL_AUDIODRIVER=pulseaudio
    SDL_AUDIODRIVER=alsa audio
    SDL_AUDIODRIVER=dsp
    SDL_AUDIODRIVER=oss

    and if i add the line "SDL_AUDIODRIVER=[any sound service] steam" it makes my cpu go crazy and my pc unresponsive.
    By default pulseaudio is used, which blocks every other application from using the sound card directly, that's why those things won't work.
    As written above, alsa-plugins-pulse and alsa-plugins-pulse-32bit should help with that as it redirects all applications to use pulseaudio instead of alsa directly.

    You could also try to disable pulseaudio in YaST->Hardware->Sound. Click on "Other..." and select "PulseAudio Configuration" for that.
    Does it work then after a reboot?

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,240

    Default Re: steam no sound AT ALL

    Starting steam with

    Code:
    SDL_AUDIODRIVER=alsa steam
    works for me.

    oS 12.3 64bit, -32 libs installed as per wolfi post.

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,240

    Default Re: steam no sound AT ALL

    Also, there's a lengthy thread on sound in steam linux forum, take a look.

    Some people report using RUNTIME=0 (or something similar) on startup works. I didn't try, as the above post solved my problem.

  5. #5

    Default Re: steam no sound AT ALL

    well installing all that makes so it works but everytime i start up a game, i have to make sure i run before killall pulseaudio. otherwise no sound.

    its somewhat inconvenient but i guess it comes with the territory (linux). hopefully this will be fixed in further updates.

  6. #6

    Default AW: Re: steam no sound AT ALL

    Quote Originally Posted by docpariolo View Post
    well installing all that makes so it works but everytime i start up a game, i have to make sure i run before killall pulseaudio. otherwise no sound.
    Installing all what?
    Please verify that you have alsa-plugins-pulse _and_ alsa-plugins-pulse-32bit installed. It _should_ work then with pulseaudio running.

    And, again, if you disable PulseAudio in YaST->Hardware->Sound you also would not have to kill it since it would not be running anyway...

  7. #7

    Default Re: AW: Re: steam no sound AT ALL

    Quote Originally Posted by wolfi323 View Post
    Installing all what?
    Quote Originally Posted by wolfi323 View Post
    alsa-plugins-pulse _and_ alsa-plugins-pulse-32bit installed.
    that
    Quote Originally Posted by wolfi323 View Post
    And, again, if you disable PulseAudio in YaST->Hardware->Sound you also would not have to kill it since it would not be running anyway...
    wont cause that other issues? i mean, doesnt everything uses pulseaudio? anyways, not a big deal. this was just for testing purposes. I find that, at least the games i tried (serious sam 3, painkiller hd, and l4d2) runs way better on my other windows computer. so no big deal if once in awhile i want to try out something i run that killall pulseaudio command.

    thanks for the info and tips.

  8. #8

    Default Re: steam no sound AT ALL

    Quote Originally Posted by docpariolo View Post
    i mean, doesnt everything uses pulseaudio?
    Not at all.
    That's why you need alsa-plugins-pulse (and alsa-plugins-pulse-32bit for 32bit programs on a 64bit system) to redirect all applications that use ALSA to pulseaudio instead.

    Pulseaudio, when it is running, blocks all other programs from accessing the soundcard. That's why program's _not_ using pulseaudio cannot output sound then.

    Btw, I don't even have pulseaudio installed here, and sound works fine. In every program I use.

  9. #9

    Default Re: steam no sound AT ALL

    interesting. ill give it a try.

    thank you again.

  10. #10
    Join Date
    Nov 2013
    Location
    Canadiana
    Posts
    461

    Default Re: steam no sound AT ALL

    On 01/19/2014 03:16 PM, docpariolo wrote:
    >
    > interesting. ill give it a try.
    >
    > thank you again.
    >


    If you still dont get it to work maybe you have to try
    http://forums.opensuse.org/showthread.php?t=494020


    --
    Was I helpful? Click that little star so that I can brag about it to my
    invisible friends
    Bring the Penguins Back! https://features.opensuse.org/316767

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •