Results 1 to 10 of 10

Thread: Webcam/skype making terrible noise all of a sudden

  1. #1
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Webcam/skype making terrible noise all of a sudden

    My skype works fine. Every now and then (though multiple times a day). Suddenly a huge and loud buss occurs. It's so bad I have to turn off my sound and shut down skype.

    I don't think it is related to skype though, but has something to do with webcam as well. Cheese is not storing images and I notice it occurs often together when I start up a webcam related application. I use opensuse 13.1 on dell xps 13. Never had problems with 12.3.

    Any ideas which logs I could check?

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Webcam/skype making terrible noise all of a sudden

    On 2014-01-17 19:06, Dorax wrote:
    >
    > My skype works fine. Every now and then (though multiple times a day).
    > Suddenly a huge and loud buss occurs. It's so bad I have to turn off my
    > sound and shut down skype.


    Perhaps: http://en.opensuse.org/SDB:Skype_Noise

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

  3. #3

    Default Re: Webcam/skype making terrible noise all of a sudden

    Quote Originally Posted by robin_listas View Post
    On 2014-01-17 19:06, Dorax wrote:
    >
    > My skype works fine. Every now and then (though multiple times a day).
    > Suddenly a huge and loud buss occurs. It's so bad I have to turn off my
    > sound and shut down skype.


    Perhaps: http://en.opensuse.org/SDB:Skype_Noise

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)
    Thank you for the link. It seems I have exactly this kind of issue.

  4. #4
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Re: Webcam/skype making terrible noise all of a sudden

    Thanks, I hope that is it, but it's not a crackling noise. It is a very loud beeping sound.

  5. #5
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Re: Webcam/skype making terrible noise all of a sudden

    Any other suggestions? Logs I can check? Skype is unusable and I need it for meetings at work. When somebody sends a chat, or sometimes without reason, the loud beeping starts. I close skype, open it again and when I get a call, the other person only hears noise. I have to reboot, then I have about 5 minutes before it starts again.

    Can I check libraries? Update something? I tried installing skype from their website and the 2 unstable packages from opensuse. All have the problem, so I am starting to think it is something with my libraries?

    Thanks for any advise.

  6. #6

    Default Re: Webcam/skype making terrible noise all of a sudden

    Quote Originally Posted by Dorax View Post
    Can I check libraries? Update something? I tried installing skype from their website and the 2 unstable packages from opensuse. All have the problem, so I am starting to think it is something with my libraries?
    Well, Skype is just not compatible with the latest PulseAudio included in 13.1.
    Have you looked at the link given above and run it with "PULSE_LATENCY_MSEC=60 skype"? That should cure that problem.

    Or try to disable PulseAudio in YaST->Hardware->Sound->Other->PulseAudio Configuration. You have to logout/login (or reboot) for this setting to have full effect.

  7. #7
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Re: Webcam/skype making terrible noise all of a sudden

    I just started skype with PULSE_LATENCY_MSEC=60 skype. Let's see how long it stays. Would be great! I will keep you posted!

    Dorien

  8. #8
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    140

    Default Re: Webcam/skype making terrible noise all of a sudden

    The post before this is the solution.

    Now how do I get skype to start automatically each time with:

    PULSE_LATENCY_MSEC=60 skype?

    ?

    Thanks.

  9. #9

    Default Re: Webcam/skype making terrible noise all of a sudden

    Quote Originally Posted by Dorax View Post
    The post before this is the solution.

    Now how do I get skype to start automatically each time with:

    PULSE_LATENCY_MSEC=60 skype?
    Edit the "Exec=" line in /usr/share/applications/skype.desktop.

    Or copy /usr/share/applications/skype.desktop to ~/.local/share/applications/ and edit it there. In this case you won't need root rights, and even reinstalling/updating the "skype" package won't overwrite your changes.

  10. #10

    Default Re: Webcam/skype making terrible noise all of a sudden

    PS: If you are using KDE, you can just use KDE's menu editor to edit the skype entry:
    Just right-click on the K-Menu icon and choose "Edit menu entries".

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •