Page 1 of 7 123 ... LastLast
Results 1 to 10 of 70

Thread: Ошибки виджета обновления и странная ситуация с репом packman

  1. #1

    Exclamation Ошибки виджета обновления и странная ситуация с репом packman

    Наконец-таки я понял почему виджет обновления не хочет обновлять систему (кстати apper тоже не хочет). Подозрения возникли еще когда на http://software.opensuse.org в поиске не нашелся lives, при этом в yast он у меня есть в репе packman. Далее расследование показало, что packman вообще не выводится в результатах поиска, и если программа присутствует только в нем она в поиске не находится. И вот тут проанализировав вывод ошибок виджета обновления я понял что он не хочет обновлять систему если в обновлении участвуют пакеты из packman (пишет типа "не найден кандидат на обновление"). При этом в yast никаких ошибок с обновлениями нет. В связи с этим вопрос: что за странная ситуация с репом packman? В вики вроде написано что он действующий. Я использую зеркало http://packman.inode.at/suse/openSUSE_13.1/, может нужно использовать другое?
    Будь мужиком, поставь Linux!
    ---------------------------------------------
    Опять забанен гуглом...

  2. #2
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    3,050
    Blog Entries
    1

    Default Re: =?UTF-8?B?0J7RiNC40LHQutC4INCy0LjQtNC20LXRgtCwINC+0LHQvdC+?==?UTF-8?B?0LLQu9C10L3QuNGPINCyINGC0LU=?=

    KOT040188 wrote:

    > Наконец-таки я понял почему виджет
    > обновления нехочет обновлять систему
    > (кстати apper тоже не хочет).


    Я полагаю, что эти средства используют только официальный репозиторий
    Update.


  3. #3

    Default Re: =?UTF-8?B?0J7RiNC40LHQutC4INCy0LjQtNC20LXRgtCwINC+0LHQvdC+?==?UTF-8?B?0LLQu9C10L3QuNGPINCyINGC0L

    Quote Originally Posted by Lazy_Kent View Post
    Я полагаю, что эти средства используют только официальный репозиторий
    Update.
    Они все репы используют как и yast. Но обновить не могут только пакеты из packman.
    Будь мужиком, поставь Linux!
    ---------------------------------------------
    Опять забанен гуглом...

  4. #4

    Default Re: Ошибки виджета обновления и странная ситуация с репом packman

    Как известно amarok требует для проигрывания некоторых форматов кодеки. Т.к. я устанавливал нужные мне пакеты в 13.1 вручную, а не сохраненным списком то кодеков у меня нет. Конечно amarok предложил их установить, но не справился с этим. Очевидно потому, что они ставятся из packman. Так я остался без кодеков и amarok! Здец, товарищи! Приплыли! Можно конечно поставить кодеки вручную, но я не знаю какие нужны пакеты!
    Будь мужиком, поставь Linux!
    ---------------------------------------------
    Опять забанен гуглом...

  5. #5
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    201

    Default Re: Ошибки виджета обновления и странная ситуация с репом packman

    Quote Originally Posted by KOT040188 View Post
    Как известно amarok требует для проигрывания некоторых форматов кодеки. Т.к. я устанавливал нужные мне пакеты в 13.1 вручную, а не сохраненным списком то кодеков у меня нет. Конечно amarok предложил их установить, но не справился с этим. Очевидно потому, что они ставятся из packman. Так я остался без кодеков и amarok! Здец, товарищи! Приплыли! Можно конечно поставить кодеки вручную, но я не знаю какие нужны пакеты!
    Неужели установка кодеков в один клик перестала работать!?

  6. #6

    Default Re: Ошибки виджета обновления и странная ситуация с репом packman

    Quote Originally Posted by e_dimas View Post
    Неужели установка кодеков в один клик перестала работать!?
    Сейчас не об этом. Ближе к теме К тому же amarok я думаю поставит только то, что нужно, а не все кодеки сразу.
    Будь мужиком, поставь Linux!
    ---------------------------------------------
    Опять забанен гуглом...

  7. #7
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    201

    Default Re: Ошибки виджета обновления и странная ситуация с репом packman

    Quote Originally Posted by KOT040188 View Post
    Ближе к теме
    По теме:
    Плазмоид обновление программ, явно сырой, если он вам нравится, и хочется заставить его работать правильно, надо обращаться к разработчику. Мне кажется разработчик этого плазмоида на этот форум не заглядывает.
    Quote Originally Posted by KOT040188 View Post
    думаю поставит только то, что нужно, а не все кодеки сразу
    Ну, если вы любите трудности!? Удачи.

  8. #8

    Default Re: Ошибки виджета обновления и странная ситуация с репом packman

    Quote Originally Posted by e_dimas View Post
    По теме:
    Плазмоид обновление программ, явно сырой, если он вам нравится, и хочется заставить его работать правильно, надо обращаться к разработчику. Мне кажется разработчик этого плазмоида на этот форум не заглядывает.

    Ну, если вы любите трудности!? Удачи.
    Не можете помочь так хоть внимательно читайте. Плазмоид и apper выдают одну и туже ошибку при обновлении пакетов из packman. Без packman обновление проходит нормально. Amarok выводит несколько иную ошибку, пытаясь загрузить кодеки из packman. Кто-нибудь знает в чем дело с packman? Надеюсь так более понятно.
    Будь мужиком, поставь Linux!
    ---------------------------------------------
    Опять забанен гуглом...

  9. #9
    Join Date
    Nov 2008
    Location
    Saint-Petersburg, Russia
    Posts
    1,146

    Default Re: Ошибки виджета обновления и странная ситуация с репом packman

    Quote Originally Posted by KOT040188 View Post
    Наконец-таки я понял почему виджет обновления не хочет обновлять систему
    Нет, не поняли. У вас предпосылка неверная.
    Quote Originally Posted by KOT040188 View Post
    Подозрения возникли еще когда на http://software.opensuse.org в поиске не нашелся lives, при этом в yast он у меня есть в репе packman. Далее расследование показало, что packman вообще не выводится в результатах поиска, и если программа присутствует только в нем она в поиске не находится.
    И не находилась никогда, и не найдётся никогда. Поиск на software.o.o ищет только в репозиториях на download.o.o (собственные репозитории проекта openSUSE), а Packman - это дружественный, но сторонний проект.
    Quote Originally Posted by KOT040188 View Post
    В связи с этим вопрос: что за странная ситуация с репом packman? В вики вроде написано что он действующий. Я использую зеркало http://packman.inode.at/suse/openSUSE_13.1/, может нужно использовать другое?
    С ним всё в порядке, это с вами что-то не так.
    "Лучше молчать и прослыть дураком, чем открыть рот и развеять все сомнения." Марк Твен.

  10. #10
    Join Date
    Nov 2008
    Location
    Saint-Petersburg, Russia
    Posts
    1,146

    Default Re: Ошибки виджета обновления и странная ситуация с репом packman

    Quote Originally Posted by KOT040188 View Post
    Как известно amarok требует для проигрывания некоторых форматов кодеки. ... Конечно amarok предложил их установить, но не справился с этим. Очевидно потому, что они ставятся из packman.
    Совершенно неочевидно. Чтобы использовались кодеки из Packman, нужно ставить сам Amarok из Packman.
    Quote Originally Posted by KOT040188 View Post
    Так я остался без кодеков и amarok!
    Исключительно в результате собственного бездействия.
    Quote Originally Posted by KOT040188 View Post
    Можно конечно поставить кодеки вручную, но я не знаю какие нужны пакеты!
    Они установятся по зависимостям при установке amarok.
    "Лучше молчать и прослыть дураком, чем открыть рот и развеять все сомнения." Марк Твен.

Page 1 of 7 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •