Results 1 to 8 of 8

Thread: nvidia graphic driver problems after 12.3 -> 13.1 update

  1. #1

    Default nvidia graphic driver problems after 12.3 -> 13.1 update

    I finally overcame my fears of updating to Opensuse 13.1. Sadly my worries became true and something is not working after the update, mainly my Nvidia graphic driver is not installed anymore.

    For the record I updated via 'zypper dup'.
    So I downloaded the driver again and now i experience problems with the installation. This is the one I wanna install: NVIDIA-Linux-x86_64-260.19.12.run

    First it said that some kind of X Server is running and therfore it can`t install it. I solved this with doing 'sudo init 5', but now I get another error:

    Code:
    The kernel header file '/lib/modules/3.11.6-4-desktop/build/include/linux/version.h' not exist. The most likely reason for this is that the kernel files in '/lib/modules/3.11.6-4-desktop/build' have not been configured.
    http://imgur.com/N7JQXHG

    Has anybody an idea how to solve this?

    I use Opensuse 13.1 KDE.

  2. #2

    Default Re: nvidia graphic driver problems after 12.3 -> 13.1 update

    Quote Originally Posted by JakobAbfalter View Post
    I finally overcame my fears of updating to Opensuse 13.1. Sadly my worries became true and something is not working after the update, mainly my Nvidia graphic driver is not installed anymore.
    Yes, because of a new kernel.
    You have to reinstall it after an upgrade.
    Or install it from the nvidia repo, then you can upgrade it along with the rest of the system when calling "zypper dup".

    So I downloaded the driver again and now i experience problems with the installation. This is the one I wanna install: NVIDIA-Linux-x86_64-260.19.12.run
    Don't install that. It won't work as it is far too old.

    What graphics card do you have?

    Download either the latest 331.48 or the older 304.117 depending on that.

    Or just add the nvidia repo and install it from there. This way you would even get updates automatically and won't have to reinstall the driver after a kernel update.
    http://en.opensuse.org/SDB:NVIDIA_drivers

  3. #3

    Default Re: nvidia graphic driver problems after 12.3 -> 13.1 update

    Thank you the 331.48 version of the driver worked

  4. #4
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: nvidia graphic driver problems after 12.3 -> 13.1 update

    wolfi323 wrote:

    >
    > JakobAbfalter;2616825 Wrote:
    >> I finally overcame my fears of updating to Opensuse 13.1. Sadly my
    >> worries became true and something is not working after the update,
    >> mainly my Nvidia graphic driver is not installed anymore.

    > Yes, because of a new kernel.
    > You have to reinstall it after an upgrade.
    > Or install it from the nvidia repo, then you can upgrade it along with
    > the rest of the system when calling "zypper dup".
    >
    >>
    >> So I downloaded the driver again and now i experience problems with
    >> the installation. This is the one I wanna install:
    >> NVIDIA-Linux-x86_64-260.19.12.run

    > Don't install that. It won't work as it is far too old.
    >
    > What graphics card do you have?
    >
    > Download either the latest 331.48 or the older 304.117 depending on
    > that.
    >
    > Or just add the nvidia repo and install it from there. This way you
    > would even get updates automatically and won't have to reinstall the
    > driver after a kernel update.
    > http://en.opensuse.org/SDB:NVIDIA_drivers
    >

    Where did you find a 48 version? I can only find the 38 version even
    looking at the Beta drivers on Nvidia website.

    Thanks
    --
    openSUSE 13.1(Linux 3.11.6-4-desktop x86_64|
    Intel(R) Quad Core(TM) i5-4440 CPU @ 3.10GHz|8GB DDR3|
    GeForce 8400GS (NVIDIA-Linux-x86_64-331.38)|KDE 4.12.0


  5. #5

    Default Re: nvidia graphic driver problems after 12.3 -> 13.1 update

    Quote Originally Posted by upscope View Post
    Where did you find a 48 version? I can only find the 38 version even
    looking at the Beta drivers on Nvidia website.
    That was a typo.
    It should have been 331.38, that's the latest one.

  6. #6
    Join Date
    Jun 2008
    Location
    Moses Lake, WA. USA
    Posts
    474

    Default Re: nvidia graphic driver problems after 12.3 -> 13.1 update

    wolfi323 wrote:

    >
    > upscope;2616875 Wrote:
    >> Where did you find a 48 version? I can only find the 38 version even
    >> looking at the Beta drivers on Nvidia website.
    >>

    > That was a typo.
    > It should have been 331.38, that's the latest one.
    > Thats what I thought. Its been running since Tuesday with no error

    That's what I thought. its now been four days with no issues (kmail and
    Akonadi). Last night I went to KDE 4.12.1. Still good.

    Thanks for all your help.
    --
    openSUSE 13.1(Linux 3.11.6-4-desktop x86_64|
    Intel(R) Quad Core(TM) i5-4440 CPU @ 3.10GHz|8GB DDR3|
    GeForce 8400GS (NVIDIA-Linux-x86_64-331.38)|KDE 4.12.1


  7. #7
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    990

    Default Re: nvidia graphic driver problems after 12.3 -> 13.1 update

    This driver (331.38) doesn't build with the 3.13 kernel. The installer says it can't find nvidia.ko. Come to think of it, it doesn't install with the 3.12 kernel either.

    Has anyone else got it to work with these kernels?

  8. #8

    Default Re: nvidia graphic driver problems after 12.3 -> 13.1 update

    Quote Originally Posted by pilotgi View Post
    This driver (331.38) doesn't build with the 3.13 kernel.
    That's correct.

    A patch is available here:
    http://cvs.rpmfusion.org/viewvc/rpms...ee&view=markup
    That's supposed to make it work with kernel 3.13, but I cannot guarantee you anything. Haven't tried it myself...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •